www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit Schaltung


Autor: dicke Möpse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
habe mit meiner Schaltung (siehe Anhang) ein Problem...
und zwar funktioniert die Schaltung nur so wie sie soll,
wenn ich die blaue Leitung nicht anklemme
und dann die spannung zwischen den xy pkten messe,
(grüne leitung)
erkennt man deutlich wie die spannung immer von 0V auf +5V ansteigt und
wieder abfällt....
also so wie es soll, nur da dann ja die +12V versorgung abgeklemmt
ist,
liegt die rote Leitung ja nicht so wie sie soll an +12V
sondern nur an +5V die vom uc kommen......

wie kann es nun also sein, dass die Spannung bei konstant
bei 12V liegt und nicht ansteigt und abfällt, wenn ich den blauen draht
anklemm ???



DANKE !!!!

Autor: dicke Möpse (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hier das schaltbild

Autor: Johannes Raschke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Folgende Infos fehlen:

Dein Name
Transistortyp
Wicklungswiderstand
Wert der Basis-Vorwiderstände

Wenn der Transistor nicht weit genug aufgesteuert wird und der
Wicklungswiderstand gering ist, wird bei dauerhaft eingeschaltetem
Transistor fast sämtliche Spannung am Halbleiter abfallen. Schau' Dir
doch mal die Spannung im Schaltmoment mit einem DSO an.

Autor: Neuling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Widerstände:          1 kOhm
Transistoren:         BC639 (NPN)
Dioden:               1N4148
Wicklungswiderstände: ~50 Ohm

was ist bitte ein DSO ??

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Digital Storage Oscilloscope (Speicheroszi in digital)

Autor: Neuling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm woher soll ich son ding nehmen wenn nicht stehlen ??

bin student, mein kontostand ist immer knapp unter 0,00 EUR,
kennt ihr doch sicherlich ?!

aber zurück zu meinem problem

Autor: Magnus Müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sich deine (aufgebaute) Schaltung so verhält, wie du es schilderst,
hast du die Transistoren definitiv falsch angeschlossen!

Im Anhang findest du die korrekte Pinbelegung.

Gruß,
Magnetus

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach so... alternativ wäre noch folgendes denkbar:

Transistoren (eigentlich) korrekt angeschlossen, aber die Emitter sind
nicht mit GND verbunden.

Gruß,
Magnetus

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Johannes Raschke:

ist die technische Entwicklung wirklich schon so weit fortgeschritten,
daß man zur Funktionsprüfung eines simplen Relaistreibers ein DSO
braucht???

Ich behaupte mal, Grundkentnisse über Stromkreis, Transistor, das
Ohmsche Gesetz sind merklich kostengünstiger und sinnvoller.

Sorry, aber ich bewundere immer wieder, wie statt Grundlagenwissen zu
benutzen mit Kanonen auf Spatzen geschossen wird.

Ansonsten wurden schon alle Hinweise gegeben.

Gruß aus Berlin
Michael

Autor: Neuling (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
doch doch ist alles soweit korrekt angeklemmt,
hab mal nen foto davon gemacht, vielleicht könnt ihr da was drauf
erkennen ??

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Würde behaupten dass die Transistoren überfordert sind. Steck' doch
Testweise mal MOSFETs rein, müsste gehen.

Autor: Neuling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm welche schlägst du vor ??

habe leider keine und müsste die erst ma ordern... :(
am besten wäre reichelt.de
welche kannst du mir da ausm sortiment empfehlen ??

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn überfordert, dann aber von der Verstärkung her. Oder die 50 Ohm
stimmen nicht.
Ich würde einfach mal 2 von den BC639 als Darlington schalten und es
damit versuchen.

Ansonsten: Vielleicht hat ja eines der Kabel keinen/schlechten Kontakt
im Steckbrett. Wenn die älter sind leiern manche etwas aus.
Die Freilaufdioden würde ich übrigens etwas großzügiger dimensionieren.
1N4148. Wahrscheinlich gehts auch damit, aber ich würd mich nicht drauf
verlassen.

Sebastian

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe immer ein paar BUZ11 rumliegen, die sind für solche Tests perfekt.

Autor: Neuling (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
leider weiß ich nicht wie man die als darlington schalte google da aber
gleich ma und wenn ich nichts find meld ich mich...

kabel sind bestimmt nicht ausgeleiert, das ist erst die 3te schaltung
die ich damit aufgebaut habe.....
schelchten/keinen kontakt schließe ich aus, habe durchgemessen....
versuche es gleich mal 2 der 1N4148 in Reihe zu schalten, vielleicht
hilft das ja weiter,

sonst hätte ich noch folgende Dioden:
 2x BYV 27/200
15x 1N 4001

die 50 Ohm stimmen schon, das ist jeweils der Widerstand einer Spule
bis zur Mittenanzapfung.

vorne habe ich den Widerstand auf 1 kOhm,
vielleicht ist der auch zu groß, das da kaum ne Verstärkung zu stande
kommt ??

so habe auch was zum darlington gefunden siehe anhang....
soll ich das dann so wie auf dem bild im anhang verschalten und für die
D1 halt entweder:

1)  2x 1N 4148
2)  1x BYV 27/200
3)  1x 1N 4001

nehmen ??

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nehmen wir mal einen Einzelkreis.

Bei 1k Basiswiderstand können max. (4,7V-0,7V)/1k = 4mA fließen.
4,7V als max. H-Pegel am AVR angenommen und 0,7V als Ube.

4mA /3 = 1,3mA als Rechenwert für 3-fache Übersteuerung des
Transistors, damit er sicher in die Sättigung kommt.

12V/50Ohm = 240mA Spulenstrom- und damit Kollektorstrom.
240/1,3 = 184 als Mindestverstärkung - paßt nicht, mit mehr als 50
würde ich bei einem kleinen Transistor und 240mA Kollektorstrom nicht
rechnen.
Angegeben ist im Datenblatt 25...250 bei Ic = 150mA und Impulssteuerung
auf Vce 2V. Alles zu knapp auf den ersten Blick.

Basiswiderstand auf Minimum verringern, also (4,5V-0,7V)/15mA = 250,
also 270 Ohm.

Ansonsten Darlington oder anderen Transistor oder FET.

Das gilt jetzt alles nur für eine statische Ansteuerung, dynamisch
sieht es noch anders aus.

Gruß aus Berlin
Michael

Autor: Neuling (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Michael,
danke für deine ausführliche beschreibung,
leider habe ich auch schon probiert einen geringeren widerstand zu
nehmen, hatte einmal einen 100Ohm eingesetzt und einmal einfach ne
brücke dahingesetzt....
hat beider nicht funktioniert...
ich denke ich komme nicht drumherum, meine BC639 als Darlington zu
verschalten und es mit anderen dioden zu probieren...

wenn ich die BC639 durchmesse, haben die alle hfe von um die 140 !!

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

naja, 100Ohm dürften dem AVR weh tun (maximaler Strom bei H!) und eine
Brpcke dürfte zum Todesfall für AVR Portpin und/oder BE-Strecke des
Transistors werden, weil es dann garkeine Strombegranzung gibt.
hfe vermutlich gemessen mit üblichem Multimeter, da wird bei ca. 1mA Ic
gemessen. Bei höheren Strömen ist hfe geringer.

Wie steuerst Du den Kram im Moment an? Impulse? Welches
Tstverhältnis/Frequenz? Dynamisch kommt die Induktivität zum Tragen, da
ist das Verhalten sowieso noch anders.

Trenn den Basiswiderstand vom AVR ab und lege ihn zum Test an die 5V.
Am Kollektor sollte dann die Spannung von Deinen 12V gegen 0 gehen,
wenn die sich garnicht ändert, ist der Transistor kaputt...
Wenn sie zwar absinkt, aber Uce nicht klein genug wird (<0,5V) paßt
Ansteurung/Transistor/Verstärkung nicht.

Mach es nicht zu lange, nur zum Messen, wenn der Transistor nicht genug
durchgesteuert wird, verheizt er sonst eine ungesunde Verlustleistung.

Gruß aus Berlin
Michael

Autor: Johannes Raschke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Michael: DSO braucht man nicht, aber viele hier haben sicher die
Möglichkeit, bei der Arbeit oder in der Uni mal eines zu benutzen. Es
ersetzt kein Grundwissen, beschleunigt mitunter aber die Fehlersuche.
Zugegeben, manchmal verlängert es dieselbe auch...

@Neuling:
Nur mal eine simple Frage: Ist das GND-Potential von AVR und
Transistoren überhaubt das gleiche? Die Massen müssen verbunden sein!
Ich nehme mal an, dafür ist die grüne Leitung links oben da.
Auch wenn Michael gezeigt hat, dass die Transistoren nicht optimal
sind, solltest Du eigentlich etwas sehen, bzw. sollte der Motor
zucken.
Was ist denn das überhaubt für ein Motor? Ich habe noch nie einen
Schrittmotor mit solchem Anschluss gesehen, immer nur mit 2 Spulen,
teilweise mit Mittelabgriff. Die hatten dann 4 bzw. 6 Leitungen.
Sind bei Deinem Motor die Mittenabgriffe der Spulen intern verbunden
(rote Leitung)?

Testweise würde ich eine der Motorwicklungen durch einen 1k Widerstand
ersetzen. Geht es dann immer noch nicht, die Basis des Transistors mal
über 1k mit den +12V verbinden. Der sollte dann richtig leiten. AVR
vorher abklemmen.


Wenn alles nicht geht, sind wohl die Transistoren kaputt.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Johannes Raschke:
>...manchmal verlängert es dieselbe auch...
:-))

naja, war auch von mir eher eine allgemeine Anmerkung.
Ich habe eben manchmal hier beim Lesen das Gefühl, daß schnell eine
Schaltung zusammengesteckt wird, Zusammengesucht aus Teilen anderer
Schaltungen, wo man meint, es müßte so gehen.
Habe ich früher nicht anders gemacht, mache ich durchaus auch heute
noch so. Geht natürlich oft nicht, auch bei mir. ;)
Dann kommt eigentlich die Analyse, was eigentlich meiner Meinung nach
passieren müßte und das gezielte Messen und Suche der Ursache.
Inclusive Studiom von Unterlagen und Datenblättern usw.
Heute geht das Dank Internet schnell, "Google hilft".
Früher hatte man meist gezwungernermaßen Zeit zum drüber Nachdenken,
weil die Bibliothek oder der Kumpel zum fragen nicht sofort greifbar
waren. Von Oszi oder gar DSO war sowieso nicht die Rede. ;)
Heute habe ich oft das gefühl, daß man eben dank Internet zu schnell
fragen kann oder dank besserer Verfügbarkeit von Technik lieber einen
DSO kauft als ein Buch. ;-))))
Ist alles keineswegs böse gemeint.
Mein erster Z80-Rechner incl. Textgrafikkarte in "Plain-TTL" hat nie
einen Oszi gesehen.
War vermutlich auch besser, wenn der seine Taktflanken gesehen hätte,
der hätte nie wieder einen Ram-Zugriff gemacht...

Gruß aus Berlin
Michael

Autor: HomerS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Uni kann ja wohl nicht sein.

Sieht nach Stepper aus, aber wie soll der drehen?


Blaue Leitung weglassen? Was soll das?


Dioden  zeigen nach +12V, wennse denn Freilaufdioden sein sollen.


LERNE mal einen Schaltplan so zu zeichnen, dass ma erkennt was
passieren soll.#


ts

Autor: Magnus Müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
>> Sieht nach Stepper aus, aber wie soll der drehen?

Indem der Schrittmotor von einen Contoller über eine geeignete Endstufe
(daran wird hier gerade gearbeitet!) angesteuert wird.


>> Blaue Leitung weglassen? Was soll das?

"dicke möpse" (gewöhnungsbedürftiger Name) versucht halt in
experimenteller Weise den Fehler einzugrenzen. Immerhin hat er schon
einmal versucht, selbst etwas herauszufinden - im Gegensatz zu vielen
anderen Anfängern, die einfach (sinngemäss) schreiben: "Hab hier ne
Schaltung, die nicht funktioniert... bin auch zu faul selbst was daran
zu machen... also macht ihr das für mich!".


>> Dioden  zeigen nach +12V, wennse denn Freilaufdioden sein sollen.

Das tun sie doch! Oder?


Ich hoffe mal, dass "dicke möpse" nix dagegen hat, wenn ich mal einen
"sauberen" Schaltplan hier für ihn einstelle ;)

Gruß,
Magnetus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.