www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Webserver Problem ENC28J60 & avrETH1


Autor: Yves Däschle (yvesdaeschle)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Zusammen,

hab wieder ein Problem. Und zwar will ich einfach mit dem Code von 
avrETH1 einen Webserver machen, der mir eine simple "Hello World" Seite 
anzeigt. Dies funktioniert nun auch soweit. Das Problem ist nur, dass 
wenn ich sie mehr als 2mal aktualisieren will, dass dann nichts mehr von 
dem controller kommt. Es ist dann so ein 5s Timeout. Nach einem Reset 
geht es dann wieder!

Hab meine httpd.c angehängt. An der tcp.c wurde soweit nichts geändert.
(Code genommen von: http://avr.auctionant.de/avrETH1/)

Kann mir vielleicht jemand helfen?

Wenn mehr Informationen benötigt werden einfach Bescheid geben!

Danke, Gruß
Yves

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.