www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Fehlermeldung bei Ponny


Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yo,da bin ich wieder.

Jetzt hab ich zwar den Controller (Mega-16-16) und mir auch alles
zusammengestzt (Den von AVR-Prog für die Serielle.)


Aber mit AVR-Prog bekomme ich beim Setup noch nen OK aber er zeigt
error wenn ich was übertragen will bzw. einfach den Controller
auslese.

Beim Pony erkennt er den Controller (Damit dürfte die Hardware ok sein)
richtig aber es kommen dauernd Error -24 wenn ich was übertragen will.

Ein erhöhen der Wartezeiten wie in der Anleitung beschrieben hilft auch
nix.

Auch verschiedene Quarze (4.8.16 Mhz) oder garkeiner helfen nicht.


Das Serielle Kabel ist nur nen Meter lang und von der Schaltung am Ende
geht auch nur ein 20cm langes Flachkabel zum Controller.


Hat einer ne Idee woran es liegen könnte bzw. was ich falsch mache ?

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Korrektur:


Ich hab in der Faq verkehrt gelesen.
Es ist zwar Fehler "24" aber derr hat nix mit de Obigen Sachen zu
tun.

In der Dokumentation steht dazu nur folgendes:
------------------
Q: I can't read or write AT90S1200 device. I receive the error
message:
   "Device missing or unknown device -24"

A: Select "Ignore" button, if the final message is "Write
succesful" you have a sample that
   doesn't reply to the identify command. It seems that early devices
don't reply to this command.
----------------

Schön und gut aber das dürfte eigentlich nicht auf nen Mega 16
zutreffen.

Weiß denn wirklich keiner was ?

Autor: raoul4 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bei mir was auch so,
ich hab meine erste(!!!) platine mit nem 4433 bestückt, und es ging
natürlich nicht! dann habe ich alles neu gekauft, und auch nen anderen
MC (den 90s8535) und plötzlich ging es. wenn du bei der fehlermeldung
in pony prog auf ignorieren klickst, sieht es nur so aus, als würde er
ihn auslesen. also, alles neu kaufen!?!?

mfg raoul4

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab hier 2 Mega16 und die Schaltung auch schonx-mal überprüft aber
die Elemente sind ok.

Vorsichtshalber hab ich nun alle Transis die ich hatte (BC547)
ausprobiert aber immernoch nix.

Die Signale auf der Seriellen und der Schaltung hab ich auch auffem
Oskar betrachtet aber das sieht alles Sauber aus.

Um dann der Paranoia noch etwas Futter zu geben hab ich mal eben ne 2.
Parition mit W98SE erstellt aber das Ergebnis bleibt das gleiche.

Ich bin gerade dabei nen Paralelles zu basteln (Bei 2 Widerständen kann
ja nu garnix schif gehen) aber langsam kommt mir der Gedanke hoch das
ich nen Kapitalen Fehler mache und den Wald vor lauter Bäumen nicht
sehe.

Autor: Ratber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yo,habs gestern noch fertig bekommen.

Erst wollte er nicht laufen dann bin ich mal von den Empfehlungen
abgegangen und hab die anderen Interfaces ausprobiert und siehe da es
geht.

Die Sereiellen laufen alle bei mir nicht also bleibe ich erstmal beim
Paralellen.

Topic kann geschlossen werden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.