www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT232R - kleines Problem


Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich habe mir gerade eine kleine Schaltung mit dem FT232R aufgebaut.
An RXD und TXD ist noch nix angeschlossen.
Im Moment soll es erst mal nur als USB - Seriell Adapter arbeiten.

- der Chip wird beim einstecken des USB Kabels erkannt.
- Treiberinstallation auch ok
- EEProm mit MProg programmiert

Das Problem ist eigentlich das meine Software den Adapter nicht erkennt.
Vom Prinzip soll mir der FT232R die seriellen Daten einfach zum Port TX 
"raushauen", ob was angeschlossen ist oder nicht, so wie es mein Orginal 
USB-Adapter auch macht.
Muß ich hier eine Brücke einlöten (RTS-CTS, DTR-DSR) oder so ?
Oder welche Einstellungen muß ich ändern.

Die Schaltung entspricht der im Datenblatt Seite 26 (ohne PIC)
Reset ist noch offen, den sollte ich doch sicher auch gegen Plus mit 
einem R legen?

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poste doch mal deinen Schaltplan.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Thobias.

Jetzt weiß ich leider nicht wie ich das machen soll :o(

Vom Prinzip ist jetzt erst mal nur der FT232R mit dem USB verbunden und 
die Spannung vom USB an VCC und VCCIO, sowie die 5 
Masseanschlüsse...und....Kondensatoren.
Ich wollte halt nur testen ob das mit dem seriellen Ausgang so geht.
Ich brauch keine Protokolle und vorerst keine Rückmeldungen ob das 
gesendete angekommen ist.

Mario

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also brücken brauchst du eigentlich nichts und /RESET kann offen 
bleiben.

> Vom Prinzip soll mir der FT232R die seriellen Daten einfach zum Port
> TX "raushauen"

Kannst du denn mit deiner Software den zugewiesenen COM-Port öffnen?

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Kannst du denn mit deiner Software den zugewiesenen COM-Port öffnen?

ja, soweit geht das. auch in der Hardwarsteuerung (Windows) ist alles 
ok.
Nur sobald ich etwas sende, erkennt er den Port nicht.
Achso mit dem Programm "HTERM" hier aus dem Forum kann ich auch nicht 
senden. Ich denke es fehlt einfach eine Rückmeldung.....???

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"erkennt er den Port nicht"

Kannst du das etwas näher beschreiben? Kommt eine Fehlermeldung?

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
hab gerade mal das Priogramm von FTDI "Seralizer" gestartet.
Da kommt als Fehler "Failed to initialize tester" .

HTERM bringt keinen Fehler und ich kann damit "Conecten"
Bei klick auf senden, scheint aber nix raus zu gehen, da keine Daten im 
unteren Feld erscheinen.

Autor: Tobias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erscheinen sie denn im "unteren Feld", wenn du TX und RX des FT232R 
miteinander verbindest?

Autor: Bjoern Buettner (tishima)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Hast Du überhaupt nach der installation und beschreiben mit MProg die 
Com Treiber installiert ???

gruß,
Bjoern

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Björn,

noch ein Treiber?
Das ist immer noch der, den ich auch vor dem "beschreiben" verwendet 
habe.
COM-Port und ein paar Werte (Baudrate......) kann ich hier einstellen.

TX und RX werde ich dan morgen mal verbinden.

Danke erst mal!


Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo.

Jetzt versteh ich gar nix mehr.
Ich habe nun RXD und TXD vom FT232R verbunden.
Beim Test mit HTerm werden im oberen Fenster die gesendeten Daten 
angezeigt. Das untere Fenster (Ausgang) bleibt leer fragend guck.

Die andere Software erkennt den (COM-)Port immer noch nicht.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mist, hab was falsch gemacht mit Hterm.
Ich bin auf ASEND gegangen, statt mit ENTER zu senden.
Also das geht schon mal. Nur die LED die ich als TX RX LED definiert 
habe tut es auch nicht, aber das kontrolliere ich gleich noch mal.
Mit anderer Software geht es halt immer noch nicht.

Autor: Mario (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Weiterer Statusbericht.

Nein, es liegt nicht an dem FT232R.
Ich habe jetzt verschiedene Software zum ansteurn getestet und damit 
fuktioniert es. Nur mit der Software die ich benutzen will geht es 
nicht, wobei diese mit einem Handelsüblichen Adapter funktioniert.
Der Software die ich verwenden will ist die Baudrate egal.
Ich denke hier fehlt irgend eine Rückmeldung des Adapters den die 
Software haben will ??????????????

Mario

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.