www.mikrocontroller.net

Forum: Platinen Problem mit PCB-Pool Target und Massefläche


Autor: Layoutanfaenger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe mit PCB-Pool Target einen kleinen Funktionsgenerator mit XR8038 
und Verstärker konstruiert.
Nun bin ich dabei die Platine zu layouten.
Dabei hat der Autorouter und vor allem Autoplazierer von Target 
allerdings mehrmals totalen Mist gebaut :(
Nachdem ich nun alle Bauteile händisch sinnvoll plaziert habe, konnte 
auch der Autorouter eher etwas brauchbares erzeugen.
Allerdings weigert er sich beharrlich einige sehr sinnfrei Routes zu 
löschen :(
Z.B. war eine Leitung um ein Pin "gewickelt" worden, so das es nicht 
geroutet werden konnte (siehe Anhang), doch jetzt weigert sich Target 
beharrlich den noch verbliebenen Bahnteil zu markieren :(
Von der Unfähigkeit GND Pins, die am GND Signal hängen, mit der 
Massefläche zu verbinden mal ganz abgesehen ...
Wie's aussieht werde ich wohl wieder die gesamte Ebene löschen müssen 
und von vorne anfangen.
Ich habe jetzt mehrfach versucht nur mit Selektionen einzelne Signale im 
Autorouter zu arbeiten, doch das Ergebnis ist immer unbefriedigend.
Gibt es Tips, wie ich den Autorouter besser "füttern" kann ?
Oder ein Tutorial, wie ich händisch sinnvoll route ?
Ich hab' die Platine jetzt viermal neu gemacht und langsam keine Lust 
mehr.
Ist das komische Verhalten ein Bug, oder ein Bedienungsfehler ?
Danke !

P.S.: Mir ist gerade aufgefallen, das nachdem man "Vorschau" gedrückt 
hat, das Attachment-Feld leer ist !
Das sollte sinnvollerweise geändert werden, sonst hätte ich jetzt keinen 
Anhang mitgepostet !

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
poste einmal das Target File, damit man den Fehler lokalisieren kann

Autor: Karl heinz Buchegger (kbucheg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und vergiss den Autorouter gleich wieder.
Wenn du das händisch routest, wärst du schon längst fertig.

Autor: Blackbird (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Autorouter ist für kleine Projekte, wie oben angegeben, ganz 
brauchbar. Es erwartet doch wirklich niemand, das er alles auflöst, 
oder?
Es kommt beim Auto-Routen auf die Vorgaben an, wie Raster, 
Leiterbahnbreite, Ebene(n), Aura, BE-Abstände und -Anzahl, ausgewählte 
Signale, usw. Dann bringt er in Verbindung mit ein wenig Handarbeit, in 
mehreren Stufen, ganz ordentliche Ergebnisse - schneller als alles von 
Hand.

Der Autoplatzierer ist aber wirklich großer Mist, der schmeißt die BE 
wahllos auf die Platine.

Blackbird

Autor: Blackbird (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum eigentlichen Problem:
Es scheint ein Bug zu sein (Sicher bin ich mir aber nicht, es könnte 
auch eine fehlerhafte Vorgehensweise sein):
Wenn man Leiterbahnen aueinanderreißt, zieht, verschiebt, dreht ... und 
sie dann mit M1 markieren will, sind sie nicht erreichbar. Da hilft nur 
ganz raus ziehen oder alle nicht benutzten Ebenen wegschalten und die 
Leiterbahn mit einem Maus-Rechteck markieren. Dann erscheint sie 
markiert und man kann sie löschen, etc.

Das kann man verhindern, indem man Leiterbahnen löscht bevor sie 
auseinandergerissen werden.

Blackbird

Autor: Layoutanfaenger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Blackbird:
Danke für den Tipp, sobald ich alle Layer bis auf Kupfer unten ausblende 
geht's ;)
Scheint so das Target denkt ich will die Massefläche markieren / 
auseinanderreißen ...
Mal sehen wann ich dazu komme da weiterzumachen.

@ Karl heinz Buchegger:
Das hab' ich ja erstmal versucht, nur meine bisherigen Projekte sind 
halt Lochraster mit "Nähkästchen"-Verdrahtung (also zwanzig Layer 
Kupferlackdraht übereinander lol ).
Und ehrlich gesagt war's mir nicht möglich nachdem ich VCC und GND im 
Target verlegt hatte, die Signalleitungen ohne zig Brücken zu verlegen 
:(
Bei der Suche im Netz komme ich immer wieder auf Kurse zum bezahlen oder 
allgemeine Infos, aber kein gescheites Tutorial für's Routen von 
Platinen.
Wenn Du da gut Infos/Seiten hast, immer her damit ;)

Danke !

Autor: Thomas Strauß (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

es gibt die neue pcbpool-Version V12. Die ist naturgemäß kostenlos. Eine 
email-Adresse ist nötig, um den Link zum Downloaden zu erhalten. 
Außerdem muß man sich ein Password ausdenken. googlen: downloads pcbpool 
edition S7 oder so
ähnlich.

Thomas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.