www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit AT90S8515


Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

hab da ein Problem beim Programmieren des 90S8515. Der Baustein wird
von Programmer gar nicht erkannt. :-(
Gabs da nicht mal eine Serie von Atmel, bei der das SPIEN-Bit nicht
gesetzt war?
Hat jemand ne Idee, wie ich das hinbekommen kann? (Ist leider ein
SMD-Baustein, den ich eigentlich nicht wieder auslöten möchte.) Könnte
ich mittels Parallel-Programmer das Teil wiederbeleben? (Habe zum Glück
fast alle Pins auf Stiftleisten oder IC-Sockel rausgeführt.)
Benutze zum programmieren bis jetzt den ISP-Programmer aus der App-Note
AVR910 mit modifizierter Firmware (3.0). Der Programmer meldet sich
auch korrekt, schreiben tut er anscheinend!!! auch, nur beim Verify
bringt er ne Fehlermeldung.

Schon mal danke für eure Hilfe.


Gruß, ERDI - Soft.

Autor: Armin Kniesel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe auch den Programmer auf die V3 upgedatet, er schreibt angeblich
auch, nur beim Verify bringt er Fehler. Und ich habe das getestet,
geändert im Prozessor hat er nichts.
Da ist wahrscheinlich noch der große Bug in der V3.

Armin

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Er liest mir aber auch keine Controller-ID ein. Nur FF FF FF. Muß mal
den 1200er einbauen und gucken, was passiert. Ich hoffe nur, dass ich
nicht parallel programmieren muß. Hab nämlich gar keinen
Parallelprogrammer. Müßte ich mir dann erst bauen.
Was hast du denn alles getestet? Hast du nen µController programmiert,
beim Verify dann nen Fehler bekommen und das Proggi hat (in der neuen
Version) dann trotzdem funktioniert? Oder lief weiterhin das alte
Prog?

Vielleicht sollte man auch mal die V3.1 ausprobieren.

Autor: Milchknilch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab den mit PonyProg programmiert und hatte kein probleme. vieleicht
probierst du das mal  bevor du auslötest.

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann müsste ich ja nochmal nen Programmer bauen!! Da probiere ich doch
lieber erst mal den alten AT90S1200 mit der Firmware V2.3.
Hat schon mal jemand die V3.1 ausprobiert?

Autor: Milchknilch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok da hast du recht, allerdings ist  der Programmer für PonyProg (und
andere) wesentlich leichter und schneller aufzubauen, wie das LowCost!
:-D Teil von Atmel.

Autor: ERDI - Soft (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich das nicht schon hätte! :-) Soviel unterschied macht das aber
nicht, da ich sowieso ne Platine gemacht hätte. Egal für was. Und der
Atmel-Programmer gefiel mir wegen der Unterstützung aus dem AVR-Studio
heraus. (Der natürlich auch noch einfacher aufzubauen wäre, wenn man
statt des analogen Krimskrams nen MAX232 benutzen würde.)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.