www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik mc nicht gefunden


Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi
habe den "Atmel AVR ISP für STK200 und STK300" auf 
http://rumil.de/hardware/avrisp.html gebaut und einen atmega16 
angeschlossen nach den schaltplänen auf  "AVR-Tutorial - Benötigte 
Ausrüstung"
habe jetzt mit avrdude "avrdude" -p m16 -c stk200 -P lpt1 -U 
flash:r:"flash.hex":a
eingegeben
bekomme instantan die fehlermeldung
avr device not responding
initialization failed, rc=-1
woran liegt das?
und sollte das programmieren auch ohne externe stromversorgung 
funktionieren also nur über parallel port?

Autor: Reiner1967 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi und hallo,

die Zielschaltung sollte schon mit Strom versorgt werden, da der 
Programmieradapter aus dem Zielsystem versorgt wird, nicht aus dem 
Parallelport.

Gruß, Reiner

Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi
ich habe die spannungsversorgung scon angeshaltet :-)) wollte nur wissen 
ob es auch ohne gehen würde...
nichts desto trotz kommt ( mit spannungsversorgung) die fehlermeldung...

Autor: Philipp Burch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier's auch mal mit yaap. Es könnte auch an deiner Einstellung vom 
LPT liegen.
Und überprüf' mal ganz genau, ob beim Programmer alles gut ist, ich 
hatte da ganz am Anfang eine Brücke drin, das ergab die selbe 
Fehlermeldung...

Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was meinst du mit einstellung  des lpt ?
isp hat keine brücke...
kann ich den isp einzeln testen? also sagt mir das programm schon etwas 
wenn es den isp erkannt hat?

Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi nochmal
habe nochma alles nach brücken abgesucht und nichts gefunden ...
versorgungsspannung ist auch ueberall da....
muss ich erstnoch irgendwelche einstellungen machen? stichwort conf 
datei?

danke im voraus thomas

Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was mir noch einfällt
ich stecke den isp direkt an den pc ...da ist nicht igrgendeine etwaige 
kabelkreuzung eines verlängerungskabels mit eingerechnet oder?

Autor: mc nicht gefunden (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
noch ein post von mir :-))

hab an der schottky diode am ISP nen spannungsabfall von 0,2V ..Ist das 
normal? hab deshalb am IC noch 4,9V...sollte das langen oder gibts da 
probs?

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Reicht dicke!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.