www.mikrocontroller.net

Forum: Compiler & IDEs WinAVR 070101


Autor: Sardaukar (Gast)
Datum:
Angehängte Dateien:
  • preview image for 1.PNG
    1.PNG
    11,1 KB, 235 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nach der Installation des neuen WinAVR (WinAVR-20070101) erhalte ich im 
AVR Studio nun (mit dem selben Code der mit der Version WinAVR-20060421 
ohne Fehler funktioniert) folgenden Fehler (Anhang).

Das Hex-File wird ordnungsgemäß erstellt und funktioniert auch.

Weiß jemand was diese Meldung bedeutet bzw. wie ich die wegbekomme (die 
Info nach dem übersetzen, wieviel Speicher benötigt wird finde ich 
nämlich so praktisch ;-))

mfg

Autor: Elektrikser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fehler tritt bei AVR-Studio 4.12 auf. Es wird in der nächsten Zeit 
ein Update geben, wobei der Termin nicht feststeht. Hier ein Zitat vom 
Ersteller vom WinAVR Eric Weddington:
>>There is also an issue with the new binutils avr-objcopy program and
>>creating the EEPROM load file, that it required changes to the WinAVR
>>Makfeile Template. The new version AVR Studio will correctly handle this
>>in its internal Makefile generation, but 4.12 will report an error.

Gruß Elektrikser

Autor: Elektrikser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Sardaukar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein herzliches Dankeschön!

Autor: Ulrich Spizig (uli)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,


ich hab seit dem Update auf WINAVR070101 auch Probleme mit meinem AVR 
Studio.

Kompilieren geht ohne Probleme, allerdings funktioniert der Simulator 
nicht mehr.

Starte ich "Build&Run" krieg ich einen RunTime Error(siehe Bild im 
Anhang).

Hab zur Sicherheit WINAVR und Studio komplett deinstalliert und neu 
installiert(mit Service Pack). Trotzdem bleibt der Fehler bestehen.

Hat ausser mir jemand die gleichen Probleme?

Gruß
Uli
(falls es jemand was bringt: WIN XP war das böse Betriebssystem)

Autor: Sardaukar (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus,

ja, genau das selbe... :-/

mfg

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt WinAVR-20060421-install.exe installiert (letzte 
auffindbare Vorversion). Damit geht es wenigstens zusammen mit AVR 
Studio Version 4.12 Build 460.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.