www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik HIP 4081 Verständnisprobleme


Autor: Florian Peter (guschdldererste)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Ich baue eine Brückenschaltung mit N-Kanal Mosfets (BUZ11). Soll so 12V 
und ca. 2A schalten.
Hab mir jetzt mal den Brückentreiber HIP 4081 AIP gekauft und probier 
grad ein bisschen mit dem rum. Sollt viell dazu sagen, dass das meine 
erste Schaltung ist die ich bau, also noch nicht so viel, bzw. gar keine 
Erfahrung damit hab.
Ich hab den HIP mal aufgesteckt auf so ne Experimentierplatine um zu 
schauen was der so macht.
Hab an die PINs folgende Spannungen angelegt:

1.BHB: gar nix, da das nur für Bootstrapping nötig ist. Der Treiber kann 
sollte auch ohne Bootstrap funktionieren, wenn er statisch wie in diesem 
Fall betrieben wird.
2.BHI: ca. 6V --> logische 1
3.DIS: 0V --> enabled
4.Vss: Hab ich natürlich auf Ground gelegt.
5.BLI: 0V --> logisch 0
6.ALI: ca. 6V --> logisch 1
7.AHI: ca. 6V --> logisch 1
8.HDEL: nicht verbunden
9.LDEL: nicht verbunden
10.AHB: nicht verbunden, da Bootstrap

15.Vcc: 12V Betriebsspannung
16.Vdd: 12V Betriebsspannung

An den restlichen PINs der rechten Seite liegt sonst nichts mehr an, da 
würd ich dann meine FETs anschließen.

So wie ich das mir gedacht hab müsste doch jetzt ne Spannungsdifferenz 
von 12V ham an den PINs BHO-BHS und ALO-AHS, damit die Mosfets 
geschalten werden.
Hab an jedem PIN aber ca. 6V anliegen, außer an BHO, da liegen 12V an.
Warum? Was hab ich falsch gemacht?

Die ganzen Spannungen sind alle bezogen auf Vss!

Ich betreib die Schaltung erstmal ohne PWM, also mit ner konstanten 
Spannung. Erstens bin ich zur Zeit nicht an der Uni und hab deshalb 
keins zur Verfügung und zweitens will ich erstmal verstehen was ich mach 
bevor ich mich mit Delay-Widerständen und dem Bootstrap-Zeug rumschlag.

Hab das Datenblatt mit der PIN-Belegung mal angehängt.
Falls irgendwas unverständlich war, bitte nachfragen.
Hoff es kann mir jemand helfen! Vielen Dank schon mal!
Gruß Flo

Autor: alfsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ohne switching+bootstrap geht nur was, wenn xHS + xLS auf vss 
liegen, + xHB an vcc.
denk mal 5 min nach, was soll der ausgang ohne masseanschluss + vcc denn 
schalten??

Autor: Florian Peter (guschdldererste)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, leuchtet ein! Habs jetzt so gemacht wie du gesagt hast.
Hab jetzt aber nirgends ne Potentialdifferenz! Wie kann das sein?
Hier mal die PIN-Belegung:
1.BHB: 12V
2.BHI: ca. 7,5V
3.DIS: 0V
4.Vss: 0V
5.BLI: 0V
6.ALI: 7,5V
7.AHI: 7,5V
8.HDEL: 4,41V
9.LDEL: 4,41V
10.AHB: 12V

an xHO + xLO hab ich ca. 0,17V (nichts angeschlossen). An xLS + xHS 0V 
(sind mit Vss verbunden). An Vdd und Vcc hab ich 12V.
Müsste doch jetzt eigentlich ne Spannung messen zwischen den Pins 
BHO-BHS und ALO-ALS! Aber da liegt nichts an (außer den 0,17V)!

Hab mal die Application-Note angehängt!
Bin für jede Antwort dankbar!

MfG

Flo


Autor: alfsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
haste hdel ldel je zb 100kohm nach vss ?
siehe datenblatt, test:
VDD = VCC = VAHB = VBHB = 12V, VSS = VALS = VBLS = VAHS = VBHS = 0V, 
RHDEL = RLDEL = 100K

Autor: Florian Peter (guschdldererste)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja hab ich!

Autor: alfsch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tja, dann muss er...oder hast ihn gekillt?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.