www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Crumb128 Probleme bei der Inbetriebnahme


Autor: Orko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

wie der Titel schon sagt habe ich Probleme bei der Inbetriebnahme meines 
Crumb128 Modul.
Ich habe leider noch nicht soviel Erfahrung mit diesen Prozessoren, habe 
vorher nur mit Lego Mindstorm gearbeitet und zu Weihnachten den Crumb 
bekommen.
Nun zu meinem Problem:

Ich habe den Crumb mit 5V (Pin 21 an Con1, Pin 20 an Con2) sowie Masse 
(Pin22 Con1, Pin21 Con2) versorgt.
Am Crumb habe ich den CrispAVR-USB Adapter angeschlossen.
Ich habe den USB Treiber R2176.zip - FT232R Driver for Windows XP, 2000, 
Server 2003 installiert.
Mein Betriebssystem ist Windows XP Pro.

Anschliessend habe ich den Adapter über das mitgelieferte USB Kabel an 
den Computer (Notebook) angeschlossen.

1.
Der Adapter wird erkannt und im Gerätemanager angezeigt.
Die grüne Staus LED auf dem Adapter leuchtet.

Der Crumb wird allerdings nicht angezeigt. ????
Laut der Beschreibung sollte er im Gerätemanager als USB Gerät angezeigt 
werden.

2.
Der USB Adapter wird als Com 9 eingerichtet.

Mit dem Programm PonyProg kann ich aber nur Com 1- 4 auswählen.

Irgendwie komme ich nicht richtig weiter und hoffe das Sie mir einige 
Tips geben können.

Gruß Orko

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 1.
> Der Adapter wird erkannt und im Gerätemanager angezeigt.
> Die grüne Staus LED auf dem Adapter leuchtet.
>
> Der Crumb wird allerdings nicht angezeigt. ????
> Laut der Beschreibung sollte er im Gerätemanager als USB Gerät angezeigt
> werden.

Es wird ja auch nicht das Crumb128-Board als solches erkannt, sondern 
nur der FTDI-Chip (der COM-Port). Das ist normal.

> 2.
> Der USB Adapter wird als Com 9 eingerichtet.
>
> Mit dem Programm PonyProg kann ich aber nur Com 1- 4 auswählen.

PonyProg wird dir in diesem Zusammenhang sowieso nicht viel 
weiterhelfen.

Autor: anworter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe mit dem Modul keinerlei Erfahrungen, aber hier das, was aus den 
Schematics ersichtlich ist:

a) VCC und GND müssen jeweils nur einmal angeschlossen werden

b) überprüfe den RS232 Jumper auf dem Board

c) in WinAVR sollte avrdude zum flashen dabei sein



http://www.kreatives-chaos.com/artikel/winavr-tutorial



Viel Glück/Spaß/Erfolg noch

Autor: Orko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für Eure Antworten.

Habe dazu noch einige Fragen:

>> b) überprüfe den RS232 Jumper auf dem Board

Ich nutze doch die serielle Schnittstelle nicht sondern den USB 
Anschluss

>> c) in WinAVR sollte avrdude zum flashen dabei sein

Meinste ich sollte das benutzen?

Gruß Orko

Autor: Orko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin,

leider bin ich immer noch nicht weiter.

stehe da mit einem neuen crumb128 und versuche verzweifelt diesen 
irgendwie in betrieb zunehmen.
leider gibt es hier sehr wenig infos im netz.
hat noch irgendjemand ne idee oder selbst einen in betrieb genommen?
freue mich über jeden denk anstoss.
ansonsten werde ich das teil in die tonne tun.
selbst vom vertreiber gibt es keine infos.

gruß orko

Autor: Will gerne helfen... (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

habe für alle, die helfen möchten mal den Schaltplan als *.pdf 
angehängt.

Gruß, Thomas

Autor: Will gerne helfen... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
QOrko

was machen die LED´s auf dem Programmieradapter ?
....ist hier beschrieben:
http://www.chip45.com/index.pl?page=CrispAVR-USB&lang=de


Der Programmieradapter selbst hat keine Bedienelemente, die Bedienung 
erfolgt über die PC Software. Zwei Leuchtdioden auf CrispAVR-USB zeigen 
den aktuellen Betriebszustand an:

grüne LED pulsiert langsam - Standby des ISP Adapters, kein Target ist 
angeschlossen.

grüne LED ist dauerhaft an - ISP Adapter ist aktiv, Target wurde erkannt

grüne LED blinkt schnell - ISP Adapter ist aktiv, Target wurde falsch 
angeschlossen (z.B. ISP Stecker verdreht)

orange LED ist an - AVR ISP Modus, Zugriff auf das Target per ISP


Gruß, Thomas

Autor: Will gerne helfen... (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@all

hier noch ein paar Info´s über das Crumb128-Modul als *.pdf Datei.

@Orko
hast Du möglicherweise den Reset-Jumper gesteckt ?

Gruß, Thomas

Autor: Will gerne helfen... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Orko

Sorry, hab´in meinem Eifer leider überlesen das Du folgendes geschrieben 
hattest
:
> 1.
> Der Adapter wird erkannt und im Gerätemanager angezeigt.
> Die grüne Staus LED auf dem Adapter leuchtet.

.....demnach wird Dein Crumb128-Modul von Deinem Programmieradapter 
erkannt. Also wären als nächstes die Einstellungen deiner 
Programmiersoftware zu überprüfen.

Gruß, Thomas.

Autor: Orko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Thomas,

erstmal Danke für die Antworten.
Die Beschreibung des Status der LEDs war eine Hilfe.

Inzwischen habe ich mir das AVR Studio runtergeladen.

Zuerst :
grüne LED ist dauerhaft an - ISP Adapter ist aktiv, Target wurde erkannt


dann beim auslesen:
orange LED ist an - AVR ISP Modus, Zugriff auf das Target per ISP

Kann also mit meinem Crumb eine Verbindung herstellen.

Leider wollte ich gerne mit den Programmers Notepad  und Ponyprog 
arbeiten.
Da ich beim PonyProg aber den Com9 Port nicht einstellen kann, muss ich 
mir das wohl abschminken. Kann leider nichts darüber im Internet finden.

Gruß Orko

Autor: WIN32API (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Orko,

google mal nach "devmgr_show_nonpresent_devices".
Damit kannst Du evtl. Deine vergebenen COM-Port-Nr. aufräumen und dann 
den
FT232R-Treiber neuinstallieren.

Autor: A.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ports aufräumen und Treiber neu installieren bringt einem meiner 
Erfahrung nach bloss zweistellige COM-Ports ein. Da ist irgendwo ein 
Zähler, dem das Aufräumen garnicht imponiert, der zählt munter weiter.

Aufräumen von USB-Leichen ist sinnvoll, aber danach kann man die 
verbleibenden USB-COM-Ports einfach umbenennen. Im Gerätemanager in den 
Eigenschaften des Ports unter "Port Settings", "Advanced".

Autor: James Blond (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schau Dir XP mal genauer an....
....siehe Anhang !

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.