www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Thread error beim ARM


Autor: mussa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe folgendes problem:

ich habe unter LINUX ein Programm geschrieben, in dem ich folgenden 
thread eingebaut habe:

if(pthread_create(&my_thread, NULL ,  thread_function , (void*)dummy)!= 
0)
  {
  printf("Thread ERROR: %s \n",strerror(errno));
  exit(1);;
  }

Wenn ich dieses Programm auf meinem PC bzw. Notebook laufen lasse 
funktioniert alles super!

Nun habe ich das Programm auf mein ARM Entwicklungsboard AT91RM9200 -EK
geladen...

Wenn ich den thread raus nehme läuft auch dort alles Andere super
(sockets, serielle Schnittstelle, etc.)

wenn ich allerdings den thread mit einbaue bekomme ich folgende 
Fehlermeldung: Thread ERROR: Interrupted system call

vielleicht kann mir jemand sagen wo das problem liegt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.