www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik yaap und co mögen Atmega32 nicht


Autor: ironeagle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ich habe einen Atmega32 (16PU). Ausserdem hab ich mit den ISP Dongle von 
Roboternetz.de nachgebaut ( 
http://www.roboternetz.de/wissen/index.php/AVR-ISP... )
Sowie deren Grundschaltung mit einer Diode (laut 
http://www.roboternetz.de/wissen/index.php/AVR-Ein... )
Ich hab dann mit Bascom das Programm geschrieben, dass die Diode blinken 
lässt, compilt und mit dem Programmer in den µC geladen. Alles bestenes. 
Diode blinkt. Jetzt wollte ich die Tutorials von mikrocontroller.net 
ausprobieren (und deshalb auf Bascom verzichten).
Jetzt hab ich nur das Problem, dass weder yaap noch AVR Studio und auch 
Pony-Prog es nicht schaffen, den Controller zu erkennen.

Hier ist das, was mit yaap sagt:
Ich sterte yaap. Die (I/O Triber hab ich natürlich installliert)
Wenn ich unter Options den LPT POrt einstelle und das INterface auf 
Autodetect stelle kommt, nachdem ich auf "Device Detect" drücke:
"Init failed. Is target connected and power on?"
Wenn ich unter interface "STK 200/300" angebe kommt:
"Cannot find the seleted interface on the seletec port"

Waran kanns liegen? MIt dem Bascom gehts ja.
Für Tipps wäre ich wiedermal echt dankbar.

Gruss
Ironeagle

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probiers mal mit TwinAVR: http://www.rowalt.de/mc/avr/progd.htm

Autor: ironeagle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie muss ich die Settings einstellen ?
Ausser LPT weiss ich leider nicht, wo ich die Häckchen hinmachen muss.

Autor: ironeagle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn ich nur LPT einstelle und alles andere so lassen kommt:
"Programmer Enable Sequenz not successfull. LPT and Programmer type 
correct? If yes, switch to the power off and run"

Autor: ironeagle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
Mit uisp unter gnu gehts seltsamerweise auch...

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bau dir zum testen mal den mit den 2 widerständen, da mußt du dan nix 
sonderlich einstellen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.