www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Installation ISE auf Linux


Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

versuche gerade unter Linux,Suse die ISE9.1 zu installieren.
Die Setup Datei (unter windows setup.exe)lässt sich aber leider nicht 
starten.
Der Editor öffnet dann Quelltext.Auch die Umbenennung der Setup Datei in
setup.sh oder setup.bash bringt nichts.Vielleicht kann mir jemand helfen
mit mehr Linux-Erfahrung wie ich.
Danke im voraus.

Sebastian

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuchst du allen Ernstes, die Windows-setup.exe unter Linux 
auszuführen? Entweder bist du ein Troll, oder wirklich ein blutiger 
Anfänger. Dann wiederum stellt sich die Frage, warum ausgerechnet DAS 
unter Linux sein muss.

Falls du zweiteres bist: Von ISE gibts AFAIK ne Linux Version. Die 
nehmen, bitte.
Wenn du aus unerfindlichen Gründen die Windowsversion benutzen willst, 
kannst du es mal mit wine (->google) versuchen.

Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Frank
ne natürlich nicht die Windows exe sondern die Setup Datei in der ISE
Linuxversion.Was ist den die Ursache das der Editor die Datei öffnet
und nicht setup startet.

Autor: Manuel Kampert (manuel1139)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann dir nur sagen das ich obwohl ich imho genügend linux Erfahrung 
habe, ISE nicht komplett zum laufen bekommen habe. Im speziellen ging 
der Floorplanner nicht.

Installation war eigentlich kein Problem. Einfach die setup.sh 
ausgeführt und schon gings los. Bekommst du denn eine Fehlermeldung wenn 
du in der Konsole die Setup ausführst?

Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachdem ich setup in setup.sh umbenannt hatte meldete sich der Editor 
beim Start.Danach habe ich Setup.sh versucht im Terminal zu starten.Dort 
bringt er
mir die Fehlermeldung :unbekanntes Kommando.(?)

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird wohl nicht als ausführbar gekennzeichnet sein.
Je nachdem, wie du das machen möchtest, Rechtsklick und dann mal 
schauen, oder gleich im terminal, weil du zu Installation eh super user 
sein musst:
<mach dich zum root, normalerweise su bei suse>
chmod +x setup.sh
(oder wie auch immer die datei heißt, funktioniert allerdings nur, wenn 
ganz am Anfang der Datei der shabang(?) #! zu finden ist)
oder auch einfach: sh setup.sh

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wenn du in dem verzeichnis bist, musst du noch ./ voranstellen. also 
./setup.sh

Autor: sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Hilfe.Probiers gleich mal aus.

Mfg
Sebastian

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... oder aufrufen mit
sh setup.sh
So ist's wohl vorgesehen (steht sicher auch in irgendeiner 
Installationsanleitung).

Autor: yalu (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... ach, seh ich jetzt erst: Das hat Frank schon geschrieben.
Aber wenn gleich zwei auf die Idee kommen, muss was dran sein ;-)

Autor: Rick Dangerus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
siehe auch hier:
http://www.mikrocontroller.net/articles/Xilinx_ISE_Linux

Der floorplanner geht nur wenn die Farbtiefe des X-Servers stimmt. 
Außerdem braucht er m.E. auch spezielle Motif-Bibliotheken.

Am Besten mal von der Kommandozeile aus aufrufen, da kann man sehen, 
woran es hängt (ggf. strace nutzen).

Rick

Autor: SiO2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soweit ich mich erinnern kann, wird erstmal die integritaet geprueft ( 
von der datei) danach entpackt, und dann geht die install los. wenn due 
es als root ausfuehrst (mit su zu root gewechselt) sollte dein X 
freigegeben sein (xhost +, ist aber ein gewisses sicherheitsrisiko ;) 
sudo sollte besser sein [aber ich hab kein plan von :( ])
du kannst es aber auch als normalouser ausfuehren, und lokal in deinem 
home installieren. ist eigentlich kein problem, sollte dir in der 
konsole/*term anzeigen wenn es ein problem gibt, was es fuer eins ist. 
ich hatte noch nie probs damit, aber die probs gehen los, wenn man die 
treiber zum flashen installieren will :))))) (ausser man hat redhat 
entensteiss)

Autor: Uwe Bonnes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unter Suse 10.2 brach die Installation auf einer Maschine mit 512 MByte 
ab. Auf einer Machine mit 1.5G hat es geklapppt. Ich habe dann den 
installierten Baum kopiert...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.