www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik kein ACK bei TWI.. / wie testen?


Autor: TWI Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe gerade einen I2C-Chip am Mega8 angeschlossen und sende

TWI-Start, (Antwort 08h) dann
die Chip-Adresse (Antwort 20h) und dann
ein Datenbyte (Antwort 30h)

Lt. Datenblatt müßte das bedeuten, daß der Slave kein "ACK" generiert 
(also gar nicht reagiert)?

Es könnte ja sein, daß der Chip ein paar Millisekunden braucht oder so.. 
Sollte ich zum Test immer zyklisch

TWI-Start -> Chip-Adresse

ODER

TWI-Stop -> TWI-Start -> Chipadresse

senden, bis Antwort 18h kommt?

Habe ich überhaupt eine andere Chance zu sehen, ob der Chip funktioniert 
/ mit mir reden will, als das ACK-Bit zu prüfen? Oszi habe ich, aber 
keiner zum Speichern..

Autor: Xine L. (xine)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

leider kann ich Dir darauf auch keine Antwort geben, denn ich habe 
momentan exakt das gleiche Problem. Nur, dass ich 2 AVRs benutze über 
I²C verbunden.

Hast Du mittlerweile eine Antwort auf Dein Problem bekommen??? Falls ja, 
lass es mich gern wissen, denn langsam verzweifle ich hier...

Danke, Xine

Autor: TWI Anfänger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es selbst herausgefunden - der Takt (definiert durch den TWI 
Vorteiler) war bei mir viel zu schnell eingestellt. Ich habe angenommen, 
es sollten so ca. 100KHz sein, aber es kann auch viel langsamer sein. 
Jetzt habe ich so ca. 10kHz und keine Probleme mehr. Das Debuggen fand 
ich nicht leicht. kannst Dir ja erstmal ein anderes TWI-Gerät nehmen, 
das sicher funktioniert (Temp.-Sensor oder so) - dann weißt Du 
zumindest, ob Dein Master funktioniert.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

max. 100kHz können alle I2C-ICs. Natürlich darf die Leitung nicht zu 
lang sein (Kapazitäten stehen in der I2C-Beschreibung) und die PullUps 
müssen passen (Formel steht auch im AVR-Datenblatt. Innerhalb einer 
Leiterplatte sind 4,7k brauchbar, die internen PullUp des AVR sind zu 
hochohmig.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.