www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ENC28J60 Betriebstemperatur


Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
ich habe heute meinen ersten ENC28J60 in Betrieb genommen. Dieser wird 
mit 3,3 - 3,4V betrieben (mit Oszi gemessen und schön ruhig). Wenn ich 
das Netzwerkkabel einstecke, leutet sowohl die eine LED vom ENC als auch 
die vom Switch.
Den Kontroller habe ich momentan noch im Reset, weil ich erst die 
Beschaltung auf Fehler prüfen möchte.

Soweit heile Welt - wenn der ENC nicht nach etwa 30sek merklich warm 
werden würde. Nicht richtig heiß, aber doch handwarm; unabhängig von der 
Netzwerk-Verbindung. Ist das normal?
Habe schon meine Schaltpläne mit diversen aus diesem Forum verglichen 
und keinen Fehler gefunden. Auch die Spannungspegel sind alle gemäß 
Datenblatt. Die Stromaufnahme der einzelnen Vdd-Pins ist auch nicht 
gerade außergewöhnlich:
Pin 28 (Vdd): 5mA
Pin 25 (VddOSC): >1mA, aber <0mA
Pin 19 (VddRX): 1,8mA
Pin 20 (VddPLL): 3,2mA
(alles gemessen ohne Netzwerk-Verbindung)

Jetzt möchte ich eifach mal die Frage an die Erfahrenen in den Raum 
werfen, ob das normal ist oder ob mir der IC demnächst abraucht. Länger 
als 1min hatte ich ihn noch nicht an.

Danke!
Andy

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die Stromaufnahme der einzelnen Vdd-Pins ist auch nicht
> gerade außergewöhnlich:

Das eben ist ungewöhnlich. Der ENC braucht normalerweise so um die 
150mA. Und wird deshalb auch deutlich warm. Im Netz jedenfalls.

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Antwort!

Also wenn der ENC deutlich weniger braucht als normal und trotzdem heiß 
wird, dann müßte er die verbratene Leistung theoretisch woanders 
herkriegen -> doch Schaltungsfehler. grübel
Ich forsche mal weiter...   ;)

MfG Andy

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Unser ENC macht um die 40°C bei 3.3V und aktiver Verbindung. Ist normal.

Autor: tt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, ist ok, wir verwenden einen PIC18F67J60, der hat auch den ENC28J60 
intern und der wird auch so um die 45 Grad warm. Hab mich zuerst auch 
gewundert, läuft aber seit Monaten problemlos.

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe das Problem noch ein bißchen weiter analysiert.
Wenn ich die ganze Filter-Beschaltung vom TPout wegmache, dann ist die 
Stromaufnahme am Netzteil plötzlich minimal, aber er baut keine 
Verbindung zum Switch auf.
Sobald ich die Drossel draufmache (1 Ende fest, das andere auf's Pad 
gebogen), verdreifacht sich die Stromaufnahme, das Teil wird wieder 
warm, und die Verbindung zum Switch ist (fast) sofort da.

N.B. Interessant ist, daß die LED A ohne Filter und mit angestecktem 
Netzwerkkabel regelmäßig 2x kurz aufblinkt. Habe im Datenblatt nur noch 
nicht gefunden, was das bedeutet.

Wenn das normal ist und ich gerade Phantome jage, dann ist das OK. Ich 
werde nur immer unruhig, wenn solche Logikbauteile warm werden.

MfG Andy

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann gut sein, dass ein erheblicher Teil des Gesamtstroms an den 
diversen Vdd-Anschlüssen vorbei über die beiden 50 Ohm Widerstände in 
den ENC reinfliesst. Du also auch mal den Strom durch die Vss-Anschlüsse 
messen musst.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Du jagst einem Phantom nach...

Wenn Du die Ausgangsbeschaltung ablötest, ist es doch logisch, daß nur 
noch wenig Strom verbraucht wird. Bleibt schließlich nur ein bißchen 
Logik übrig, die zieht heutzutage nicht mehr allzuviel.

Der abgelötete Rest gehört schließlich zum Ethernet-Leitungstreiber, der 
möchte wegen recht hoher Frequenzen, möglichst steiler Flanken und 
dranhängener Leitung doch etwas Leistung abgeben können und da der 
Wirkungsgrad vermutlich nicht bei 99% liegt, wird es dem Kerlchen eben 
warm ums Herz.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.