www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MC lässt mich nicht mehr in den programming mode!


Autor: Matthias Grimmer (Firma: schueler) (rok)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

Ich habe ein Problem, und zwar:
Verwendet wird von mir eine kleine uC Platine mit einem atmega32 drauf.
Ich programmiere ihn über die ISP schnittstelle
Ich habe schon viel mit der Platine gearbeitet und sie hat auch 
funktioniert!

Programmiert habe ich immer im CodeVision AVR, und hirmit auch den 
Controller programmiert
(programm FLASH)
jetz ist es mir passiert dass ich im Programmermenü "PORGRAMM ALL" 
versehentlich gerückt habe.
--> die Fusebits usw alles "verstellt", (Programm all)

und jetz kann ich nichts mehr auf den controller laden...
nicht auslesen, gar nichts... im codevison geht gar nichts mehr

AVRstudio:

auch im AVR studio geht nicht.
will ich die FuseBits einstellen:
entering the programming mode... FAILED
leaving the morgramming mode... OK!

chip signature lässt sich auch nicht auslesen!

will ich dann den Menuepunkt Fuse/Lock bits öffnen, kriege ich eine 
Warnmeldung, dass dies nicht mögl ist (ISP frequenz richtig einstellen 
usw)
ich hätte aber die ISP frequenz richtig eingestellt (sie ist zwar immer 
wieder verstellt wenn ich das AVRstudio lade, komisch?)

wie kann ich den uC wieder beschreiben bzw die fuseBits richtig 
einstellen?

Danke für eure Hilfe!

mfg matthias

Autor: E. B. (roquema) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Einen HV-Programmer verwenden. Der kann alle  Fuses immer einstellen.
Z.B. STK500 oder Universalprogrammer.

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ganz einfach, steck den Chip in deinen HV Programmer und setz die Fuses 
zurück. Wie? Du hast keinen HV Programmer? Dann steck den Chip in die 
Sondermülltonne und kauf nen Neuen (oder eben nen HV Programmer).

bye

Frank

Autor: Trunes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab das so gemacht wie es hier beschrieben wurde (hat super 
funktioniert),
weiss aber nicht ob das in deinem Fall auch funktioniert.

http://www.mikrocontroller.net/articles/AVR_Fuses#...

Autor: Matthias Grimmer (Firma: schueler) (rok)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DANKE,
für deine schnelle Lösung!
Hat prima funktioniert :-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.