www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Hardwareproblem RS232


Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe heute auf einem Steckbrett einen max232 von Texas Instr. 
aufgebaut komischerweise liegen nirgends die 7V an die laut Datenblatt 
erzeugt werden. Habe das ganze mit Miniaturelkos 1µF/63V von Reichelt 
aufgebaut und die Versorgungsspannung noch nen 100n Kerko parallel zum 
Elko installiert und mal einen Eingang mal auf Masse und auf 5V gelegt 
an den Ausgängen tut sich allerdings nicht. Die Maxim Teile leifern laut 
Datenblatt typ. 8V von den eigentlichen 12V ist das aber immer noch ein 
ganzes Stück weg.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schicke doch mal Deine Schaltung. Gerne wird bei solchen Sachen ein Elko 
verkehrt herum eingelötet, dann tritt der Effekt auch auf.

MfG Paul

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Steckbrett ist wahrscheinlich ausgelatscht.

Autor: Stefan R. (kroko)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas!

Prüf die Schaltung nochmal und geh mit dem Voltmeter durch, ob wirklich 
auf den Pins des MAX232 die Spannungen anliegen.
Manche Steckbretter haben schlechte Kontakte, vorallem alte.

Mfg Kroko

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, also das Steckbrett ist ganz neu weil ich für diesen Projekt ein 
größeres gekauft habe um alle Schaltungsteile auf einem aufzubauen. Die 
Elkos sind auch richtig angeschlossen habe das mehrfach überpüft bevor 
ich Saft auf den Baustein gegeben habe. Manche Ausgangspins geben mir 
die volle Versorgungsspannung aus unabhängig ob ich den zugehörigen 
Eingang auf High oder Low lege.

Habe gerade kein Programm hier um einen Schaltplan zu malen. Aber kann 
kurz den Anschluß de Elkos beschreiben.
1ter Elko mit + an VCC und mit - an GND
2ter Elko mit + an C1+ und - an C1-
3ter Elko mit + an C2+ und - an C2-
4ter Elko mit + an Vs+ und - and GND
5ter Elko mit + and GND und - an VS-

Autor: Nullpointer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elkos fuer den Max232 ? Da nimmt man doch Keramik

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Da nimmt man doch Keramik

Da gehen auch Elko's.

Dein 4. Kondensator scheint falsch zu sein, oder ich habe den Überblick 
verloren.
>4ter Elko mit + an Vs+ und - and GND
Der muss mit + an VS+ und - an VCC wenn mich nicht alles täuscht.

Dann müsstest du, wenn du an z.B. T1IN (PIN 11) +5V anlegst an T1OUT 
(PIN 14) die ausgangsspannung abgreifen können.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
an VS+ sollte doch die hochgepumpe Spannung anliegen und da diese ja 
höher als VCC ist muss doch + Vs+ das Datenblatt zeigt es zumindestens 
so an.

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:
> an VS+ sollte doch die hochgepumpe Spannung anliegen und da diese ja
> höher als VCC ist muss doch + Vs+ das Datenblatt zeigt es zumindestens
> so an.

Eben deshalb muss - vom Elko ja auch an Vcc und nicht an GND.

Autor: Thomas O. (kosmos)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
also danke für die Hilfe war genau daran gelegen, mich hat da das GND 
Schaltzeichen im Datenblatt durcheinander gebracht, dachte das das immer 
für GND steht oben rechts.

Ich habe jetzt einen Pegel von +8,5V und -8,5V ohne Belastung.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da waren wirklich 2 Elkos verkehrt mit GND und VCC verbunden also am 
MAX232 waren sie richtig dran aber die anderen Ende vertauscht.

Jetzt habe ich unbelastet jeweils 17V/-17V und das kommt der RS232 Norm 
mit ihrer 12/-12V bzw- 15V/-15V schon näher.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:
> da waren wirklich 2 Elkos verkehrt mit GND und VCC verbunden also am
> MAX232 waren sie richtig dran aber die anderen Ende vertauscht.
>
> Jetzt habe ich unbelastet jeweils 17V/-17V

+/- 17V bei 5V Betriebsspannung???
Du solltest Dein Messgerät mal überprüfen.

> und das kommt der RS232 Norm
> mit ihrer 12/-12V bzw- 15V/-15V schon näher.

Um die +/- 9V sind beim MAX232 normal, wenn er mit 5V versorgt wird.

...

Autor: Ideal Standard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei der Keramik kann man wenigstend nicht Plus mit Minus verbuchseln.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10µF in Keramik habe ich noch nicht gesehen, aber in Folien gibts das. 
Aber mein Problem war ja nciht das verpolen sondern das ich habe das 
eine Ende verkehr angeschlossen.

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:
> 10µF in Keramik habe ich noch nicht gesehen, aber in Folien gibts das.

Es gibt einen Untertyp vom MAX232 (etwas teurer), der kommt mit unter 
1µF aus. Und da nimmt man Keramik. Ich nehme aber auch den Normaltyp und 
Elkos.

> Aber mein Problem war ja nciht das verpolen sondern das ich habe das
> eine Ende verkehr angeschlossen.

Also Bremse und Gas verwechselt?

MfG, Blaubeer

Autor: Ideal Standard (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Naja fast...

Autor: Thomas O. (kosmos)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ja die MAX Typen für 1µF waren mir etwas zu teuer, deswegen der normale.

In der Schaltzeichnung ist bei mir das GND Zeichen abgebildet wobei es 
aber an VCC und umgekehrt muss.

Und welcher Kerko ist das gibts den auch bei Reichelt?

Autor: Ideal Standard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eher nicht. Leider.

Autor: Falk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Thomas O. (kosmos)

>ja die MAX Typen für 1µF waren mir etwas zu teuer, deswegen der normale.

???
Der 0815 MAX232CPE kostet bei A. R. aus S. gerade mal 0,41 Euro und 
läuft mit 1uF Elkos super! Kann es sein dass hier einge das mit den 
100nF Typen verwechseln?

MfG
Falk

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
tatsächlich ich habe nen 1µF Typen und auch 1µF Elkos dafür der 0,1µF 
MAX232 war mir im Vergleich zu teuer.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.