www.mikrocontroller.net

Forum: Compiler & IDEs Eclipse 3.3.0 + CDT 4.0.0 und MSPGCC


Autor: Wechselplatte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte gerne unter Eclipse MSPGCC benutzen.

Irgendwie scheint es bei der neuen Version anders zu sein als
wie in den diversen Tutorials beschrieben.

Kann mir bitte jemand sagen, was man machen muss um bei der
ogg. Konfiguration die MSPGCC toolchain verfügbar zu machen?
Ich finde keine Auswahlmöglichkeit.

Danke

Autor: Wechselplatte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Steven,

ich habe den Fehler gefunden!

Auf deine Antwort hin habe ich nochmals alles durchgesehen, weil ich
mich nicht blamieren wollte.
Ursache war letztendlich , dass durch meine mehrmaligen Versuche Eclipse
zu "installieren" und durch meine Verzeichnisstruktur (wollte Verson 3.1
unter allen Umständen beibehalten), zwei Plugin Verzeichnisse entstanden 
sind. Ich habe dann natürlich promt das MSPGCC Plugin in das falsche
Verzeichnis kopiert.

Danke für deine Hilfe.

Hast du den MSPGCC Debugger in Betrieb ? Lohnt es ich diesen in Gang zu
setzen ? Habe bisher NOICE 430 benutzt. Bin recht unzufrieden damit.
Habe gelesen, dass ich aber auch nicht mehr vom MSPGCC Debugger erwarten
kann.

Danke nochmals.

Autor: botnec (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Ausführungen.

>>Eclipse muss man doch nur entpacken. So habe ich 3.3 neben 3.2 laufen
>>gehabt.

Ja,ja, deshalb habe ich ja auch "installieren" mit Gänsefüßchen 
geschrieben.

Zum Thema Debugger bin ich allerdings grundsätzlich total anderer
Meinung. Lieber einen schlechten Debugger als keinen. Erlaube mir den
Vergleich zwischen einem Tretroller und einem Fahrrad (von Rennrad
möchte ich gar nicht reden). Man kommt mit beiden vorwärts, aber 
unterschiedlich schnell und bequem.
Ich bin allerdings verwöhnt von meinem ARM7 Debugger und habe früher
beim 8051 mit ICE gearbeitet (beruflich). Für MSP430 nutze ich wie
gesagt den NOICE , muss aber dazu bisher den Imagecraft C-Compiler
benutzen. Es passt leider nur das zusammen. Dummerweise gibt es
anscheinende nichts brauchbares für den Hobbybereich ohne größere
Kosten.

Werde aufgrund deiner Aussage erst gar nicht versuchen den Debugger in
Gang zu setzten. Vielleicht finde ich doch noch eine andere Lösung die
mir die Benutzung von gcc für den MSP430 erlaubt und gleichzeitig eine 
ordentliche Debugmöglichkeit bietet.

Danke nochmals für die anregenden Antworten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.