www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Pony Prog läuft nicht mehr (Pollin-Board)


Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich habe vor kürzem das Pollin-Board bestellt und dann erfolgreich in 
Betrieb genommen. Die ersten Testprogramme sind wunderbar gelaufen 
(Atmega8). Dann kam plötzlich eine Fehlermeldung beim Brennen des 
Controllers mit Pony Prog:

"Device missing or unknown device".

Nach einer Neuinstallation funktionierte das Programm wieder, zumindest 
ein paar mal. Jetzt kommt der Fehler wieder und eine Neuinstallation 
hilft auch nicht mehr.
Ich habe schon das gesamte Forum durchsucht aber keinen richtigen 
hilfreichen Beitrag gelesen.

Ich programmiere mit BASCOM und WinXP. Brennen mit Pony Prog und Seriell 
(Pollin Board 2.0)

Wäre schön, wenn ich dieses Problem mit euren Antworten schnell in den 
Griff kriegen könnte. Dann könnte ich den Urlaub noch etwas tiefer in 
die Materie Mikrocontroller einseigen. Bin nämlich noch Anfänger.

MFG
Mixer

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du PonyProg´s Schnittstelle mal kalibriert? Muß man nach 
Neuinstallation machen. Gehe sicher, daß während der Kalibrierung und 
während des Datentransfers keine hohe Prozessorlast an Deinem Computer 
anliegt.

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Ja, ich hab nach jeder Neuinstallation die Schnittstelle neu eingestellt 
und das ganze Kalibriert. Kann man ja auch fast nicht vergessen bei der 
Meldung!

MFG
Mixer

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergessen vielleicht nicht, aber ignorieren ;-) Tausche doch mal den 
Controller auf dem Experimentierbrett. Wenn er verfust ist, kannst Du 
ihn trotz jetzt korrekter Einstellungen nicht erreichen. Zum "Entfusen" 
reicht eventuell ein Takt am XTAL1 oder Du mußt einem Kollegen mit 
STK500 mal einen ausgeben ;-)

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Travel Rec. wrote:

..

> oder Du mußt einem Kollegen mit
> STK500 mal einen ausgeben ;-)

Ja, hier, mein STK500 freut sich schon drauf.

MfG, STK500 besitzender Blaubär

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich meine einen Kollegen in seiner Nähe, sonst wird das Porto ja teurer, 
als Controller und Bierchen zusammen ;-)

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eben...

Grüß die Klusberge.

MgG, 5406

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Nein, bei den Fuses hab ich noch nix geändert. Und ein anderer neu 
ausgepackter Mega32 funktioniert ebenfalls nicht.

MFG
Mixer

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Grüß die Klusberge.

Mach ich, von wem denn ;-)?

Autor: Sowieso (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sowieso wrote:
> PonyProg in BASCOM-IDE einbinden.
> http://bascom-forum.de/index.php/topic,89.msg263.html#msg263

Ihhhhhhh..... Wer will'n Sowas???

MfG, Blaubär

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Das funktioniert ebenfalls nicht!!

MFG
Mixer

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christoph S. wrote:
> Hallo,
>
> Das funktioniert ebenfalls nicht!!
>
> MFG
> Mixer

Wenn Pony nicht funktioniert, liegt es meist am Rechner. Entweder taugen 
seine Schnittstellen nix, oder es läuft noch eine andere Software, die 
das Timing empfindlich stört. Natürlich kann auch die externe Hardware 
fehlerhaft sein, da reicht manchmal schon eine zu lange Leitung. Da das 
Pollin-Board die seielle Schnittstelle für Bitbanging missbraucht, 
solltest Du prüfen, ob nicht eine andere Software diese 
COM-Schnittstelle für sich beansprucht und über das BIOS oder einen 
Treiber blockiert.

MfG, blauer Bär (prost...)

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Es läuft nur Pony Prog und im bios ist die Schnittstelle freigeschaltet, 
ein Treiber ist auch installiert. Wenn ich beim Einstellen der 
Schnittstelle auf "probe" klicke, dann sagt er OK.

MFG
Mixer

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Troll Blaubär (blaubeer)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christoph S. wrote:
> 
http://www.reichelt.de/?SID=30MotKHqwQAR4AAGHSz4k7...
>
> also den zum Beispiel, oder?

Oder den, der hier im Shop angeboten wird.
http://shop.mikrocontroller.net/csc_article_detail...

MfG, Blaubär

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder du baust dir einen

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe, Du nutzt auch die richtige 9pol.Buchse auf dem Pollinbrett? 
Dort, wo der MAX232 dran ist, wird es nix mit dem programmieren...

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Des ist mir auch klar. Ein bisschen hab ich die Unterlagen zum 
Pollinboard schon begutachtet.

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, den Fall hatten wir hier auch schon... Außer einem defekten Kabel 
fällt mir jetzt auch nix mehr ein, da ich ja bei Dir nicht rummessen 
kann..

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich mir den AVR-ISP mit USB kaufe, muss ich dann die ge-hex-te 
Datei mit AVR studio in den controller brennen oder kann ich das von 
bascom aus direkt?

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit AVR-Studio ist es wesentlich einfacher und übersichtlicher und Du 
hast immer die aktuelle Firmware dabei. Die BasCom-implementierung wird 
sicher immer hinterherhinken. Noch dazu hast Du gleich ein mächtiges 
Werkzeug und eine Plattform für einen Assembler und C-Compiler (WinAVR).

Autor: b3rgmo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe genau das gleiche Problem.

Hab das Board aufgebaut, alles nochmal geprüft und dann mal mit einem 
Mega8 experimentiert, hat wunderbar funktioniert. Doch auf einmal geht 
gar nichts mehr. Fehlermeldung PonyProg2000 " Device missing or unknown 
device (-24) "

Hab einiges versucht, Com-Schnitstelle vom PC getestet, anderer PC 
(gleicher Fehler), anderes Serielles Kabel (gleicher Fehler), neuer 
Atmega16 (gleicher Fehler), Platine auf Fehler untersucht, Bauteile 
nachgelötet, Software mehrmals deinstalliert/installiert (verschiedene 
Versionen), schön langsam bin ich am verzweifeln...

Mixer S. hast du vielleicht schon eine Lösung des Problems gefunden?

Hab mir extra das Pollin-Board geholt, weil ich dann keinen 
ISP-Programmer brauch. Will auch nichts Professionelles, nur 
Hobbymäßig...

Autor: Christoph S. (mixer) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hab das problem mit nem USB-ISP MKII gelöst. Der kostet zwar 40€, aber 
dann hast du keine Probleme mehr. Wenn ich jetzt nochmal soweit wäre, 
würd ich den usb-programmieradapter von hier vom shop kaufen. Der ist 
etwas billiger und kann mehr!

MFG Mixer

Autor: Raimund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hier läuft das POLLIN-Board V2.01 ebenfalls nicht via serial-port

Autor: Rene (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich bin von pony weg... im nachhinein weiß ich nicht mal mehr so recht 
warum ich dieses pony überhaupt angefasst hab :-/ ich verwende zum 
proggen jetzt das hier:

http://myavr.de/download.php?suchwort=ProgTool

... SI-Prog wie es auf dem Pollin drauf ist geht damit auch ;-)

Gruß R.

Autor: edison (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
die Software erscheint mir komfortabler, mit Ponyprog hat es bei mir 
auch nicht geklappt. Welche Hardware muss ich auswählen?

Nils

Autor: adm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wär's denn einfach mit AVRDude?
Bei mir funktioniert das mit
avrdude-5.3.1.exe -p atmega8 -c ponyser -P com1 -v -U 
flash:w:[Hex-Datei]
einwandfrei. Ich habe auch ein Pollin-Board und habe es mit PonyProg 
noch nicht mal versucht weil das keine ATTiny13 und 25 unterstützt.

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
adm wrote:
> habe es mit PonyProg
> noch nicht mal versucht weil das keine ATTiny13 und 25 unterstützt.

Das stimmt so nicht. Zumindest die neueste Version unterstützt Tiny13 
und 25

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.