www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 - Problem


Autor: Oli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Bis jetzt hatte ich eigentlich nie gross Probleme mit dem STK500, doch
jetzt kann ich einfach die Chips nicht mehr programmieren. Ich weiss
echt nicht mehr woran das liegen könnte.
Wenn ich das AVR Studio öffne und damit etwas auf ein AVR programmieren
will, dann wird das STK500 ordnungsgemäss "gefunden", doch sobald ich
etwas auf einen AVR schreiben oder lesen möchte erscheint folgendes:

Setting device parameters, serial programming mode ..OK
Entering programming mode.. FAILED!
Leaving programming mode.. OK

hmm, woran könnte das liegen? -"ISP header" ist mit dem
entsprechenden Socket verbunden.
-Status-LED grün
-AVR richtig im richtigen Socket...

Sorry für die Frage, aber ich weiss echt nicht was ich noch überprüfen
muss... Danke.

Autor: The Badazz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

installier mal das AVR-Studio neu, dann gehts wieder. Das Problem hatte
ich auch schon bin fast verzweifelt.

cya The Badazz

Autor: Oli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok. dann schauen wir mal...
Danke für die schnelle Antwort.

Autor: Domagoj Mihalic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Sollte die Neuinstallation das Problem nicht lösen, kannst du mal
probieren deinen uc im High Voltage-Modus zu programmieren.
Hatte ähnliches Problem und nach einem mal
"High-Voltage-Programming"
konnte ich wieder normale ISP-Programmierungen durchführen
(falls du nicht weißt von was ich rede schau im SDK-Handbuch nach)

mfg Domic

Autor: The Badazz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau, das kann auch helfen. Hab garnicht dran gedacht!

cya Badazz

Autor: Oli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Neuinstallation AVR Studio + Firmwareupdate des STK500 -> jetzt gehts
wieder...

Danke für die Hilfe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.