www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Blöde Frage - aber ich weiss nicht weiter (Opto 6N136)


Autor: omnit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
übers Wochende versuchte ich die vor Jahren im Selbstbau gefertigte 
Schnittstelle (RS232 zu RS232 optoisoliert) zu meinem alten Oszi mit 
9600 Bauds auf die erforderlichen 115200 meines Neugerätes aufzubohren. 
Die 'Isolierung' besteht aus dem Paar MAX250 und Max251 wo im 
Handbuch/Datenblatt auch der Umbau auf die 6N136 Optokoppler für 
Baudraten bis 250k beschrieben ist ....

Wie gesagt 'beschrieben' - dementsprechend modifiziert sagt das Ding 
allerdings keinen Mucks mehr. Ich habaute daraufhin ersteinmal ein 
'6N136' Messplateau und siehe da die (sch...) Optokoppler scheinen 
einige Geheimnisse behalten zu wollen. Ich bat eben meinen Kollegen 
nochmal das nachzumessen und wir kommen glattweg zum selben Ergebnis.

Anscheinend funktionieren die 6N136 nur so bis 1 oder 2mA auf der 'open 
collector' Seite - wenn gleichzeitig auf der LED-Seite da ca. 10mA 
reingepumpt werden. Bei einem Widerstand von 4700 Ohm zwischen Vcc und 
Collector (Vo) zieht der das Ding man so eben noch gegen 'Null'. - ein 
Widerstand von 3000 Ohm überfordert das Teil dann total.

Wenn ich an der Basis einen 10k Widerstand anbändsel reagiert (schließt) 
der Transisor garnicht mehr - damits aber funktioniert müsste ich schon 
so 5mA sicher und 'pegelgerecht' auf der Collectorseite verhackstücken 
können.

Wir probierten mehrere Stück aus einer (uralten) Stange und zwei neu 
hinzugekaufte - die Unterschiede sind eher gering und ändern nichts am 
Prinzip das der die im Datenblatt angebenen 25mA nie schaltet .... auch 
nicht bei 50mA auf der LED-Seite (wo die Diode bevor sie ewig verdunkelt 
und  trotz Alterung ja irgendwie mal hell sein müsste ...).

Bei einer anderen Schaltung mit 10k-Ohm Widerständen nachgebaut 
funktioniert alles wie gedacht - aber das der MAX250 /251 mit 10 k-Ohm 
(Pullup) noch was sagt ist eigentlich nirgends angeben ....

Kurzum: Muß das so sein mit den 6N136 oder mache ich da was falsch ?
Gruß
Carl-Peter

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Carl-Peter!

Der 6N136 ist auch nur mit einem CTR von 19% bei If=16mA angegeben. 
Deine Ergebnisse stimmen also (leider).
Schau Dir doch mal den 6N137 an.

Grüße
Michael

Autor: omnit (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael
vielen Dank !
Den 6N137 fand ich gestern schon in einem Schaltplan als Alternative 
('verstärkte') Variante. Auf den CTR hatte ich das jedoch nicht bezogen, 
ging von der Schaltleistung des Transistors aus.
Ich werde denn mal weitersehn,
Gruß
Carl-Peter

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.