www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probs mit Nokia 6100 / 6610 LCD Display


Autor: pay.c (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an Alle!

Ich habe VOLL die Probleme, das 6100er LCD zum Laufen zu bringen. Ich 
habe bereits ein 3310er und das S65er erfolgreich zum Laufen gebracht, 
aber die 61er Displays weigern sich famos auch nur ein wenig zu 
funktionieren.

Im Anhang dazu mal ein Bild des Displays. Egal, was ich mache, ich 
bekomme immer diese Pixel aufs LCD mit leicht unterschiedlichen 
Helligkeiten (fast schon Graustufen - aber alle eher 
dunkelgrau/schwarz), die sich nicht ändern. Egal ob SPI-Befehle oder 
sonst was läuft, der Display ändert seinen Zustand überhaupt nicht.

Meine Ansteuerung sollte eigentlich passen, ich betreibe alle Signale 
über 470/1k Spannungsteiler an 5V (also 3,4 Volt Signale) und 3,3V 
Spannungsversorgung über einen LF33 (alles nachgemessen). 
Hintergrundbeleuchtung funzt auch (wie man sieht). Es kommt aber nix auf 
das Display, egal was ich sende. Ich glaube ich habe den PCF 
Controller (tja, wenn das jetzt mal so klar wäre...), aber ich habe 
türlich beide Controller-Varianten ausprobiert.

Hat jemand schon einmal so ein Fehlerbild gesehen? Ist das (besser die, 
weil es zwei Stück sind) LCD hinüber? Hat jemand eine Schaltung zu 
diesen Displays an 5 Volt, die mit Sicherheit läuft? Würde mich über 
jede Hilfe freuen wie Schneekönig, weil es die letzten LCD sind, die ich 
noch zum Laufen bekommen will!

Autor: Hagen Re (hagen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ich kann nur eines raten, nimm einen ordentlichen Pegelwandler und 
nicht diese Widerstandskrücke. Gerade die Nokia Teile waren damals als 
ich die einsetzte enorm empfindlich. Ein Spike auf den Leitungen und 
nichts ging mehr.

Die Signalleitungen sollten auch nicht über Vcc des Displays liegen, 
auch nicht wenn es nur 100mV sind.

Gruß Hagen

Autor: pay.c (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
:/

Och nöö, oder? Hmm, na dann muss ich mal wieder eine Reichelt Bestellung 
aufsetzen... Vielleicht einen Tip für einen ordentlichen 5V -> 3,3V 
Pegelwandler für mind. 5 Signale (damit ich Vcc auch gleich damit 
betreiben kann)? Am besten in DIP und SMD Ausführung (einmal für 
Prototyp und einmal für PCB).

Na, dann mal Daumen drücken, daß die Displays noch leben...

Dankö!

Autor: pay.c (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
SO, FUNZT!!!

War unter Anderem tatsächlich die kleine 0,1 Volt Geschichte, 
unglaublich empfindlich, dieses Display. Habe jetzt zusätzliche 
Widerstände eingebaut, damit beides (Vcc und Signale) auf 3,3V liegt. 
Also die nächste Schaltung wird wirklich per Pegelwandler gemacht, Danke 
für den Tip! :)

Na, auf jeden Fall gibts andere Probleme, aber das besprechen wir wohl 
am besten in Deinem Treiberthread.

Dankö! Fertüsch! :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.