www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega 8 falsches Fuse - tot


Autor: Matthias F. (idefix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mir ist gerade ein dumme Fehler passiert.
Hab aus versehen mit AVRPROG in meinen Mega8 als Taktgeber Ext LFXTAL 
geschrieben, jetzt ist der natürlich tot.

Was muss ich den an den anschliessen, damit ich die Fuses wieder 
programmieren kann?

Schon mal danke.

Gruss
Matthias

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Matthias F. (idefix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab jetzt wie das beschrieben ist angeschlossen, an XTAL1 hab ich einen 
4 MHz Oszillator gehängt, aber mein AVRPROG findet den Chip einfach 
nicht.

Gibt es noch eine andere Möglichkeit?
Wie schon gesagt hab ich den versehentlich auf Ext LFXTAL gesetzt.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stelle mal die ISP-Frequenz auf unter 1Mhz, wenn Du mit 4Mhz taktest. 
Wenn das dann immer noch nicht geht, dann ist noch etwas anderes faul.

Autor: Matthias F. (idefix)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Travel Rec. wrote:
> Stelle mal die ISP-Frequenz auf unter 1Mhz, wenn Du mit 4Mhz taktest.
> Wenn das dann immer noch nicht geht, dann ist noch etwas anderes faul.

hm, wie meinst du das?
Unter AVRPROG kann ich nichts bzgl. ISP Frequenz einstellen.
Oder meinst du den Oszillator, den ich an den ATMega8 hänge (XTAL1), 
damit ich einen Taktgeber habe?

Autor: Arno R. (conlost)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

du hast geschrieben, das die fuses auf (LFXTAL)
"External Low-frequency Crystal"
eingestellt wurden.

Versuche es mal mit einem 32.768 kHz Uhrenquarz an XTAL1 und XTAL2
eventuell wird es dann gehen.

Es grüßt,
Arno

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Simon R. wrote:

> Versuche es mal mit einem 32.768 kHz Uhrenquarz an XTAL1 und XTAL2
> eventuell wird es dann gehen.

Aber natürlich nur, wenn der ISP-Takt < 8192 Hz liegt (wobei dann
das ISP ewig dauern wird).

Wenn das Programmiergerät den ISP-Takt nicht einstellen kann, hat
man einfach mal schlechte Karten.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.