www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Quarz Atmega 16


Autor: Warhammer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo leute,

ich bin totaler noob in sachen programmieren und hardware, also nicht 
lachen:P

hab ein kleines test Programm am stk500 mit dem atmega 16 geschriben.
am board läuft das ganze auch, nur wenn ich mir die platine versuche so 
aufzubauen bekomme ich keine funktion (hab am oscar gesehen das der 
quarz nicht schwingt.)

was ich gemacht hab

fuse bit auf externen clock nit 64ms start up gestellt

2gnd's am controller angeschlossen

vcc und avcc und aref auf +5V gelegt

zwischen gnd und vcc 100nF

reset über 4k7nach +5V und 100nF nach masse

zwischen XTAL1 und XTAL1 4mhz quarz angeschlossen und über 22nF zur 
masse



so dabei habe ich keine funktion. wenn ich jetzt das fuse bit auf 
internen quarz setzt funktioniert es, aber auf extren nicht.

muss ich evtl in programm den externen quarz noch einbinden?

besten danke


greets
warhammer

Autor: Warhammer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achso kleiner tippfehler, ich meine natürlich 2x 22pF zu masse am Quarz

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest die Fuses auf Crystal umstellen, nicht auf external clock. 
Letzteres meint ein extern erzeugtes Rechtecksignal an XTAL1.

Autor: Warhammer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohje da ist ne mega lange liste...auf was den da genau?

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf den passenden Wert ;)

Ext. Crystal/Resonater würde ich nehmen, Frequenzbereich steht im 
Datenblatt und die Anlaufzeit kannste selbst wählen. Das Maximum ist da 
meistens keine schlechte Idee.

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warhammer wrote:
> ohje da ist ne mega lange liste...auf was den da genau?

...wenn Du wirklich (wie oben gschrieben) einen 4mHz-Quarz hast (muss ja 
ein ganz schöner Brocken sein), dann wird das wohl nichts, denn die 
nötige Treiberleistung bringt der Mega16 nicht ;-))

Bei 4MHz (ja, manchmal hat Groß/Kleinschreibung wirklich eine 
Bedeutung!) kannst Du es mal mit der letzten Zeile probieren.

Nachdem Du 2 x 22p Kondensatoren angeschlossen hast, benötigt Dein Quarz 
lt. Datenblatt also so ca. 14pF Lastkapazität? Das kommt mir für einen 
4MHz Quarz etwas klein vor (oder ist das so'n Subminiatur-SMD-Teil?).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.