www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Selbstgebauter USB-Port mit FT232RL funktioniert nicht an US


Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

mein kleines Messgerät wird vom PC-USB mit Spannung versorgt. Die 
Stromaufnahme ist etwa 200mA. Laut FTDI-Appn wird dieser Strom über 
einen IRLML6402 vom RT232 eingeschaltet.
Am direkten PC-USB-Bus funktioniert alles prima.
Über ein 4-fach USB-Hub mit externer Versorgung funktionierts nicht 
mehr, obwohl laut PC/Systemsteuerung/Hardware der Port richtig erkannt 
wird.

Kennt jemand mögliche Probleme mit USB-Hubs?

Danke für pos. und neg. Kommentare.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spannungsabfall am USB Hub bzw. langen Kabel ?
Oder ist der Ausgang des Hubs nur für einen geringeren Strom 
spezifiziert ? Das wird ab und zu bei passiven Hubs gemacht.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Tempelritter,

Ist der Strombedarf über die Konfigurationssoftware des FT.. richtig 
eingestellt und wird auch erst nach der Anmeldung zugeschaltet?
Ich hatte damit mal Probleme.

Gruß
Sebastian

Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Holla, schnelle Antwort!

Am Vcc-Pin des FT232RL messe ich 4,3V, die ext.Stromversorgung liefert 
max.2Amp.

Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ...Konfigurationssoftware des FT.. richtig....

Hallo Sebastian, mit MProg gebe ich 10mA vor, hmm wieso eigentlich?
Muss ich da meine 200mA eintragen?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tempelritter wrote:
>> ...Konfigurationssoftware des FT.. richtig....
>
> Hallo Sebastian, mit MProg gebe ich 10mA vor, hmm wieso eigentlich?
> Muss ich da meine 200mA eintragen?

Ja !!!

> Am Vcc-Pin des FT232RL messe ich 4,3V, die ext.Stromversorgung liefert
> max.2Amp.

Das ist meiner Meinung nach etwas wenig.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, und Buspowered!

Autor: Roland Z. (r-zimmermann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tempelritter,

ja, du muß mit Mprog dem Chip sagen wieviel mA dein Gerät maximal zieht.
Sonst kann es sein daß der Host deinem Gerät den Saft abklemmt 
(vorausgesetzt es ist Buspowered) und du die Meldung bekommst daß ein 
USB-Gerät den maximal zugeteilten Strom überschritten hat. Je nach 
Mainboard klappt die Enumeration unter Umständen dann nur noch zögerlich 
oder gar nicht mehr.
Gib zu dem maximalstrom vielleicht noch 50mA "Reserve" dazu dann bist du 
auf der Sicheren Seite.

MfG
Roland

Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh hah! Danke für die eindeutigen Tipps! Da hab ich wohl mit MProg 
geschludert.

Vielen Dank!

Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mist! Hab 250mA und Buspowered mit MPROG eingegeben, aber über den Hub 
funktioniets immer noch nicht. Werd mich mal um die Vcc von 4,3V 
kümmern...

Autor: Sebastian (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schade,
Anbei mal ein Auszug der Spezification.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Is es denn auch ein "High-power Hub Port"?
"Low-power Hub Ports" können nur 100mA pro Port...

Autor: Tempelritter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser Hub wird verwendet:

http://www.vivanco.de/cgi-bin/vivanco/de_DE/produc...

"...für USB-Geräte mit hohem Stromverbrauch."

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.