www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit DMX Dimmer


Autor: logo13 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

hat jemand von euch den DMX Dimmer von

http://hoelscher-hi.de/hendrik/light/dmxdimmer.htm

erfolgreich nachgebaut ??

Habe da einige Probleme und würde mich über jede Hilfe frohen.


An den Ports die die Optokoppler ansteuern kommt nur sporadisch was 
raus.
An der Hardware scheint es nicht zu liegen. Da die Hardware mit der 
Swichpack Software leuft.


 Danke.

Autor: Markus C. (ljmarkus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
haste auch die externe Nulldurchgangserkennung mit angeschlossen ?
und auch mal die Seite ganz gelesen, da steht auch was zur Fehlersuche.

lg, markus

Autor: logo13 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Beides ja !!!

Die Nulldurchgangserkennung funktioniert auch richtig.

Ich sitze da schon seit einer Woche dran :-(

Könnte nur noch an der Software liegen, glaube ich.

Autor: Markus C. (ljmarkus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
haste auch die fuses usw. richtig gesetzt ?

Autor: Henne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn es an der FW läge, würde es bei Keinem laufen, richtig?


Es fehlen Angaben zu den LEDs.
Es fehlen Angaben, ob die Tests mit der Diagnosefirmware erfolgreich 
waren.

Du hast von einem erfolgreichen Nachbau des Switchpacks  geschrieben: Du 
weißt aber, dass Du mit im Nulldurchgang schaltenden Lastteilen bei 
Anschnittsdimmern nicht weit kommst, oder? (-> andere Lastteile, die 
sofort schalten [random ignition])


Ein 'sporadisch was rauskommen' gibt es nicht, es sei denn die 
Eingangsdaten sehen dies vor.


Hendrik

Ich schau mir das nun hier mal an und verbesser dann die FAQ 
entsprechend. (Also bitte auch die Lösung am Ende posten!!)

Autor: logo13 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Lösung ist da !!!!!

Meine eigene Dummheit !

Da ich keine passenden Programmer für Ponyprog hatte, habe ich die 
Firmware mit Bascom programiert. Es lief komischerweise nur die 
Dimmerfirmware nicht richtig. :-(  der Rest lief ohne problemme.

Obwohl jedesmall beim Prog und Verifi keine fehler angezeigt wahr, hat 
Bascom  die Firmware zerschossen.

Habe mir passenden Programmer für Ponyprog gebastelt und es läuft.

Danke an alle.

Autor: henne (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube nur bei den Dimmern mit großen 16bit-Tabellen unter AVRASM 
gearbeitet zu haben.

Vielleicht mochte er keine Positionierung von Tabellen im Flash und hat 
alles hintereinandergeschrieben?

Ich bin froh, dass es funzt. (Aber irgendwie nicht FAQ-tauglich...)


Viele Grüße,
Hendrik

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.