www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bei Displayansteuerung aus Tutorial nur "D"s zu sehen!!


Autor: B.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

arbeite mich grade durchs Tutorial. Nun möchte ich wie im Tutorial 
beschrieben einen Text ausgeben, welches mir aber leider nicht gelingt. 
Ich habe ein 4 zeilen display von pollin und möchte erstmal nur die 
unteren beiden ansteueren. Dieses gelingt mir auch nur erscheint statt 
des textes in beiden zeilen lauter "D"s. Ausserdem springt mein courser 
wie wild durch die gegend.

Im Anhang ist mein Code bzw. der aus dem tut.

Bin für jede Hilfe dankbar.

Gruß

Autor: B.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun nachdem ich mehrmals den mic geresettet habe kommt in zeile 1 ziffer 
1, ein"T" alle anderen bleiben leer und in zeile 3 und 4 sind schwarze 
balken

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich sehe keinen angehängten Code. Braucht man dafür ne Glaskugel? ;)

Ich vermute, dass da was mit der Verdrahtung nicht stimmt. Poste mal den 
Schaltplan, den Code und am besten Fotos von dem Aufbau.

Autor: B.K. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry Anhang vergessen.

Also nun sind die unteren beiden Zeilen mit "D"s belegt und in den 
ersten zwei Zeilen kommen schon die Buchstaben  T,E,S,T in wirren 
reihenfolgen, manchmal auch ganz andere zeichen wie O o.Ä. .

Was mich am meisten wundert ist das ich ja nur die oberen beiden Zeilen 
ansteuere, deshalb dürfte in Zeile 3 und 4 ja gar nicts passieren.

Gruß

Autor: B.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei jedem Reset ändern sich in Zeile 1 und 2 die Zeichen bzw. 
Reihenfolge.

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sind Temp1 und Temp2 am Anfang wirklich definiert?
Der komplette Quellcode wäre schon hilfreich.

Autor: B.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jap sind sie, scroll doch mal runter, da ist ales dabei...

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Taktfrequenz des Mikrocontrollers zufällig höher als im Tutorial? Dann 
stimmen die Wartezeiten nicht mehr.

Wenn du nicht mal mehr Informationen gibst, kann man wohl nur raten...

Autor: B.K. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Datenleitungen sin ca. 15cm lang. Etwa zu lang???
Taktfrequenz ist 4Mhz.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.