www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USBprog von XP nicht erkannt


Autor: Jerome (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe Probleme mit USBprog:

Bootloader aufspielen über den Programmer von Codevision hat 
funktioniert, USBprog wurde von XP erkannt und installiert und war auch 
im USBprog Flashtool als USBprog(unprogrammiert)zu sehen. Zu Testzwecken 
wurde Led-Blink erfolgreich installiert und daraufhin die
Firmware AVRISP mk2 clone.

Soweit alles in Ordnung. Doch nach dem Aufspielen der Firmware wird 
USBprog nicht mehr von XP erkannt, XP meldet laufend neues USG-Gerät 
(AVR ISP Clone) gefunden und will einen Treiber installieren was nicht 
geht, da keine Software gefunden wird.

Die Software installer.exe, den Bootloader und die Firmware habe ich 
mehrfach neu installiert sowie mehrere USB-Anschlüsse durchprobiert und
komme immer wieder zum gleichen Ergebnis, USBprog wird nur erkannt, 
nachdem der Bootloader (neu) programmiert worden ist und keine Firmware 
geladen wurde.

Kann mir jemand bei diesem Problem weiterhelfen ?

Gruß
Jerome

Autor: Sebastian D. (bineuling)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Jerome,

ich hatte das selbe Problem. Bei mir wurde der Stick nur mit dem 
Bootloader oder der Blinklichtfirmware erkannt. Der Stick mit 
AVRISP-Firmware wurde zwar im Gerätemanager erkannt aber Windows meldete 
dass kein Treiber installiert sei.
Ich habe das Problem folgendermaßen gelöst:
- Rechte Maustaste, "Treiber installieren"
- in bestimmter Quelle nach Treiber suchen: c:\windows\system32

das war´s !

P.S: Du musst natürlich bei der Installation von AVRStudio den 
hauseigenen USB-Treiber mitinstallieren (wird dir bei der Installation 
als Option angeboten)

MFG

Sebastian

Autor: Daniel der Drüsendieb (druesendieb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe ein ähnliches Problem:
Der USBprog 3 ist schon ein Jahr alt, wurde noch nie benutzt und enthält 
schon den AVRISP mk2 clone.

Ich habe das GUI + Libusb unter XP Pro installiert, dann den USBprog 
angeschlossen.

Es öffnet sich der Treiber-Installationsdialog von XP. Die automatische 
Treiberinstallation scheitert, weil sie keinen Treiber findet.

Auch der Tipp von Sebastian Deubl führt zu keinem anderen Ergebnis.

Im GUI bleibt deshalb die Device-Combobox leer, das Teil ist nicht 
ansprechbar.

Was tun?

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal ne koppix CD einwerfen und lsusb fragen ;)

Autor: Daniel der Drüsendieb (druesendieb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lsusb meldet "Atmel Corp."

Autor: Teplotaxl X. (t3plot4x1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht mal usbprog aus dem Gerätemanager entfernen

Autor: Daniel der Drüsendieb (druesendieb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hab ich schon mehrfach gemacht und dann wieder USB-Geräte suchen 
lassen, mit oder ohne Reboot - es hat sich nichts geändert.

Autor: Daniel der Drüsendieb (druesendieb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Offenbar ist das Drecksding so kaputt, daß es den USB-Port demoliert 
hat.

Bevor ich es dort angeschlossen hatte, funktionierte er noch, jetzt wird 
der Kartenleser, den ich immer an diesen Port angeschlossen hatte, auch 
nicht mehr erkannt.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.