www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AC-Störung auf +15Vdc


Autor: Mathias U. (munter)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen,

ich habe ein elektrisches Problem, bei dem ich derzeit nicht so recht 
weiterkomme.

Folgende Grundsituation:
Ich habe ein Netzteil gebaut, welches u.A. die Spannungen +-15V liefert.
Der Schaltplan für diesen Teil ist im gepackten Anhang enthalten...

Desweiteren habe ich eine Platine, welche mir von einem belibigen 
Eingangs- signal den Effektivwert ausgibt. Dieser kann dann auch noch 
gleich logarithmiert werden. Schaltkreis ist der AD637. Auch dieser 
Schaltplan ist im Anhang enthalten. Die eingezeichnete 
Kennlinienanpassung dient der Anpassung an die Wandlerkennlinie meiner 
AD-Wandler...

Jetzt zum Problem:

Wenn ich meine Platine mit den Spannungen MEINES Netzteiles Betreibe, 
liegt auf der +15V-Leitung AC-mäßig eine Störung drauf. Diese ist im 
Bild mein-NT.jpg zu sehen.
Die Spannung aus dem Netzteil ohne irgendwelche Platinen dran sieht 
"normal" aus. Es ist AC-mäßig nen winziges Ripple zu sehen, aber sonst 
ok.

Schließe ich nun statt meines Netzteiles ein Labornetzteil an, tritt 
dieses Phänomen nicht auf. Zu sehen auf dem Bild labor-NT.jpg. In etwa 
so sieht auch die Soannung aus meinem NT aus, wenn die besagte Platine 
nicht dran ist...

Ich habe noch weitere Platinen die +-15V benötigen. Sind diese an meinem 
NT dran, aber die RMS-Platine nicht, tritt dieses Phänomen auch nicht 
auf.
Die Betriebsspannung vom NT wird auf meine Hauptplatine geführt, und von 
dort aus sternförmig verteilt.

Diese Zacken in der Spannung treten alle 10ms auf, also mit einer 
Frequenz von 100Hz.
Das blöde ist nun, das DAS Teile meiner anderen Schaltungen beeinflusst.
Und zwar SO, das ich es nicht tollerieren kann.

Ich steh jetzt ein wenig auf dem Schlauch. Was kann man da machen? Weiß 
jemand Rat?
dankeschön!

Autor: Magnus Müller (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Mathias U. wrote:
> Guten Morgen,

Morgen ;)


> Folgende Grundsituation:
> Ich habe ein Netzteil gebaut, welches u.A. die Spannungen +-15V liefert.
> Der Schaltplan für diesen Teil ist im gepackten Anhang enthalten...

Ich hab das Wesentliche (NT-Schaltplan + Oszibild) mal eben als Bild 
angehängt.

> Desweiteren habe ich eine Platine, welche mir von einem belibigen
> Eingangs- signal den Effektivwert ausgibt. Dieser kann dann auch noch
> gleich logarithmiert werden. Schaltkreis ist der AD637. Auch dieser
> Schaltplan ist im Anhang enthalten. Die eingezeichnete
> Kennlinienanpassung dient der Anpassung an die Wandlerkennlinie meiner
> AD-Wandler...

Das ist bei deinem Problem erst mal Nebensächlich.

Du kannst das Problem relativ einfach lösen:

C11 kann komplett eliminiert werden. Statt dessen solltest du parallel 
zu C12 und C15 große Cs (versuchs mal mit 4700µ) hängen.

Gruß,
Magnetus


[Edit]

Um Falk Brunner zuvor zu kommen: ja, ich weiss, dass ich gerade eben ein 
Bild als JPG angehängt habe. Aber hätte ich es als PNG angehängt, hätte 
es an Stelle von 57,1KB satte 324KB belegt.

[/Edit]

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tia, entweder ich hab mich falsch ausgedrückt, oder Du hast es falsch 
verstanden:

Die Spannung (+15V) aus meinem Netzteil sieht NUR DANN so aus, wie auf 
dem Bild, WENN meine RMS-Platine dran ist! Ohne diese Platine, auch wenn 
alle anderen Platinen an den +-15V hängen, sieht die Spannung "normal" 
aus, wie gesagt, bis auf ein klitzekleines AC-Ripple...

Autor: sechszweisechs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10uF ist vielzuwenig. Man rechnet 1500uF oder so pro Ampere am Ausgang.

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 10µ am Ausgang sind der Vorschlag aus dem Datenblatt...

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Magnus Müller (magnetus)

>[Edit]

>Um Falk Brunner zuvor zu kommen: ja, ich weiss, dass ich gerade eben ein
>Bild als JPG angehängt habe. Aber hätte ich es als PNG angehängt, hätte
>es an Stelle von 57,1KB satte 324KB belegt.

>[/Edit]

Als PNG mit 256 Farben sinds nur 98kB, überaus akzeptabel.

MfG
Falk

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Mathias U. (munter)

>Die 10µ am Ausgang sind der Vorschlag aus dem Datenblatt...

Es geht um dem EINGANG, also den Pufferkonsensator nach dem 
Gleichrichter. Wobei ich die Schaltung merkwürdig finde, ein Mischung 
aus Brücken und Mittelpunktgleichrichter. Ich halte das für keine gute 
Idee. Lieber normale Mittelpunktschaltung und dann ZWEI grosse 
Kondensatoren zur Stabilisierung von V+ und V-.

MFG
Falk

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:
> Als PNG mit 256 Farben sinds nur 98kB, überaus akzeptabel.

Tja, aber die 57,1KB sind dann doch noch weniger ;) Ich habe auch darauf 
geachtet, dass die visuelle Information erhalten bleibt.

Nun aber genug des off topic gesabbels ;o)

Gruß,
Magnetus

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Falk

Die Gleichrichterschaltung ist schon okay, eine ganz normale 
Mittelpunktschaltung für duale Spannungsversorgung!
Nur der Ladeelko C11 sollte aufgeteiltr werden, so wie Magnus schon 
erwähnte.

@Mathias

Wie hoch ist denn der Stromverbrauch der Schaltung?
Messe doch mal mit dem Oszi, ob vor dem 7815 auch schon die Spannung 
einbricht!?

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sechszweisechs wrote:
> 10uF ist vielzuwenig. Man rechnet 1500uF oder so pro Ampere am Ausgang.

Darauf hab ich geantwortet...und es gibt nur zwei 10µ C's in der 
Schaltung, und die sind am Ausgang. Ist aber auch egal.

Nochmal: Wenn ich das Netzteil mit allen meinen andren Platinen 
betreibe, geht es wunderbar, ABER wenn ich die RMS-Platine dranhänge, 
dann bekomme ich dieses komische Phänomen.

Jetzt ist für mich die Frage: Warum? Und wie löse ich das Problem?
danke

*edit: Die RMS-Platine ohne anliegende Signale zieht 14mA auf der 
+15V-Schiene...

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mathias U. wrote:
> Jetzt ist für mich die Frage: Warum? Und wie löse ich das Problem?
> danke

Die Lösung hast du doch schon serviert bekommen.

[Edit]

Die ganz schnelle Lösung: löte mal eben einen 4700µF/35V Elko parallel 
zu C12 und du wirst glücklich.

[/Edit]

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Mathias U. (munter)

>Nochmal: Wenn ich das Netzteil mit allen meinen andren Platinen
>betreibe, geht es wunderbar,

Klar, Leerlauf.

> ABER wenn ich die RMS-Platine dranhänge,
>dann bekomme ich dieses komische Phänomen.

Mit Last.

>Jetzt ist für mich die Frage: Warum? Und wie löse ich das Problem?

C11 raus, C12 und C15 jeweils auf 2200uF erhöhen.

MFG
Falk

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
warum haben C12 u. C15 unterschiedliche Werte u. unterschiedliche 
Bauarten ???

warum haben C13 u. C16 unterschiedliche Werte u. unterschiedliche 
Bauarten ???

das ist doch Quatsch! das müssen beides Keramik oder Folien C's sein.

Elkos haben bei den 78xx/79xx da nix zu suchen.

lg
Peter

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So - und jetzt zu dem Warum :

Ich rufe nochmals die Werte der drei Cs, welche nach dem Gleichrichter 
sitzen, ins Gedächtnis:

   C11    4700µF
   C12    0.33µF
   C15    2.2µF

Es ergibt sich für die Glättung der eingangsseitigen positiven Spannung 
folgende "Ersatzkapazität":

   C = C12 + ( C11 || C15 )

     = 0.33µF + 2.199µF

     = 2,529µF

Und mit dieser Kapazität willst du unter Last ausreichend 
Energiereserven für 10ms speichern?

Gruß,
Magnetus

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Magnus Müller

oh Mann,

guck dir endlich mal das Datenblatt für die Regler und die 
Schaltbeispiele an.

so einen Quatsch wie das oben hab ich schon lange nicht mehr gelesen.

mir stellt sich die Frage, ob dir überhaupt die Funktionsweise von so 
einem
Netzteil mit Festspannungsreglern bekannt ist.

Ich wills mal für dich in Worte fassen.

Trafo --> Gleichrichter --> großer Elko zur PUFFERUNG u. SIEBUNG

vertisch.

Festspannungsregler bekommen direkt an Ein u. Ausgang einen kleinen 
Keramischen oder Folienkondensator verpasst, damit sie NICHT schwingen.
Zusätzlich kann man als Stützkondensator am Ausgang noch einen KLEINEN
Elko verwenden.

vertisch.

um deinen Grundlagen noch mal ein bissel auf die Sprünge zu helfen,
guck dir das mal an.
http://www.elektronik-kompendium.de/public/schaere...
und das da.
http://www.elektronik-kompendium.de/sites/bau/0204301.htm


lg
Peter

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...auf wessen Aussage beziehst Du Dich bitte?

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
auf deine im Post vorher

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du meinst die Aussage von  "Magnus Müller"??
Evtl. wäre ein @... besser gewesen...

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mathias U. wrote:
> ...auf wessen Aussage beziehst Du Dich bitte?

Peter S* wrote:
> auf deine im Post vorher

Mathias U. wrote:
> Du meinst die Aussage von  "Magnus Müller"??
> Evtl. wäre ein @... besser gewesen...

Oh mann...

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups..

tschuldigung habs geändert ;-)

lg
Peter

.... gild aber auch für deine Schaltung

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Himmel Ar*** und Zwirn! Ich habe nie davon gesprochen, dass am Ausgang 
der Spannungsregler ein großes C hin soll! Es war von den SIEBELKOS 
die Rede!

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Magnus Müller wrote:
> Himmel Ar*** und Zwirn! Ich habe nie davon gesprochen, dass am Ausgang
> der Spannungsregler ein großes C hin soll! Es war von den *SIEBELKOS*
> die Rede!

Magnus,

du hast aber die Frage WARUM beantwortet.

C12 ist aber kein Siebelko sondern ein normaler abblock C

un genau der fehlt beim 79xx Regler am EIN u. AUSGANG

lg
Peter

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Shit... die Verlinkung funktioniert nicht richtig...

...dann also anders:


Peter S* wrote:
> C12 ist aber kein Siebelko sondern ein normaler abblock C

Der Vorschlag, C12 und C15 auf 2200µF zu erhöhen kam nicht von mir, 
sondern von Falk Brunner!

(siehe Falks Beitrag vom 23.11.2007 11:17)

>> C11 raus, C12 und C15 jeweils auf 2200uF erhöhen.
>>
>> MFG
>> Falk


> un genau der fehlt beim 79xx Regler am EIN u. AUSGANG

Und genau das habe ich bemängelt!

(siehe mein Beitrag vom 23.11.2007 10:45)

>> Du kannst das Problem relativ einfach lösen:
>>
>> C11 kann komplett eliminiert werden. Statt dessen solltest du parallel
>> zu C12 und C15 große Cs (versuchs mal mit 4700µ) hängen.
>>
>> Gruß,
>> Magnetus

Die Betonung liegt dabei auf parallel zu C12 und C15.

Genervter Gruß,
Magnetus

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...und:

Ja, ich bin auch der Meinung, dass C15 und C16 keine Elkos, sondern 
zumindest keramische Cs zu sein haben. Ausserdem können diese wertemäßig 
auch kleiner ausfallen.

Autor: Peter S* (sandmannnn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na gut,

da ist wohl einiges durcheinander gekommen.

eines ist wohl jetzt eindeutig klar,

die Schaltung von  Mathias U. (munter) ist nicht das gelbe vom Ei.
( jetzt hab ich mich sehr vorsichtig ausgedrückt )

und für Ihn sind die Links zum Elektronik-Kompendium und der Verweis auf
die Datenblätter.

lg
Peter

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Magnus Müller (magnetus)

>> C12 ist aber kein Siebelko sondern ein normaler abblock C

>Der Vorschlag, C12 und C15 auf 2200µF zu erhöhen kam nicht von mir,
>sondern von Falk Brunner!

Richtig. Aber man sollte mal die Kirche im Dorf lassen. Für einen 78xx 
ist ein Elko immen noch HF-tacglich. Das ist KEIN schneller Digital IC, 
sondern eher ein langsamer Analog-IC. Das mit Keramik/Filoeinkondensator 
ist eine Legende. Die 78xx sind OHNE Ausgangs-C stabil, allerding werden 
minimal 100nF empfohlen, aber nicht zwingend. Und da es keine 100nF 
Elkos gibt nimmt man halt Keramik oder Folie. Dito für den Eingangs-C.

MFG
Falk

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Peter S*
@ Falk Brunner

Mir hat es nur gestunken, dass hier einiges durcheinandergeraten war 
(hat Peter ja schon festgestellt) und meine Infos als falsch dargestellt 
wurden.

Nix für Ungut ;)

Magnetus

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@falk

Und es gibt sie doch  RAD 0,1/100  100nF Elko bei Reichelt

Autor: Peter S* (sandmannnn)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
so jetzt mal mit Zitat !!!


Falk Brunner wrote:
> @ Magnus Müller (magnetus)
>
>>> C12 ist aber kein Siebelko sondern ein normaler abblock C
>
>>Der Vorschlag, C12 und C15 auf 2200µF zu erhöhen kam nicht von mir,
>>sondern von Falk Brunner!
>
> Richtig. Aber man sollte mal die Kirche im Dorf lassen. Für einen 78xx
> ist ein Elko immen noch HF-tacglich. Das ist KEIN schneller Digital IC,
> sondern eher ein langsamer Analog-IC. Das mit Keramik/Filoeinkondensator
> ist eine Legende. Die 78xx sind OHNE Ausgangs-C stabil, allerding werden
> minimal 100nF empfohlen, aber nicht zwingend. Und da es keine 100nF
> Elkos gibt nimmt man halt Keramik oder Folie. Dito für den Eingangs-C.
>
> MFG
> Falk

@Falk

dann frage ich mich, warum in allen Schaltungen die mir bekannt sind,
parallel zum Puffer Elko noch ein kleiner C geschaltet ist.
Und vor allem, warum in jedem Datenblatt darauf hingewiesen wird, das 
diese
kleinen C's so dicht wie möglich an den Regler sollen!

ich habe jetzt noch mal ein Bild von so einem Netzteil angehängt.
und hier ist der Link dazu, wo alles genau erklärt ist.
http://www.elektronik-kompendium.de/public/schaere...

Falk,
du magst das mit den kleinen Block C's für eine Legende halten!
aber ich nicht.
Da es bis jetzt immer diese fehlenden C's waren, wenn eine Schaltung
nicht funktioniert hat. bzw Rippel auf der Ausgangsspannung war.


lg
Peter

Autor: Mathias U. (munter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe jetzt mal folgendes gemacht:

Parallel zu C12 und C15 hab ich nen 1mF C reingemacht...und die Sache 
sieht schon wesentlich besser aus.
Ich werde dann noch den C16 gegen einen 100n Keramik, den C15 gegen 
einen 330n MKT (wie den C12) und den C11 raus machen...

Autor: sechszweisechs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nochwas. Weshalb sollte pro Teilspannung, dh fuer den positiven Kanal, 
sowie fuer den negativen Kanal je ein Siebelko verwendet werden ? (Ich 
beziehe mich auf das erste bild in diesem Thread) Dh C11 duer 2 stueck 
ersetzen. ? Nehmen wir mal an, die beiden Zweige brauchen 
unterschiedlich Strom... zB 1A am Plus, 50ma an Minus. Bitte 
nachdenken....

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@sechszweisechs

Eben deswegen hat er ja das Problem.

Autor: Falk Brunner (falk)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@ Peter S* (sandmannnn)

>dann frage ich mich, warum in allen Schaltungen die mir bekannt sind,
>parallel zum Puffer Elko noch ein kleiner C geschaltet ist.

Das ist das Problem solcher Legenden. Alles plappern die nach ohne zu 
denken ud kritisch zu prüfen.

>Und vor allem, warum in jedem Datenblatt darauf hingewiesen wird, das
>diese
>kleinen C's so dicht wie möglich an den Regler sollen!

Nochmal, es ist ein LANGSAMER Analog-IC. Der macht bestenfalls 1 MHz, 
wenn überhaupt.
Und die Formulierung "so dicht wie möglich" ist vor allen strategischer 
Natur, damit nicht irgendwelche Nasen das Ding nen halben Meter weit ans 
andere Ende der Platine setzen und dann rumjammern, wenns nicht geht.

>ich habe jetzt noch mal ein Bild von so einem Netzteil angehängt.
>und hier ist der Link dazu, wo alles genau erklärt ist.
>http://www.elektronik-kompendium.de/public/schaere...

Nix gegen deas ELKO und Thomas S., aber das ist ja nun nicht wirklich 
DIE Referenz.

http://www.fairchildsemi.com/graphics/datasheet.gif

Seite 23

2. CI is required if regulator is located an appreciable distance from 
power supply filter.
3. CO improves stability and transient response.

VRBESSERT, aber nicht zwingend notwendig (so wie bei einigen Low-Drop 
Reglern!). Der gute alte 7805 ist von Hause aus stabil, siehe Anhang.

>du magst das mit den kleinen Block C's für eine Legende halten!
>aber ich nicht.

Das ist das Problem von Legenden. Die Leute glauben, anstatt zu denken.

MFG
Falk

Autor: Arno H. (arno_h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
15V Trafo und 15Volt geregelte UAus mit 7815 ist auch nicht eben der 
Brüller.
Die Schaltung aus dem elko ist übrigens für LDO ausgelegt, die diese Cs 
eher brauchen als die Standardregler.

Arno

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.