www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Gameboy Kamera Modul


Autor: Steffen Burr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich versuche mich gerade an einer Anteuerung eines Gameboy
Kameramoduls.

Die ganzen Signal (zum Einstellen der Register, etc.) habe ich mit
meinem Oszi überprüft. Die sollten eigentlich alle stimmen.

Dann habe ich versucht, die Spannung, die für jeden Pixel ausgegeben
wird an meinem Oszi darzustellen. Leider liegt an dieser Leitung immer
nur 5 V an.
Das READ Signal zeigt allerdings, dass die Daten ausgegeben werden
müssten. Ich vermute, dass es an der Einstellung der Register in dem
Kameramodul liegt, da evtl. die Belichtungszeit zu lang ist. Leider
finde ich aber den Fehler nicht.
Auf der Signalleitung liegt auch dann 5V, wenn das Bild nicht
ausgelesen werden darf ...

Die Ansteuerung habe ich nach folgender Anleitung gemacht:
http://www.angelfire.com/de3/juliprograms/amr/gbcam.htm

Programmiersprache ist CodeVision und der uC ein 4433.

Vielleicht hat jemand von euch eine Idee, woran das liegen kann.

Danke!
Steffen

PS: Falls jemand das Programm anschauen möchte, stelle ich es
selbstverständlich online.

Autor: Roman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gibt es Alternativen bei z.B.: Conrad die auch so angesteuert werden
können?

Autor: Steffen Burr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Roman: ob es den Chip auch bei Conrad gibt, weiß ich nicht. Der Chip,
der auf dem Kamera ist ist der M64282FP von Mitsubishi.

Bei Ebay aber sehr billig zu haben.

Trotzdem wäre ich noch für eine Hilfestellung dankbar ;)

Autor: Bastian Nordmeyer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ok, dieser Thread ist ein wenig alt, aber ich habe nun auch eine
Schaltung zum Auswerten einer GB-Cam aufgebaut, und stoße auf das selbe
Problem.

Will die GB-Cam I2C fähig machen,deswegen besteht meine Schaltung aus
einer PCF8574P Porterweiterung sowie einem PCF8591 AD-Wandler.

Besitze kein Oszi, deswegen bin ich in meinen Möglichkeiten ein wenig
eingeschränkt.

Die PCF's + GB-Cam sitzen an einer stabilisierten Stromquelle, habe in
der Schaltung nicht für eine weitere Stabilisierung gesorgt.
Ist die GB-Cam sehr Spannungsschwankung anfällig, könnte es daran
liegen?


Habe mal den genutzen Code (avr-gcc) als Anhang angehängt.
Hoffe ihr könnt mir weiterhelfen...

mfG

Bastian Nordmeyer

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.