www.mikrocontroller.net

Forum: PC Hard- und Software zu wenig power am usb - usb mit usb speisen


Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallöchen zusammen.

Ich habe ein IBM Laptop t30 2.4 Ghz Leider leider hat dieser noch keine 
USB 2 schnittstelle sondern nur usb 1.
deshalb habe ich mir schon lange eine PCMCIA karte angeschafft welche 
mir 2 Usb2 schnittstellen bietet.
Ich arbeite hauptsächlich auf einer externen 2.5" HD welche alleine 
(ohne externe stromversorgung) leider nicht betreibbar ist am usb2 
bzw.PCMCIA, allerdings am originalen usb 1 schon.
nun hab ich mir überlegt: es gibt doch diese Usb lade geräte welche eine 
5V spannung ausgeben (für natel Gps PDA, Leselampe etc...)und man am PC 
einstecken kann... Meine PCMCIA karte braucht logischerweise auch 5V. 
Könnte man nun nicht die PCMCIA Karte mit einer Alten usb1 schnittstelle 
mit spannung versorgen?
oder würde sich da etwas in rauch verwandeln???

was meint Ihr dazu?

grüsse aus dem Wald....

Autor: Ein Name (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Google nach "USB Y-Kabel". Taug zwar nichts, machen aber viele.

Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe gelesen, dass ein usb standartmässig 500mA bringt. ist das Bei 
PCMCIA host controller Weniger oder Liegt das an der Usb karte selbst, 
dass zu wenig power kommt. an jedem direkten usb reicht es.

würde eine andere PCMCIA karte villeicht funz

das mit dem usb kabel könnte gehen allerdings vermutlich nur wen ich 
original USB 1 Mit dem PCMCIA USB2 verbinde... und das geht?

sind dan bei diesen Y kabeln nur die stromversorgungspins belegt(ohne 
datenleitungen?)

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sind dan bei diesen Y kabeln nur die stromversorgungspins
>belegt(ohne datenleitungen?)

Ja. Natürlich gehen zu dem einem Y-Zweig auch die Datenleitungen.

Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der tatsache an, dass meine HD am einen usb geht und am andern nicht, 
sagt ja das diese eine unterschiedlich hohe stromabgabe haben. gibt dann 
das kein problem wenn ich diese verbinde....

sorry hab nur keine lust meine internen usb zu verheizen....

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Verwende ein externes Netzteil.

Alles andere ist nicht-standardkonformer Pfusch. Einem USB-Port dürfen 
ohne weitere Vorbereitungen maximal 100 mA entzogen werden, mehr (bis 
500 mA) sind erst nach Anmeldung durch ein USB-Device und Zustimmung 
durch den USB-Host-Controller zulässig.

2.5"-Platten ziehen Anlaufströme von über 1 A und liegen damit weit 
außerhalb jedweder USB-Spezifikation.

Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eben genau das ist das Problem...
es ist mir nicht immer möglich ein netzteil zu betreiben. und ständig 
einen akku dabei zu haben für die HD ist auch doof.

Am usb1 platz würde sie ja laufen... nur am usb 2 nicht aber 160 Gb 
festplatte mit usb 1 ist nicht so lustig...

zwei usb koppeln wär schon toll, wenns geht...

wenn du sagst das die 500 erst nach anmeldung zu verfügung stehen, 
bedeutet das, das ja wahrscheinlich nur 100 ma dazukommen werden. weil 
ja nur VCC und GND vom zusätzlichen gezogen würden, was vermutlich für 
eine anmeldung nicht reichen wird....

ich habe nichts gegen eine bastellösung, sie muss einfach 
funktionieren... und nicht zerstören.

kann man so ein usb port nicht manuel anmelden damit die 500mA zu 
verfügung stehen?

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der USB-Host-Controller schlecht(billig) implementiert ist, liefert 
er immer 500mA, auch ohne extra Anforderung. Dann kannst du mit so einem 
Pfusch-Y-Kabel was machen.

Ich denke mal, es könnte so sein. Die HDD meldet dem Controller, dass 
sie nur 100mA benötigt, zieht aber trotzdem 500mA (meist ja noch viel 
mehr). Den alten 1.1 Controller auf dem mainboard scheints nicht zu 
stören, er liefert generell immer 500mA, die HDD funzt.
Der vielleicht etwas besser nach Standard implementierte 2.0 Controller 
auf der PCMCIA Karte liefert der HDD nur die angeforderten 100mA, und 
die HDD geht nicht.

Manuell kann man gar nix anfordern, das läuft über die Desriptoren des 
USB Devices.

Lade dir mal USBVIew von MS runter, und schau nach, wieviel Strom die 
HDD anfordert. Das steht da drin, bei bMaxPower.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du könntest als Pfusch-Murks-Lösung ein USB-Y-Kabel verwenden, dessen 
datenleitungsloser Teil in den USB1.1-Port des Notebooks und dessen 
anderer Teil in den USB2.0-Port der Cardbus-Karte gesteckt wird.

Mit so etwas wirst Du nicht mehr zerstören als mit direktem Anschluss 
einer 2.5"-Platte an einen einzelnen Port.

Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jawohl, ich habe jetzt ein usb Verlängerungskabel beim Stecker geöffnet 
(bitte nicht lachen...) und ein anderer stecker mit kabel bei den Vcc 
und GNd kontakten und natürlich auch den schirm verbunden. 
eingesteckt.... ....bildschirm schwarz.... ;-(

dieses elende schema war so doof gezeichnet!!!!!!!!! sooo Doooof!!! 
....Kontakte umlöten , einstecken und gut war... habe natürlich zuerst 
am pc meines Bruders ausprobiert.... ;-)

und tatsächlich, auch meine HD läuft am Laptop nun ohne netzteil. Geht 
allerdings wirklich nur wenn ich den saft beim alten usb 1.1 abzapfe. 
beim usb 2.0 tut sich nix. aber das is ja egal... usb 2.0 als 
datenschnittstelle und USB 1.1 taugt gerade noch um strom zu liefern....

Autor: Karl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dir ist schon klar, dass solche Kabel überall erhältlich sind?

Autor: Lii Schmutz (Firma: nikolaus INC) (lii-schmutz-lii)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
:-)
wirklich?

ja natürlich, aber ich wollte es eben sofort ausprobieren, und wenns 
nicht gefunzt hätte dann wären die 10euronen für die katz gwesn. zudem 
habe ich genug verschnippselte usb kabel....

Autor: Karl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na dann is ja alles in Butter.

Nur gut, dass du nicht noch den PC deines Bruders zerschossen hast. :-)

Autor: Wolfram Quehl (quehl)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bei mir hat das auch nicht funktioniert. Ich dachte, es würde an meinem 
BS Win98 liegen. Mit welchem BS funktioniert das bei Dir? Dann will ich 
das so auch noch mal ausprobieren.

mfg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.