www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ARM Radio Reparatur


Autor: T.M .x (max)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe so ein schönes Radio mit einem Netzwerkanschluss. Nun 
funktioniert es nicht mehr so ganz. Das ganze basiert auf einem Samsung 
ARM(Barracuda Modul). Zunächst hatte ich an eine unsaubere 
Versorgungsspannung gedacht, aber auf dem Oszi sehen die 5V & 3,3V 
sauber aus. Dieser ARM steuert u.a ein Display. Mir sieht es so aus, als 
ob die Ausgänge alle Spannung ausgeben bzw etwas mit der Kommunikation 
nicht stimmt.
Wißt ihr, was eine Fehlerquelle sein könnte? Ich kenne es von den AVR, 
wenn etwas mit dem Quarz nicht stimmt, dass nur wirres Zeug raus 
kommt(UART). Ich denk mal das das beim ARM auch so ist.
Hier ist noch eine Beschreibung vom Modul: 
http://corporate.reciva.com/products_and_technolog...


So sieht das Display aus; es werden offenbar alle Pixel angesteuert (;
http://img135.imageshack.us/img135/8183/logikfaulthy1.jpg

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>So sieht das Display aus; es werden offenbar alle Pixel angesteuert (;

Sieht so aus als wenn das Display nicht initialisiert wird.
Das könnte bedeuten: Der ARM läuft einfach nicht mehr.
Quarz defekt wäre möglich. Ist das Teil mal runtergefallen ?

Autor: T.M .x (max)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es wurde mit der Post von England nach Deutschland geschickt (;  Es lief 
einige Wochen. Manchmal, wenn man die Stromversorgung trennt/wieder 
verbindet, dann funktionierts. Zunächst hatte ich ja Kondensatoren im 
Verdacht. Einen hatte ich erwärmt dann gings. War er kalt, war der 
FEhler wieder da. Nun habe ich diesen und die anderen 4 aber getauscht 
und es funktioniert genausowenig.

Ich muss dazusagen, dass dieses Modul auf einer Platine steckt und dort 
sind die beschriebenen ELKOs. Das MOdul ist als SMD aufgebaut, aber das 
Display ist dort direkt angeschlossen

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Zunächst hatte ich ja Kondensatoren im
>Verdacht. Einen hatte ich erwärmt dann gings. War er kalt, war der
>FEhler wieder da. Nun habe ich diesen und die anderen 4 aber getauscht
>und es funktioniert genausowenig.

Das hört sich nach kalter Lötstelle an. Besorg dir schon mal
ne Pulle Kältespray. Was passiert denn wenn du das ganze Gerät
warm machst ? Einfach mal auf die Heizung legen.

Autor: T.M .x (max)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das ganze mal mit einem Fön heiß gemacht, aber da hat sich 
nichts geändert. Da ich kein Kältespray hier habe, habe ich alles mal 
raus gelegt. Es  war dann auch schön kalt. Aber Beides hatte nichts 
gebracht...

EDIT: Ich habe gerade versucht den Quarz auszulöten(ist ein HC49-SMD) 
aber mit einem normalen Lötkolben ist das recht schwierig...momentan 
läuft das Radio bzw der ARM (;

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm mal ein Stück hartes Plastik und drück damit auf die SMD Teile.
Bei den ICs auch direkt auf die Lötstellen drücken.

Autor: T.M .x (max)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo holger,

danke für deine Tipps. Ich werde es gleich noch mal versuchen. 
Vielleicht baut Grundig nun ARM-Radios ^^

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.