www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik NE555 Rechtecksignal Form


Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe hier einen NE555 so beschaltet dass er als astab. Kippstufe 
arbeitet (wie in Datenblatt). Mir gefällt aber das Rechtecksignal nicht 
wirklich, ich habs mal angehängt. Meine Frage (rein qualitativ): Ist das 
Signal so normal oder nicht? Mein Prof meint nicht. Hab jetzt aber alle 
Teile ausgetauscht (bis auf Kondensator).

Autor: Christian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Skalierung?

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie geschrieben, qualitativ... Aber Vcc = 5V, Peaks bei ca. 5,8V, 
flacher Teil von High-Zeit bei ~4,6V.

Frequenz ~100kHz

Ich wollte nur wissen ob ich da ein sehr gutes Rechtecksignal erwarten 
kann oder ob so ein Ding wie bei mir rauskommt normal ist.

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frage:

Hast du die Versorgungsspannung dicht am IC mit einem Kondensator 
abgeblockt ?  (Ca. 100nF)


Das du kein Tastverhaeltnis von 50 % erwarten kannst ist dir klar ?

Gruss Helmi

Autor: Detlev T. (detlevt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Signal ist so nicht normal. Aber hast du schon einmal in Erwägung 
gezogen, dass der Signalverlauf ein Artefakt aus deiner Messaparatur 
ist? Merke:

Wer misst, misst Mist. Wer viel misst, misst viel Mist.

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Helmi

ich hatte sogar zwei Kondensatoren drin (100nF + 47u), hat rein gar 
nichts gebracht. Das mit Tastverhältnis is schon klar, Diode is zwecks 
Fehlersuche erstmal rausgeflogen

@  Detlev T.

ich habs ja schon geahnt, wollte's aber nicht wahrhaben. Das kann schon 
sein das ich da besser mal ne kleine Platine ätzen sollte bei 100kHz. Da 
weiß ich ja was ich heute abend tun kann.

Autor: DuDöddelDie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist ein typische Oszillogram eines schlechten Aufbaus, bzw. einer 
schlechten Messanordnung. Bei 100kHz musst du einen jungfräulichen, 
sauberen Rechteck messen.

Beim Messen gehört der GND-Anschluss des Oszikabels an den GND-Anschluss 
des NE555.
Ist der Tastkopf korrekt kompensiert? Passt der zum Oszi?

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Platine aetzen brauchst du nicht unbedingt.
Kannst den NE555 auf dem ruecken liegend auf  ungeaetzten 
Platinenmaterial festloeten und die restlichen Bauteile so kurz wie 
moeglich drumherum bauen.

Zum Messen:

Wenn du an deiner Messpitze den Massering so kurz wie moeglich mit dem 
GND der Schaltung verbindest solltes du bessere ergebnisse bekommen.
Ich mache dazu immer folgendes:
Etwas blanken Draht zu einer Spirale aufwickeln. Der Durchmesser sollte 
dem Massering der Tastkopfspitze entsprechen. Das andere ende des 
Drahtes an GND loeten. So hast du die kuerzeste Verbindung mit Masse. 
Das Massekabel des Tastkopfes dabei nicht anschliessen.

Gruss Helmi

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ DuDöddelDie

Ja das passt alles. Ich bastel auch gerade an nem Hochsetzsteller, 
musste mich also mit dem ganzen thema "wie messe ich sowas" 
beschäftigen. Ich denke das liegt an meinem Aufbau auf Lochraster, das 
sieht ziemlich wüst aus, nix mit großer Massefläche o.Ä. Deshalb erstmal 
die Platine, is ja klein und schnell gemacht ... es lebe die 
Toner-Transfer Methode.

Gruß

Gepi

Autor: DuDöddelDie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achso, nochwas: Der NE555 ist die Bipolare Ausführung des Timers, der 
zieht einen höheren Strom, auch während des Umschaltens, als die 
CMOS-Ausführung. Für Neuentwicklungen sollte man nur noch den CMOS-Typen 
verwenden.

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
soooo, jetzt muss ich doch nochmal nachfragen. Ich habe ein Platinchen 
geätzt und zusammen mit einer ganz kurzen Masseleitung bekomme ich auch 
ein ganz vernünftiges Signal ... aber:

Ich habe mit dem Kondensator gespielt (der der dauernd geladen/entladen 
wird) und mir ist aufgefallen das mit der positiven Flanke was nicht 
stimmt. Dasselbe Bild hatte ich auch bei einem früheren fliegenden 
Aufbau.

Das erste Bild im Anhang (links) zeigt das Rechtecksignal mit f=1274 Hz. 
Das sieht so ganz gut aus, schaut man sich die Flanke aber zeitlich 
genauer an, erkennt man auf Bild zwei (mitte), dass der Spannungsanstieg 
kurz kleiner wird und dann weitergeht bis zur höchsten Spannung.

Ich hatte gedacht das passiert nur bei höheren Frequenzen wie in Bild 
drei (rechts), aber wies ausschaut ist mir das bei ein paar kHz nie 
aufgefallen weil ich nie "rangezoomt" habe.

Mein Frage nun: Ist das normal? Muss das so sein? Liegt das am internen 
Aufbau des NE555. Mein Prof. meinte nämlich da müsse wohl ein Bauteil 
kaputt sein. Kann aber nicht sein, ich habe jetzt schon alles getauscht, 
teilweise 4 mal.

Gruß
Gepi

Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
... und hier noch der Anhang ;)

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gepi (Gast)

>Das sieht so ganz gut aus, schaut man sich die Flanke aber zeitlich
>genauer an, erkennt man auf Bild zwei (mitte), dass der Spannungsanstieg
>kurz kleiner wird und dann weitergeht bis zur höchsten Spannung.

Poste mal einen Schaltplan mit Bauteilwerten.

Wenn dein Timingkondensator sehr gross ist, und der Kondensator zur Vcc 
Pufferung eher klein, dann passiert sowas.
Ausserdem ist der normale NE555 kein High-Speed Bauteil, der macht nur 
500 kHz. Da ist die Flanke schon relativ OK.

MFG
Falk

P.S. PNG ist schonmal gut. Jetzt nur noch 16 oder 256 Farben verwenden 
und es ist perfekt (denn da braucht man nur noch 43 bzw 64 kB).

Autor: Detlev T. (detlevt)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Gepi:
Im 555 arbeitet intern ein Flip-Flop. Daher kann die Beschaltung mit den 
R und C auf die Signalform eigentlich keinen Einfluss haben. Ich weiß 
nicht, ob der 555 vielleicht eine Mindestlast am Ausgang braucht, um ein 
sauberes Signal zu liefern. Schalte doch einmal 10kOhm zwischen Ausgang 
und der Versorgungspannung VCC.

(Oder hängt im Gegenteil schon etwas dahinter, wovon du uns noch gar 
nichts erzählt hast?)

Autor: Gregor B. (gregor54321)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... ein Transistor am Ausgang kann in diesem Fall die Flankensteilheit 
auch nochmal positiv beeinflussen.

Autor: Helmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht er danach aus das der Ausgangsdarlington Transistor des NE555 
dieses Verhalten produziert.

Zuerst sind beide Transistoren leitend , wenn jetzt die Ausgangsspannung 
die Betriebsspannung erreicht hat kann der Ausgangstransistor nicht mehr 
voll durchgesteuert werden. Folge der Ausgangsstrom kann nicht mehr so 
hoch werden wie am Anfang der Flanke. Jetzt uebernimmt sein 
Treibertransistor ueber den B-E Widerstand und B-E Strecke des 
Ausgangstransistors ein Teil des Ausgangsstromes. Da der aber weniger 
Strom liefern kann als der Ausgangstransistor hast du da auch eine 
langsamere Flanke am Ausgang.

Gruss Helmi

Autor: JensG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau - es ist das, was Helmi schreibt.
Weitere Variante wäre, daß der (die) Abblock-C('s) über die 
Betriebsspannung doch nicht so besonders ist (sind). Hast Du mal mit 
einem zweiten Tastkopf die Betriebspannung direkt am 555 angeschaut? 
Möglicherweise ist da zur selben Zeit ein Spannungseinbruch.

Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten, ich habe jetzt noch einen zusätzlichen 
Kondensator an die Versorgungsspannungsleitung gehängt und einen 10k 
Widerstand an den Ausgang. Jetzt sieht das so aus wie im Anhang zu 
sehen, damit bin ich zufrieden.

Also nochmal Dankeschön.

Gruß

Gepi

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gepi (Gast)

>Dateianhang: Signal_endg_ltig.PNG (6,6 KB, 24 Downloads)

Sehr schön. ;-)

>Kondensator an die Versorgungsspannungsleitung gehängt und einen 10k
>Widerstand an den Ausgang. Jetzt sieht das so aus wie im Anhang zu

Dei 10k kannst du sicher weglassen.

MFG
Falk

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist da noch was eingefallen:
Wenn ich mir die Amplitude meines Rechtecksignals anschaue dann liegt 
die unbelastet bei 4,4V, belastet bei 3,6V, und das bei 5V 
Versorgungsspannung. Kann ich das mit dem Spannungsabfall über der 
Kollektor-Emitter-Strecke des zweiten Transistors der Darlington-Stufe 
(Datenblatt ST: Q22) erklären oder ist das was anderes. Erscheint mir 
etwas hoch.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Gepi (Gast)

>die unbelastet bei 4,4V, belastet bei 3,6V, und das bei 5V
Versorgungsspannung. Kann ich das mit dem Spannungsabfall über der

Womit belastest du denn? DER NE555 bringt bis zu 200mA, da musst du 
schon ORDENTLICH Strom ziehen, um den in die Knie zu zwingen.
Bringt dein Netzteil genügend Strom.

MfG
Falk

Autor: Gepi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@ Falk

ich habe immer noch den 10k Widerstand drin. Sollten also um die 0,5mA 
fließen. Und am Netzteil liegts auch nicht, das kann 2,5A und die 
Strombegrenzung habe ich momentan bei 260mA. Ich häng mal noch mein 
Schaltbild dran, vielleicht hilft das. Ich seh da aber keinen Fehler.

Gruß

Gepi

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falk Brunner wrote:

> Womit belastest du denn? DER NE555 bringt bis zu 200mA, da musst du
> schon ORDENTLICH Strom ziehen, um den in die Knie zu zwingen.

Wie Helmi schon schrieb, hat der klassische bipolare NE555 einen 
NPN-Darlington als Pullup, mit Widerstand parallel zu BE vom zweiten 
dieser Transistoren und die Stufe 3,6V/4,4V ist eine direkte Folge 
davon. Das ist folglich normal.

http://www.ortodoxism.ro/datasheets/philips/NE_SA_...

Für ein sauberes Rechteck sind die CMOS-Versionen weitaus sinnvoller.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Gepi (Gast)

Dateianhang: ne555_PADS05.PNG (31,3 KB, 2 Downloads)

C2 ist für den bipolaren etwas knapp, da würde ich lieber 10u und mehr 
nehmen. Denn der zieht für einig hundert ns einig hundert mA :-0

Wenn du R1 auf den Anschlag von Pin3 drehst, schliesst sich der NE555 
die eigne Stromversorgung kurz. Da fehlt ein fester Vorwiderstand.

Ach ja, die Ausgangsspannung kann nur max. Vcc-1,4V werden, schliesslich 
ist der Ausgang ein Darlington. Wo ist dein 10k Widerstand?

MfG
Falk

Autor: Gepi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh Mann, das steht ja auch im Datenblatt das der bei 5V 
Versorgungsspannung normal nur 3,3V Ausgangsspannung liefert. Naja dann 
ist alles klar, danke für die Hinweise.

@ Falk Brunner
jo stimmt, Last is nicht eingezeichnet. Hängt natürlich an Pin 3.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.