www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik TDS2004B - seltsame Glitches


Autor: Marko (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe gestern ein TDS2004B Digitaloszi bekommen. Testweise vollte ich 
mal sehen ob auf der Vtarget-Spannung meines STK500 irgendwelche 
Störungen zu sehen sind. Sind sie auch, siehe Anhang, und was für 
welche! Diese treten in zufälligen Abständen von einigen Sekunden bis 
mehreren Minuten auf.

Nach einigem rumrätseln (wie kann das Board so überhaupt funktionieren) 
kam ein Schock: die Bursts treten auch auf, wenn gar nichts an den 
Tastkopf angeschlossen ist!

Ich habe mal einen Test gemacht:

Kanal 1, Masseklemme mit Tastkopfspitze verbunden
Kanal 2, Masseklemme nirgends angeschlossen
Kanal 3, Masseklemme entfernt
Kanal 4, kein Tastkopf angeschlossen

Das Ergebnis kann man auf dem Bild 2 sehen: hochfrequenter Burst (>100 
MHz), Dauer um die 200ns. Hat irgendjemand eine Erklärung dafür? Am Oszi 
kann es doch nicht liegen, wenn es ohne Tastkopf nicht auftritt, oder?

Autor: Marko (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch das 2. Bild.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mal den Fall, dass ein Analogscope alle paar Sekunden einen 
Peak anzeigte, mit oder ohne Kabel. Der nervte etwas, weil das Scope 
darauf triggerte. War bei totaler Verdunkelung dann auch leidlich zu 
erkennen. Allerdings war der sehr schön regelmässig: Es war das Radar 
vom nahe gelegenen Flughafen.

M.a.W: Sowas kann auch von aussen "durch die Luft" kommen. In diesem 
Fall recht wahrscheinlich: Du fängst dir das durch die Masseleitung der 
Klemme ein, die wirkt als Antenne.

Autor: Harald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich vermute Du hast die Tastkopfmasse zentral an die Stromversorgung 
über ein "längeres" Kabel angeschlossen. Dann kommt es genau zu dieser 
Erscheinung. Es ist die Induktivität der langen Masseleitung. Nehme nur 
die kurze Tastkopfmasse und suche dir einen guten Bezugspunkt. z.B. 
misst Du am µC direkt VCC und GND. Dann sollte das Bild besser 
aussehen...
Harald

Autor: Marko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas: ja, irgendeine externe Störquelle muß es ja sein. Wobei der 
"Sender" ja schon recht kräftig sein muß, damit das Scope 2,4V S-S 
anzeigt, oder?

Harald: lies nochmal. Bei meinem Test (Bild 2) lagen die Tastköpfe 
einfach nur auf dem Tisch, da war keine Schaltung dran. Aber klar, wenn 
ich jetzt sinnvolle Messungen machen will, muß ich mir richtig kurze 
Masseanschlüsse basteln ...

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marko wrote:

> Andreas: ja, irgendeine externe Störquelle muß es ja sein. Wobei der
> "Sender" ja schon recht kräftig sein muß, damit das Scope 2,4V S-S
> anzeigt, oder?

Ist schon ein paar Jahrzehnte her, aber ich glaube die Störung war in 
ähnlicher Grössenordnung.

Das kannst nur du rauskriegen - es kann alles mögliche sein, bis hin zum 
Start oder Stop vom Kompressormotor des Eisschranks vom Nachbarn, der im 
Tastkopf seinen Schwingkreis findet.

Autor: Harald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yep, das habe tatsächlich überlesen. Sorry. Wie wäre es denn mit einem 
probehalben Abkleben des Schutzleiters? Ich möchte jetzt nicht den 
genauen Scopetype recherchieren, aber das Scope doch keine 
potentialfreien Eingänge, oder? Dann sind nämlich das Scopemassen mit 
dem Schutzleiter verbunden. Führt das zur Besserung würde ich einen 
Trenntrafo einsetzen... Auf keinen Fall den Schutzleiter dauerhaft 
abgeklebt lassen, das muss sicherlich an dieser Stelle gesagt werden.

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Etwas ähnliches hab ich bei mir manchmal auch, allerdings etwas 
niederfrequenter und mit 20-30sec dauer, auch wie bei dir kommt es aus 
der Luft.

Der Modulierung nach scheint es bei mir ein Funkamateur zu sein ... 
grrr!
Manchmal knallt es auch auf UKW durch und man hört bei 103MHz manchmal 
verzerrte Sprachfetzen.

Ebenso war bei meiner TK Anlage (DeTeWe) ein Stecker SNT dabei das noch 
in 3m Entfernung sichtbare Störungen am Oszi machte, grösser als meine 
selbstgebauten SNTs in 5cm Entfernung, kaum zu glauben.
Aber da waren die Störungen in den SNT typischen Intervallen.

Aber wie schon bemerkt 2.4Vss ... das ist heftig.
Du wohnst nicht zufällig neben einer Radiologenpraxis mit einem Kernspin 
Tomo. oder sowas?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kupfer Michi wrote:

> Der Modulierung nach scheint es bei mir ein Funkamateur zu sein ...

Wobei mir ein Funkamateur mal sagte, das ihn das Powerline-Netzwerk 
eines Nachbarn solange nervte, bis er mal ein Weilchen seine 800W 
dorthin geblasen hat - danach war Ruhe. Mag sein, dass das Jägerlatein 
war - aber diese Leute sind über Störungen gewöhnlich ganz gut 
informiert.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nur wenn die Tastkopfspitze mit GND kurzgeschlossen ist, dann zeigt sich 
das Bild? Antenne!
Hast du ein Schaltnetzteil in der Nähe?
Vielleicht das Handy?
Dimmer in der Arbeitsleuchte?
einen halb-defekten Schalter (verschmutzte Kontakte) an einem Gerät 
irgendwo in der Umgebung?
>Kompressormotor des Eisschranks vom Nachbarn
Kompressormotor des eigenen Kühlschrankes?
und vieles mehr ...

@ Kupfer Michi (Gast)
>Der Modulierung nach scheint es bei mir ein Funkamateur zu sein
Kann sein - aber ich seh eher keine Modulation sondern einen mit einem 
Puls angeregten Schwingkreis, der dann ausschwingt ...

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>aber diese Leute sind über Störungen gewöhnlich ganz gut
informiert

Funkamateure sicher ja, bei CB Funkern gehts aber of über das Drücken 
der Sprechtaste nicht hinaus und wenn dann das Gerät ne Macke und auf 
einem Nebenband mitschwingt....

Aber bei Marko schein es ja irgend ein techn. gerät in der Nähe/mit 
hoher Strahlleistung zu sein. Ich nehme an das tritt auf allen 4 Kanälen 
auf.

Das nicht über die Stromversorgung zu kommen scheint, die 
Schleifenantenne am Tastkopf abstimmen und Richtpeilung spielen....

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>Der Modulierung nach scheint es bei mir
>Kann sein - aber ich seh eher

war auch nur als Anektote gedacht

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich nehme an das tritt auf allen 4 Kanälen auf.
War zunächst auch auf dem Trip, aber Marko schrieb:

>Kanal 1, Masseklemme mit Tastkopfspitze verbunden
>Kanal 2, Masseklemme nirgends angeschlossen
>Kanal 3, Masseklemme entfernt
>Kanal 4, kein Tastkopf angeschlossen

>Das Ergebnis kann man auf dem Bild 2 sehen:

Schau dir das Bild 2 nochmal an. Ein klein wenig ist auf K2 noch zu 
sehen.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja eben. Massekabel als Schleife: prima Antenne, Tastkopf ist 
Schwingkreis und das gibts auf #1 zu sehen. Bei #2 fehlt der 
Schwingkreis, aber die Antenne ist noch dran. Bei #3 und #4 fehlt die 
Antenne, folglich ist duster.

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich nehme an das tritt auf allen 4 Kanälen auf

ich meinte damit, dass das Signal jeweils dann auf jedem Kanal empfangen 
wird wenn man an der Tastspitze eine Schleife (Antenne) herstellt.

(ich liebe mein Analog Oszi, bei den Digitalen weiss man nie so genau ob 
es einfach nur Wandler rauscht oder ein Signal anliegt)

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ja eben. Massekabel als Schleife: prima Antenne

ja, desswegen meinte ich Marke soll man Gelber Peilwagen spielen.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>(ich liebe mein Analog Oszi, bei den Digitalen weiss man nie so genau ob
>es einfach nur Wandler rauscht oder ein Signal anliegt)

Genau - und wenns schlimm kommt, dann ist die Schwinung, die man beim 
Digitalen gerade sieht, tatsächlich auf einer ganz anderen Frequenz ...
Und die meisten haben 8-Bit-Wandler, das sind nur 256 Treppchen auf dem 
Schirm - die sieht man noch!

Autor: Kupfer Michi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>und wenns schlimm kommt...die meisten haben 8-Bit-Wandler

Hatte gerade gestern den Fall dass beim Werkeln an meinem neuen FET 
Tastkopf ich ab und zu ein einen etwas dickeren Strahl hatte.
Reinzoomen ergab dann eine leichte Rückkoplung bei 464MHz durch eine 
etwas falsch geführte Abblock Masseverbindung.

Ich glaub nicht dass ich sowas mit einem 60MHz/1GSa DigiOszi hätte sehen 
können, dazu müsste man schon tiefer in die Tasche greifen.
(... obwohl, manchmal wünscht man sich nicht sehnlicher als eine 
Singleshot Aufzeichnung)

Autor: JensG (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Solche Spikes kenne ich auch - allerdings wußte ich zumindest, wo es 
herkommt.
Nämlich von der Mopedzündung-Testschaltung, die bei mir auf dem Tisch 
"funken" durfte. Bei ein paar 10cm Abstand hatte ich immer noch etliche 
Volt "Empfangsspannung". Interessanterweise ebenfalls so um die 100MHz 
wie bei Dir (der kurzgeschlosssene Tastkopf bildet wohl einen 100MHz 
Schwingkreis).
Wenn nicht gerade eine Hochspannungsleitung bei Dir über'm Haus 
langgeht, dann ist es wohl irgendwas in unmittelbarer Nähe - vielleicht 
max. 1-2m Umkreis.
Z.B. Röhrenmonitor, wenn dessen Hochspannung gelegentlich schon 
irgendwelche Nebenwege geht (also irgendwelche Kriechstromstrecken, oder 
Zeilentrafo kurz vorm Exitus, ...).
Versuche soch mal, mit deiner "Antenne" die Quelle anzupeilen bzw. Dich 
im Raum zu bewegen - der kurzgeschlossene Tastkopf ist nämlich 
richtungsselektiv.
Da wirst Du bestimmt den "Funker" finden, wenn er in der Nähe ist.

Autor: Der Techniker (_techniker_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..hatte sowas auch mal - Bei mir wars der TFT, der daneben stand.. ;-)
(evtl. die 3kV von der Hintergrundbeleuchtung?!?)

Autor: Der_Ing. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau - und wenns schlimm kommt, dann ist die Schwinung, die man beim
Digitalen gerade sieht, tatsächlich auf einer ganz anderen Frequenz ...
Und die meisten haben 8-Bit-Wandler, das sind nur 256 Treppchen auf dem
Schirm - die sieht man noch!

hi,

auch 50 Gs oszis haben nur 8 bit.
das reicht aber.
solls genauer sein, machts auch das 13GHz 50Gs auf der arbeit.

ich werd mir das 2004b auch zulegen für den hausgebrauch.
hab lange überlegt, ob ich das 200MHz nehmen soll, aber die 
gesamtperformance der kleinen TDS ist begrenzt, sodass die 200MHz eben 
sozusagen nur theoretisch sind.
praktisch sind die 4 kanäle.
für die schnellen messungen kann man sich ja noch ein 500MHz analog für 
500 euro auf ebay kaufen.
die kleinen digitalen sind sehr praktisch.
viele messungen die frequenz, pulstime, anstiegszeit werden automatisch 
ermittelt und man muss nicht an zig knöpfchen drehn ;)

grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.