www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Läuft mein Quarz oder nicht?


Autor: Nickname (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin, Leute!
habe einen etwas komische Ereigniss. Ich konnte meinen Mega16 nicht 
proggen. Dann hat es doch geklappt, nachdem ich die kondensatoren 
gewechselt habe.
Nun konnte ich ihn proggen, die Fusebits auch richtig eingestellt.
Jetzt wollte ich kontrollieren / gucken, wie er schwingt.
Habe mein Oszi ans Quarz angeschlossen. Gnd vom Tastkopf an XTAL2 und 
Spitze an XTAL1. Mein Oszi zeigt nichts an. Ich habe noch keine LED´s 
und sonstige Sachen dran zu kontrollieren.
Ich weiss nur, wenn ich den Quarz rausnehme, dann kann ich nichts mehr 
programmieren. Also Quarz funktioniert doch (scheint so)
Messe ich falsch?
Guten Abend!

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alex?

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Messe ich falsch?

>Gnd vom Tastkopf an XTAL2 und
>Spitze an XTAL1.

Mann, GND vom Tastkopf an GND !!!!!

Autor: Uwe ... (uwegw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Oszi-Tastkopf ist schon eine relativ große Belastung für den 
Oszillator. Da kann es in gewissen Fällen vorkommen, dass man damit die 
Schwinung abwürgt.

Du könntest einfach mal einen IO-Pin toggeln lassen, und dort mit dem 
Oszi nachmessen.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du misst nicht falsch, es wird so sein, daß die Quarzschwingungen 
abreißen, sowie Du Deinen Oszillographen als "Last" dranhängst.
Häng Dich mal an Masse und XTAL1 oder XTAL2.

Schreib Dir ein Programm, was Dir eine LED im Sekundentakt schaltet.
Dann kannst Du sehen, ob die erzeugten Zeiten stimmen, d.h. ob Dein 
Quarz
überhaupt schwingt oder der interne Takt im Gange ist.

MfG Paul

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@nickname oder auch von mir aus alex (scheint ja derselbe zu sein) :

schließe mich holger an :

Mann, GND vom Tastkopf an GND !!!!!

warum kannst du nichts messen ? vielleicht weil xtal2 eben keine masse 
ist, oder weil das vielleicht ein eingang/ausgang NUR für den quarz ist 
?

wie misst man spannungen mit einem scope ? braucht man masse ?

lies dir doch erstmal die grundlagen ein wenig durch (z.b. 
elektronikwerkstatt, elektronikkompendium) dann kannst du dir derlei 
fragen sparen ....

und falls du wirklich alex bist :

hör auf fragen zu stellen und die leute dann noch dumm anzusaugen wenn 
sie dir mit einem kleinen tritt versuchen zu zeigen wie man an 
informationen rankommt.
in diesem forum wird sicherlich vielen geholfen, aber ohen 
eigeninitiative läuft hier gar nichts ....
probier lieber mehr rum (mehr als kaputtmachen kann mans nicht und dann 
muß man sich wirklich doof anstellen) und wenn du wirklich nicht weiter 
weißt lies dich ein.
wenn du dann immer noch fragen hast kannst du wenigstens mit deinem 
bisher angelernten wissen argumentieren und die leute verstehen dich 
besser ...

Autor: Nickname (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>@nickname oder auch von mir aus alex (scheint ja derselbe zu sein)

lol? nein, ich heisse nicht Alex, wieso?????

Autor: Bensch (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Gnd vom Tastkopf an XTAL2 und Spitze an XTAL1

Nein, wie süss.....
Auf DIE Idee muss man erstmal kommen, alle Achtung!

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lol? nein, ich heisse nicht Alex, wieso?????

hmmm..... warum nur???? ich weis es nicht ;-)

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@andy

ich auch nicht ....

@bensch

auf so eine idee muß man erstmal kommen ....

@nickname

warum heißt der pin xtal2 xtal2 und nicht gnd ?
warum hast du überhaupt zwischen den beiden pins gemessen ? (ich weiß, 
du wolltest wissen ob der quarz schwingt, aber warum gerade DIESE 
möglichkeit)

Autor: Nickname (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>warum gerade DIESE möglichkeit
Ich habe erst über GND und XTAL1 gemessen. Da war nix.
Habe den Pin getoogelt, es funktioniert, auch wenn ich nichts messen 
kann. na ja, egal!
Danke!

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Glaubt Ihr wirklich, dass Alex ein Ossi hat? *g

Autor: Andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@gast:

Warum die richtige Art wenn es so viele Möglichkeiten gibt es falsch zu 
machen ;-)
Oder liegt es einfach daran? Zitat: "ich bin zu blöd"

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Habe den Pin getoogelt, es funktioniert, auch wenn ich nichts messen
>kann. na ja, egal!

woher weißt du dann das es funktioniert ?!

>Ich habe erst über GND und XTAL1 gemessen

und über xtal2 und gnd ? scope richtig eingestellt ? spannung dran ? 
(kein witz, kann man schonmal vergessen)

fuses richtig eingestellt ?!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.