www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Problem bei Inbetriebnahme von Xilinx Coolrunner


Autor: Thomas W. (olaschir)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe eine Platine mit einem XCR64 im VQ Gehäuse. Für Debug Zwecke 
sind dort Testanschlüsse (Pfostenleiste)vorhanden.
Problem ist, das ich an der Leiste  kein Ausgangssignal bekommen.

Selbst die supi simple funktion
ausgang <= eingang
funktioniert nicht.
Eingang wird mit 5V und seriellem 2k Widerstand stimuliert.
Am Ausgang Meßinstrument bzw. Oszi.

Der CPLD läßt sich über IMPACT programmieren, auslesen löschen etc.
Bei Auslesen erhält man reprodzierbar veränderte Dateien, je nachdem was 
vorher programmiert wurde.
Vcc (3,3V) und GND Pins passen, Leiste ist "direkt" an den I/Os 
angeschlossen.
Eletrischer Kontakt zwischen CPLD und Leiste besteht.

Was kann es sein?
Hab ich was einfaches grundlegendes übersehen?

Thomas

Autor: Morin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieh dir mit den entsprechenden Tools (leider keine Ahnung welche das 
sind, ich kenn es nur von FPGAs, da sind es im ISE "view placed/routed 
design" und "fpga editor", letztered nur in der Profiversion vorhanden) 
die fertige Konfiguration an, und schau nach ob die richtigen Pins 
verbunden sind.

Autor: Klaus Falser (kfalser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuch einmal, den oder die Ausgänge fest auf '1' oder '0' zu setzen.
Damit siehst Du, ob die Ausgänge überhaupt reagieren.

Autor: Thomas W. (olaschir)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Pins sind richtig verbunden, da habe dann nicht nur ich drauf 
geschaut.

mit 0 und 1 wäre natürlich auch was...
probier ich gleich mal aus.

Autor: Thomas W. (olaschir)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, problem beseitigt.

meist ist es doch der Mensch, der was falsch macht.

In der ganzen Toolkette ist es passiert, das als Familie Coolrunner II 
anstatt Coolrunner ausgewählt wurde.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.