www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Probem: Schaltnetzteil mit L4960 "startet" nicht


Autor: Markus _neu (markush)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leutz,

ich habe ein "Schaltnetzteil" mit einem L4960 nach einem Vorschlag von 
Fabian Greif (kreatives-chaos.com). Netzseitig ist ein Trafo era 
vorhanden: 2,3VA, 9V, 256mA.
Wenn ich die Schaltung in Betrieb nehmen mit Last (µC Mega32 + GLCD) 
dann läuft das Netzteil nicht richtig an, Spannung bleibt bei ~ 1,8V. 
Ohne Last ist es kein Problem, Stecker rein und dann erst µC Board 
angeschlossen.
Hat jemand ne Idee was das Problem sein könnte? Hat der Trafo vielleicht 
zuwenig Power?

Gruß - Markus

Autor: The Devil (devil_86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wie du das beschreibst scheint die Versorgung unter der Last 
zusammenzubrechen.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hängt an den Klemmen X1 direkt der Trafo, oder ein Steckernetzteil mit 
integriertem Gleichrichter (D3 als Verpolschutzdiode)?

Einweggleichrichtung mögen Trafos nämlich gar nicht gern.
Versuch mal eine klassische Graetz-Brücken-vollweggleichrichtung.

Ansonsten wie immer: kurze Leiterbahnen, damit es geringe parasitäre 
Leitungs-Induktivitäten gibt.
Ist die Drossel eine spezielle für Gleichstrombelastung? Entstördrosseln 
eignen sich hier nicht.

Autor: mandrake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@eProfi:
>Ist die Drossel eine spezielle für Gleichstrombelastung? Entstördrosseln
>eignen sich hier nicht.

Richtig!

Sehr wichtig! Manchmal kann man das schon dadurch bemerken, dass die 
Spule recht warm wird (speziell der Kern). Das deutet darauf hin, dass 
so ziemlich alle Energie durch Ummagnetisierungsverluste flöten geht. 
Das Kernmaterial muss unbedingt geeignet sein (z.B. N87 oder 3F3).

Autor: Εrnst B✶ (ernst)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mandrake wrote:
> @eProfi:
>>Ist die Drossel eine spezielle für Gleichstrombelastung? Entstördrosseln
>>eignen sich hier nicht.
>
> Richtig!
>
> Sehr wichtig! Manchmal kann man das schon dadurch bemerken, dass die
> Spule recht warm wird (speziell der Kern). Das deutet darauf hin, dass
> so ziemlich alle Energie durch Ummagnetisierungsverluste flöten geht.
> Das Kernmaterial muss unbedingt geeignet sein (z.B. N87 oder 3F3).

Mal nicht übertreiben... für die paar 100mA macht das kaum einen 
Unterschied.
Und das üblicherweise in Entstördrosseln bewickelte 26er Material 
(Amidon, Gelb/Weiss) eignet sich recht gut für Schaltregler, solang man 
nicht deutlich über 100kHz hinaus will.
Klar, wenn man das letzte Prozent an Wirkungsgrad noch optimieren will, 
gibts besseres, aber im Orginal-Post gings ja um "Schaltung geht gar 
nicht".

Ich tipp ebenfalls auf die Gleichrichtung am Trafo.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich tippe auf den L4960:
Ich hatte vor kurzem ein Netzteil mit einem L4962, das nicht 
hochgekommen ist, da meine Schaltung einen etwas großen Einschaltstrom 
hatte. Im Betrieb braucht sie aber nur rund 0,3A. Mit einem LM2574 läuft 
die Schaltung dagegen problemlos.

Autor: Markus _neu (markush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachm Trafo kommt natürlich ein Brückengleichrichter B80C1000. Als Spule 
hab ich die verwendet: 
http://www.reichelt.de/?;ACTION=3;LA=2;GROUPID=317...

Drosselspule
Festinduktivität SMCC
Einlagige und mehr-
lagige Wicklung auf
Ferrit- und Phenol-
harzkernen. Tauchver-
zinnte axiale An-
schlüsse.
Toleranz: ±10%
Induktivitätsangaben
bei 20KHz
Fr: 4,2 MHz
R: 2,80 Ohm
I: 280 mA

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nachm Trafo kommt natürlich ein Brückengleichrichter B80C1000.
Du hast dann also ~11V.

> http://www.reichelt.de/?;ACTION=3;ARTICLE=18194
> R: 2,80 Ohm

Was zieht deine Schaltung denn für einen Strom?
Bei angenommenen 300mA ist das fast ein Volt, das in der Spule verbraten 
wird.

> I: 280 mA
Wird die Spule im Betrieb warm?

Probier doch mal den Softstart zu verlängern. (C6)

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich glaube nicht, dass diese Spule als Speicherdrossel taugt. Und erst 
recht nicht, dass die Angabe 280mA die Grenze zur Sättigung darstellt. 
Das wird eher diejenige Grenze sein, jenseits der das Teil olfaktorisch 
zu wirken beginnt.

Autor: Markus _neu (markush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexander Schmidt wrote:
>> Nachm Trafo kommt natürlich ein Brückengleichrichter B80C1000.
> Du hast dann also ~11V.

Mess ich heut abend mal nach.

>> http://www.reichelt.de/?;ACTION=3;ARTICLE=18194
>> R: 2,80 Ohm
>
> Was zieht deine Schaltung denn für einen Strom?

Mess ich heut abend mal nach ;-)

> Bei angenommenen 300mA ist das fast ein Volt, das in der Spule verbraten
> wird.
>
>> I: 280 mA
> Wird die Spule im Betrieb warm?

Wär mir nicht aufgefallen, werd heut abend mal den Finger "anlegen".

> Probier doch mal den Softstart zu verlängern. (C6)

Probier ich heut abend mal aus.

Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Passende Spule wäre diese
http://shop.embedit.de/product__507.php

Verwende die auch für einen Bausatz. Der liefert auch bei >2A noch ein 
sauberes Ausgangssignal. Hab die Schaltung schon mit allem gequält was 
mir eingefallen ist. Hab ich noch nicht kaputt gekriegt. Ist halt etwas 
größer

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Markus, apropos Shop: Bei solchen Spulen ist eine Grössenangabe 
ungemein hilfreich.

Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke. Habs geändert

Autor: Markus _neu (markush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leutz!

Also, das Ding läuft problemlos wenn ich die Pufferkapazität C8 zwischen 
Trafo und Netzteil erhöhe. Mit 2200µF und höher gibts kein Problem beim 
Einschalten.

Zur Spule: Ich hab das Ding jetzt ne halbe Stunde laufen, Spule wird 
nicht spürbar warm!

Hab allerdings auch den ursprünglich geplanten Trafo wieder eingebaut: 
2VA  6V  333mA. Läuft tadellos damit, Spannung bleibt fast konstant 
bei 5,02V auch wenn alle Abnehmer ein sind (Display, LEDs und 2XRelais).

Stromaufnahme ohne die Relais beträgt 27,5 mA !!! Das ist ja weit 
weniger als ich dachte, hab allerdings noch nie nachgemessen bei einer 
Schaltung.

Da stellt sich mir natürlich die Frage, ob sich da der Aufwand mit dem 
L4960 Netzteil überhaupt lohnt? Was meint ihr? Wärs von der Effizienz 
wirklich so viel schlechter einfach einen 7805 zu nehmen?

Markus

Autor: Markus Burrer (Firma: Embedit Mikrocontrollertechnik) (_mb_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ob sich der Aufwand lohnt hängt von der Eingangsspannung und vom Strom 
ab. Je höher die Spannung oder je höher der Strom, umso eher lohnt sich 
ein Schaltnetzteil. Bei 30mA und einer Eingangsspannung <10V würde ich 
den Aufwand noch nicht machen

Autor: Markus _neu (markush)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Markus Burrer wrote:
> Ob sich der Aufwand lohnt hängt von der Eingangsspannung und vom Strom
> ab. Je höher die Spannung oder je höher der Strom, umso eher lohnt sich
> ein Schaltnetzteil. Bei 30mA und einer Eingangsspannung <10V würde ich
> den Aufwand noch nicht machen

Seh ich jetzt auch so, beim nächsten Projekt werd ich auf alle Fälle 
beim Prototypen schon messen was an Leistung benötigt wird - 
Entsprechend wird das Netzteil gebaut.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Also, das Ding läuft problemlos wenn ich die Pufferkapazität C8 
zwischen
Trafo und Netzteil erhöhe. Mit 2200µF und höher gibts kein Problem beim
Einschalten."

War es ein neuer oder gebrauchter C? Mit zumehmenden Alter trocknen Cs 
aus und die "inneren Werte" verschlechtern sich dramatisch.

Daran hatte ich erst gedacht, als meine Antwort schon abgeschickt war:
dieser C ist sehr wichtig, weniger die Kapazität, vielmehr eine niedrige 
Impedanz (Induktivität und ESR) sind wichtig. Das kann man auch durch 
parallelschalten mehrerer kleiner Cs erreichen (wie in dieser Schaltung 
am Ausgang).

Hier trennt sich Spreu vom Weizen: es gibt riesen Qualitätsunterschiede 
bei allen Bauteilen, speziell Cs und Ls.

Z.B. habe ich hier in einer H-Brücke einen Panasonic low-ESR-C  470µF 
100V, der liefert kurzzeitig ohne weiteres 150A, ohne mit der Wimper zu 
zucken.
Vorher war ein Billigheimer drin, der ist bei 20A schon völlig 
eingebrochen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.