www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Lcd-hd44780-kaputt?


Autor: woldo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe mir ein LCD-Display gekauft und möchte dieses über einen Atmega8 
ansteuern. Das Display reagiert momentan leider überhaupt nicht.
Deshalb meine Frage:

Wenn ich das Display an die Versorgungsspannung anschließe und "PIN3" 
mit dem Potentionmeter verbinde passiert nichts. Müsste dieses jedoch 
beim ersten start nicht schon die 2 schwarzen Balken anzeigen?

Da es relativ warm geworden ist hab ich dessen Stromverbrauch gemessen. 
330mA!! kann ich das gleich schon weghauen oder saug dieses normal so 
viel?


MfG

Stefan

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, nicht normal! vielleicht liegt daran, dass du ein Liquid Crystal 
Display Display und kein LC-Display hast.
spannung verkehrtrum angelegt? überprüf mal deine schaltung nochmal.
wenn die dann stimmt und du probleme mit der software hast:
http://www.mikrocontroller.net/articles/AVR-GCC-Tu...
http://www.mikrocontroller.net/articles/AVR-Tutorial:_LCD

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es wird doch mal Zeit für ein eigenes HD44780 LCD Forum, oder zumindest 
eine Anleitung für eine Schritt für Schritt Fehlersuche im Wiki...

Backlight über Vorwiderstand angeschlossen, Spannung nicht verpolt an 
die richtigen Pins angeschlossen ?

Autor: Heinrich Huber (Firma: none) (woldo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Hab die Hintergrundbeleuchtung gar nicht angeschlossen-muss ich ja 
nicht..oder?
Hardwaremäßig sollte es auch passen. Hab vorerst nur die ersten 3 
angeschlossen:
1  Vss  GND
2  Vcc  5V
3  Vee  Kontrastspannung (0V bis 5V)

Hatte um die Software zu testen natürlich auch die anderen 
angeschlossen.

Deshalb eben die Frage ob das Display nach dem Einschalten(nach Neukauf) 
nicht bereits die schwarzen Balken anzeigen müsste?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heinrich Huber wrote:

> Hab die Hintergrundbeleuchtung gar nicht angeschlossen-muss ich ja
> nicht..oder?

Es geht auch ohne. Das machen nur viele falsch, daher die Frage.

> Hardwaremäßig sollte es auch passen. Hab vorerst nur die ersten 3
> angeschlossen:
> 1  Vss  GND
> 2  Vcc  5V
> 3  Vee  Kontrastspannung (0V bis 5V)

Ist OK.

> Deshalb eben die Frage ob das Display nach dem Einschalten(nach Neukauf)
> nicht bereits die schwarzen Balken anzeigen müsste?

Wenn es mit 5V Kontrastspannung auskommt ja.
Aber ich würde mich erstmal um die 330mA kümmern.
Dass ein neues LCD kaputt ist, ist äußerst unwarscheinlich. Du 
hast/hattest also vermutlich irgenwas falsch angeschlossen.

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo stefan/heinrich
mal ins datenblatt geschaut, ob die Vee nicht vielleicht negativ sein 
muss? die spannung zur kontrasterzeugung ist immer negativ, die frage 
ist nur, wo der inverter sitzt. entweder auf dem lcd selbst mit dabei 
oder du musst den extern zusammenbaun.

Autor: Heinrich Huber (Firma: none) (woldo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hm,

ja wenn dann hab ich vorher mal falschen code raufgespielt und es ist 
jetzt dahin..
naja, danke jedenfalls für die Hilfe!!

mfg

woldo

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H* wrote:
> die spannung zur kontrasterzeugung ist immer negativ

Falsch. Viele Character LCDs mit Mux 1/16 kommen mit etwa 4,5V aus. Nur 
solche mit erweitertem Temperaturbereich, oder größere Grafik LCDs 
benötigen eine höhere Spannung (bis etwa 35V).

Heinrich Huber wrote:
> ja wenn dann hab ich vorher mal falschen code raufgespielt und es ist
> jetzt dahin..

Durch einen falschen Code ein LCD zu zerstören ist nahezu unmöglich. 
Außer der Code steuert eine Planierraupe die über das LCD fährt...

Autor: Michael H* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benedikt K. wrote:
> Michael H* wrote:
>> die spannung zur kontrasterzeugung ist immer negativ
>
> Falsch. Viele Character LCDs mit Mux 1/16 kommen mit etwa 4,5V aus.
ahja, wieder was gelernt. trotzdem eine überprüfung wert. die 300mA 
wollen ja auch irgendwo herkommen

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H* wrote:

>> Falsch. Viele Character LCDs mit Mux 1/16 kommen mit etwa 4,5V aus.
> ahja, wieder was gelernt. trotzdem eine überprüfung wert. die 300mA
> wollen ja auch irgendwo herkommen

Ja. Wenn man die negative Spannung an ein LCD anschließt, ohne dass die 
positive Betriebsspannung anliegt, dann ist die warscheinlichkeit groß, 
dass das LCD kaputt geht.
Aber das trifft ja hier nicht zu, wenn woldo wirklich nur 5V, GND und 
ein Poti zwischen 5V und GND am Kontrastpin angeschlossen hat.

Autor: Niels Hüsken (monarch35)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Michael H* wrote:

> ahja, wieder was gelernt. trotzdem eine überprüfung wert. die 300mA
> wollen ja auch irgendwo herkommen

Richtig. Und ich bin davon überzeugt, das hier falsch Verdrahtet worden 
ist. Entweder ist das Teil schon defekt oder es funktioniert noch und 
muss nur korrekt verdrahtet werden.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.