www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Brenner8P von Sprut- Programmierspannungs Probleme


Autor: bigsweeper (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich habe den Brenner8P von Sprut aufgebaut,
mit dem Programm USBurn kalibriere ich dann die Programmierspannung...

Bei der Ersteinstellung der Z-Spannung messe ich 3,33 Volt, danach habe 
ich über den PWM-Schieber(=25/ 21%) 13,02 V eingestellt und den 
Spannungsteiler richtig eingestellt(2,61).

Dann das Problem:

bei "programming Voltage test"  stelle ich 10V ein, bekomme aber nur 
8,44V Programmierspannung auf der Platine erzeugt.
Bei 11V nur 9,67V , bei 12V etwa 10,85V aber bei 13V  steigt der Wert 
kurz auf 14V fällt dann aber auf 1,49V zurück und die grüne LED geht an, 
und bleibt an.

Ich habe bereits PIC´s des Typ 16F84 erfolgreich gebrannt, aber nach 
jedem mal brennen, geht die grüne LED an, und bleibt an. Trotzdem hatte 
das keinen Einfluss auf den 16F84.

Jetzt wollte ich einen PIC des Typs 16F72 brennen und da geht gar 
nichts. Der Brenner kann den PIC-Typen nicht erkennen obwohl er den 
unterstützt.

Denke das liegt an der Programmierspannung Vpp...
Anbei der Schaltplan, vlt. kann mir jemand da helfen...die 
Programmierspannung misst man zwischen den Punkten LSP1 und LSP2.

MfG
bigsweeper

Autor: stepp64 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was für Widerstände haste denn genommen? R4 + R5 sollten möglichst 
kleine Tolleranzen aufweisen, also am besten Metallschichtwiderstände 
mit <= 1% nehmen. Ich persönlich benutze keine Kohleschicht mehr, auch 
wenn die Metallschicht ein paar Cent teuerer sind.

Ansonsten halt noch mal alles genau kontrollieren und den Funktionstest 
der Beschreibung noch einmal genau durchgehen.

Ich will mir den Brenner8P erst in den nächsten Tagen bauen, warte 
allerdings noch auf meine Bestellung.

Sven

Autor: stepp64 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab gerade gelesen, die Diode D1 spielt auch eine wesentliche Rolle. 
Hast du da die BAT43 genommen wie im Schaltplan oder eine andere? Bei 
der falschen Diode wird in der Aufbauanleitung beschrieben, dass die 
Spannungen dann zu gering sind. Da würde ich mal mit der Fehlersuche 
anfangen.

Autor: Thomas Müller (thomas1123) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
die grüne led geht an weil der pic glaubt das er eine zu Grosse 
programmierspannung erzeugt.

zwischen welchen punkten misst du die spannung?
hate damals den fehler gemacht das ich zwischen den beiden pins gemessen 
habe die auch noch im layout sind und in etwa das gleiche verhalten 
beobachten können

du musst die MCLR spannung gegen masse messen dann wird es 
wahrscheinlich funktioniren

mfg
Thomas

Autor: bigsweeper (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Thomas!

Es funktioniert!

Das war der Fehler, ich habe den Brenner8p auf eine Lochrasterplatine 
aufgebaut, und der "Schaltplan-Designer" hat zwei Messpunkte verwendet, 
bzw. eingeplant, bin davon ausgegangen, dass die Programmierspannung 
zwischen den beiden Punkten zu messen wäre...und extra nicht gegen 
Masse...(Z-Diode zur anhebung des Massepotentiales!?->falsch gedacht! 
;o)
Klar das der Brennerr die Spannung abschaltet, schließlich war die ja 
dann auch zu hoch.

Tipp: Mann sollte beim Aufbau des Brenners direkt noch einen dritten 
Messpunkt(Masse) mitberücksichtigen! Zur einfacheren Kalibration.

Dann erhält man einen ganz anderen Spannungteilerverhältnis und die 
Test-Spannungen sind korrekt!
 Hatte vorher einen Wert von 2,61 und jetztvon 3,10...

Komisch nur, dass der Brenner ohne Probleme den PIC16F84 gebrannt hat...
der hat zwar den MCLR an einem anderen Pin aber die Spannung muss doch 
die selbe sein.

Jedenfalls vielen Dank an alle!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.