www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Masse / EMV Problem


Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe eine kleine Schaltung mit einem atmega128 die über einen ftdi 
ft232 per USB an den PC angeschlossen wird. Des weiteren wird die 
Schaltung über ein externes Netzteil mit Spannung versorgt, da der USB 
Port für manche Anwendungen zu wenig Strom liefert. Wenn ich das 
Netzteil einstecke und sich die zwei Massepotentiale (Netzteil und 
Schaltung) verbinden fließen wohl Ausgleichströme, die sehr üble 
Störungen auf der Versorgungsspannung erzeugen (spitzen mit über 100V). 
Dadurch steigt oft der FTDI chip aus.
Mit welchen Maßnahmen bekommt man denn die Störungen am besten weg?

Viele Grüße
Achim

Autor: Alexander Liebhold (lippi2000)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Achim,
ich würde mit folgenden Untersuchungen beginnen:

1: Wie seiht die Spannung am Netzteil ohne USB aus? Drossel & C?
2: Sorge für nen Potentialausgleich (2mm² Kabel zum PC-Gehäuse). Spitzen 
weg?


Nutzt du die 5V vom USB zusätzlich zum Netzteil?


Gruß Alexander

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist dein Netzteil geeerdet und dann an einer völlig anderen Steckdose 
angeschlossen, als dein PC? Das wäre für mich die einzige Erklärung, 
ansonsten kann es nur ein defektes Netzteil sein. Wo sollen denn sonst 
Störungen von 100V herkommen? Überhaupt sind Störungen von 100V schon 
sehr ungewöhnlich.

Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
100 V klingt sehr unwahrscheinlich. Wie hast Du das gemessen?
(Dabei ist nicht nur die Wahl des Messgerätes interessant, sondern auch 
die GENAUE Art des Anschlusses.)

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke schon mal für die Antworten, hier noch ein paar Erklärungen dazu.

Das Externe Netzteil für die 24V ist ein einfaches Steckernetzteil, 
solches mit einem schmalen Stecker für die Steckdose, das keine Erdung 
hat.

Gemessen habe ich die Spannungsspitzen mit einem normalen Oszi auf der 
5V Versogungslage.

Meine Vermutung ist, das beim Einstecken des Netzteils ein hoher 
Ausgleichsstrom entsteht und dann die Störungen von der GND Lage
auf die VCC Lage eingekoppelt werden.

Autor: Achim (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch was, wenn ich die Schaltung an einem USB Hub mit externer 
Spannungsversorgung betreibe tritt das Problem nicht auf.

Autor: Winfried (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kommen die Spannungsspitzen denn zyklisch? Wenn ja, welche 
Periodendauer.

Wie will man denn 100 V Spitzen auf 5 V aufmodulieren, die vermutlich 
mit Keramik + Elko abgeschlossen sind? Vorstellbar ist das für mich 
nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.