www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio 4.12 Unterschiedliche Lage und Größe bei Vollbildmodus


Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe ein kleines Problem beim Aufruf des AVR Studio 4.12 (Build 462 
SP1) im Vollbild Modus.

Bei mir wird das AVR Studio Fenster in unterschiedlichen Größen 
angezeigt und die Lage des Fenster ist nach unten verschoben.

Dies äußert sich so, dass nicht wie sonst  bei Windows Fenstern üblich, 
die Anzeige des Fensters bildschirmfüllend angezeigt wird, sondern nach 
unten verschoben ist.

Dadurch ist der Fortschrittssbalken (z. B. loading Programm Memory) 
nicht mehr sichtbar.

Nach Aufruf des AVR Studio im Vollbildmodus ist am oberen Bildschirmrand 
immer noch ein schmaler Streifen vom Desktop im Hintergrund sichtbar. 
Dieser sichtbare Streifen ist je nach Lage und Größe des AVR Studio 
Fenster unterschiedlich breit.

Ich habe festgestellt, dass die Lage und Größe des Fensters sich nach 
jedem erneuten Aufruf des AVR-Studio ändert.

Ich hoffe das ich mein Problem einigermaßen verständlich beschrieben 
habe.

Kann mir vielleicht jemand einen Tipp geben?

Vielen Dank im voraus.

Hans

Autor: Gregor B. (gregor54321)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dieses Problem kenne ich. Mir ist es auch schon bei anderen Programmen 
aufgefallen (selten). Entweder weil diese zufällig den selben 
Programmierfehler enthielten, oder beide mit der Ansteuerung des 
Grafiktreibers ihr Problem haben. Gibt's hier nen Windows Programmierer 
der weiß, wie Windows Programme in den Vollbildmodus schaltet?
Ich behelfe mir, indem ich auf "Normal"-Modus gehe und das Bild per Hand 
in die richtige Größe bringe.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Hast du schon mal die Einstellungen für den Programmstart überprüft 
(recter Mausclick auf das AVR-Studio Icon ->Eigenschaften->Ausführen. 
Dort kannst du auswählen Normales Fenster/Maximiert/... Teste mal 
'Maximiert'.

MfG Spess

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe ich ausprobiert, aber seltsamerweise hat dies überhaupt keinen 
Einfluss. Egal was angewählt ist, AVR Studio öffnet sich immer im 
Vollbild Modus.

Wenn ich das AVR Studio mehrmals hintereinander öffne, legt sich das 
zuletzt geöffnete Fenster immer wieder über das offene, allerdings etwas 
nach unten verschoben.

Dies kann ich mehrmals machen und irgenwann (nach ca 7, 8, 9... 
Versuchen)beginnt das Ganze wieder am oberen Bildrand.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Hast du mal in AVR-Studio->Options->Workspace nach gesehen? Da gibt es 
einen Punkt 'Restore Desktop Posistion... Den habe ich bei mir gesetzt.

MfG Spess

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Spess

irgenwie scheint es mit dem Windows zusammen zu hängen.
Ich habe den Rechner neu gebootet und nun funktioniert es so wie es 
soll.
Die Frage ist nur, wie lange.

Ein alter Spruch hat sich mal wieder bewahrheitet.
"Ein firscher boot, tut meistens gut"


Bei mir war unter AVR-Studio->Options->Workspace --> "use smart docking" 
angewählt.

Jetzt habe ich auch zusätzlich noch "Restore desktop postition ....." 
angewählt.

Vielleicht beinflußt irgend eine andere Applikation (z. B. Outlook, 
Word, Exel, Viso ......) das Veralten des AVR Studio. Ich werde es mal 
beobachten.

Vielen Dank für die Tipps.

MfG
Hans

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

> AVR-Studio->Options->Workspace --> "use smart docking"

Ist bei mir auch eingestellt.

MfG Spess

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Spess,

Fehler ist wieder aufgetreten und er ist auch reproduzierbar.

Es hängt mit dem Windwos Mediaplayer zusammen.
Sobald dieser im Hintergrund läuft, tritt das Problem auf.
Wird der MEdiaplayer wieder abgeschaltet funktioniert alles prima.


Danke nochmals

MfG
Hans

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Interessant. Dann bleibt dir also nichts anderes übrig, als dich auf 
eine Sache zu konzentrieren.

MfG Spess

Autor: Helmut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn bei mir Winamp läuft, tritt gleicher Effekt auf.

Autor: Hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt doch eine Möglichkeit, beide Programme laufen zu lassen.

Anscheinend ist die Reihenfolge entscheidend.

Ich habe jetzt zuerst AVR-Studio gestartet, dann das Fester minimiert.
Danach Winamp gestartet.
Wenn man jetzt das Fenster des AVR Studio wieder maximiert, dann 
funktioniert alles ohne Probleme.

Helmut, irgendwie ist es beruhigend wenn Du die gleichen Erfahrungen 
gemacht hast, so kann ich davon ausgehen das es nicht an meiner Kiste 
liegt, sondern das es ein generelles Problem ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.