www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit IC LM 741


Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi ich hab ein IC LM 741 DIP mit folgender Pinnpelegung

Pin 2  Steuersignal +
Pin 3  invertierte Masse mit 1K ohm
Pin 4  Masse
Pin 6  Ausgang
Pin 7  12 V +

mein Problem ist das ich eigentlich eine Steuerspannung von 0,5 V hab 
die ich auf 5 v anheben will, die idee ist ganz einfach liegen die 0,5 V 
an sollen diese verstärkt werden und den Transistor duchschalten fallen 
die 0,5 v ab auf 0V findet keine verstärkunk statt und der transistor 
sperrt nur das problem ist egal ob ich o,5 oder 0 v anliegen hab ich hab 
immer 12 v spannung am ausgang anliegen was mach ich falsch ist der ic 
kaputt oder hab ich einfach nur eine falsche belegung der pinns


vielen dank für die hilfe

gruß chris

Autor: AlexL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst Du Deine Schaltung mal als Bild posten? Ist schlecht sich das so 
vorzustellen.

Gruß,

AlexL

Autor: Chris@ (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich hoffe das hilft dir weiter

Autor: FRAGENSTELLER (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich glaube du hast pin 2 & 3 vertauscht

pin 2 = invertiert

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nur mal so non inverting input ist doch meine + also steuerspannung und 
inverting ist masse richtig ???

Autor: FRAGENSTELLER (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ein bild dazu

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja, und mit der Verstärkung kommst du nur auf 2,5V Ausgang bei 0,5V 
Eingang, denn die Verstärkung ist nur 5.
Kann der 741 überhaupt so nahe an Masse noch arbeiten? Ich glaube nicht!
Du wärst mit einem LM358 oder LM 324 wesentlich besser beraten.

Zu den letzten Posts: Deine Steuerspannung muss an den Non-Inverting 
Input, also an Pin 3.

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich hab jetzt mal die steuerleitung von 0.5 V weggelassen und das 
problem ist sobald ich die betriebsspannung 12v an die schaltunganlege 
steuert der transistor durch der von dem op out put  eigentlich die 
spannung auf die basis bekommen sollte aber woher kommt die spannung den
????

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
natürlich habe ich die steuerleitung 0.5 V auf pin 3 war ein tipp fehler 
von mir zuvor

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kenne deine Kenntnisse in E-Technik ja nicht, deshalb mal ganz 
einfach:

Lass mal den Transitor weg und schau dir den Ausgang vom OP an.
Lass auch mal den 1k weg. Dann müsste der OP-Ausgang genau der 
Steuerspannung folgen (zwsichen 3 und 9V Eingang). Dann mach mal einen 
zweiten 4k hin: der OP müsste jetzt bei Eingangsspannungen größer 3V 
zweifach verstärken. Unterhalb von 2-3V Eingangsspannung geht der 741 
nicht!

Ausserdem generell:
Wenn du mit dem Transistor eine 12V-Quelle an den Verbraucher anschalten 
willst, kommen vermutlich kaum 10V aus dem Transistor raus. Der 
OP-Ausgang vom 741 kommt nicht bis zur Versogungsspannung! Ebenso der 
Einang: er kann nur etwa von 2-3V bis zu 2-3V unter der VCC arbeiten. 
Bevor wir also diese Problem lösen, sollten die Randbedingungen (was 
willst du damit erreichen?) geklärt werden. Dann könnte ich dir ev. 
einen Vorschlag machen.
Für die geforderten 0,5V gehts auf jeden Fall nicht mit dem 741.

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also ich war beim conrad und hab den folgendes Prob geschildert :

Funkzentralverriegelung am Auto defekt alles was noch rauskommt ist eine 
Kurze spannungsspitze von 2.5 v die dann sofort abfällt auf 0,5 V, wenn 
ich das fahrzeug öffne, schließe ich das fahrzeug fällt die spannung auf 
0 V soweit so gut
jetzt zur schaltung nach vorschlag vn conrad, in den op 0,5 reingeben 
der vrstärkt das signal 5 fach auf 2.5 v (durch die spannungspite auf ca 
10 -12 V kurzzeitig ) das sollte reichen um den Transistor zu schalten 
und die 2.5 sollten ihn dann leitend halten, spannungsversprgung hab ich 
13,7 V die dann über den transistor auf ein kleines relai gehen und mir 
die Zentralveriegelung ansteuert,

die 0,5 V sind fix die kann ich nicht verändern !!!!!!!!!!!!!! deswegen 
ja der OP

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
auserdem hab ich das PRoblem momentan ich lege 13.7 v 
versorgungsspannung an und an den non inverting input hab ich nichts 
angeschlossen dann bekomm ich am out put des op´s eine spannung von 7 V 
die mir dann schon den transistor schalten woher kommen die 7 Volt ???? 
da dürfte doch eigentlich doch nichts sein oder irre ich mich da

Autor: HildeK (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Der bei Con*ad verkauft Elektronik - ob er sie auch versteht ...?

Nun, wenn an einem Eingang nichts angeschlossen ist, kann alles mögliche 
sein. Und selbst wenn: beide Eingänge vom 741 arbeiten erst richtig 
oberhalb ca 3V! Was darunter ist, habe ich nie ausprobiert - außerhalb 
Spezifikation!

Da deine 'Spannungsspitze' von 2.5V offenbar schon messbar ist (wie hast 
du das festgestellt?), so könnte doch auch einfach ein Transistor gehen, 
der das Relais bedient.
Also:
Emitter an GND, Basis über 470 Ohm an dein Steuersignal und das Relais 
an Kollektor und Batteriespannung. Noch eine Diode parallel zum Relais 
(in Sperrichtung, d.h. Kathode an +12V) wegen der Selbstinduktion beim 
Abschalten.

Wenn du aber während der Zeit, in der die 0.5V länger anliegen, auch das 
Relais angezogen haben willst, dann schlage ich mal die anhängende 
Schaltung mit einem Komparator vor.

Autor: Chris@ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das zeigt das messgerät kurzzeitig (digital ) an biss es sich auf 0,5v 
einpendelt

ja das relai muss dauerhafft angezogen sein wenn die spannung abfällt 
schließt er ja wieder zu

und wie funktioniert dann deine schaltung wenn 0,5V anliegen schaltet 
der Transistor durch ???

und wie heißt dein Programm das scheint ganz praktisch zu sein und was 
für ein transistor hast du verwendet muss die bauteile dann ja kaufen

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, dann gehts mit nur dem Transistor nicht.
Das Programm heißt Switcher-CAD von Linear Technologies. Gibts zum 
Download. Ist eigentlich zum Simulieren von deren ICs gedacht.

Zur Funktion des Bildes:
Mit R3 und D1 wird eine Referenz von 0.6V gemacht und durch R5 und R6 
auf etwa 0.25V geteilt.
Steigt deine Eingangsspannung über diese 0.25V an, dann geht der Ausgang 
von U1 auf 0 und der PNP-Transistor wird über R1 durchgesteuert. Ist die 
Eingangsspannung bei 0V, dann ist der Ausgang vom U1 hochohmig (open 
Collector) und der R2 macht den Transistor zu.
R4 ist eine Mitkopplung, die dafür sorgt, dass der Komparator nicht 
schwingt, wenn die Eingangsspannung so langsam über die Schwelle kommt.

Was in dem Bild natürlich nicht drin ist:
Die ganze notwendige Schutzbeschaltung für die typischen 
Automobilprobleme. Die Versogung von der Batterie sollte über eine 
Drossel und weitere C's 'gereinigt' werden, ausserdem fehlt ein 
Abblock-C am U1 (100nF über +/-). Zudem würde ich parallel zu R6 noch 
100nF schalten. Und parallel zum Relais, das im Schaltbild gar nicht 
vorkommt, muss noch eine Diode (1N4148) in Sperrrichtung.
Der Transistor könnte ein BC327 sein - das hängt aber sehr von dem 
Relais ab, das du ansteuern willst. Der kann 0.8A, das sollte reichen, 
falls das Relais nicht weniger als 20 Ohm Spulenwiderstand hat. Falls es 
mehr als 150 Ohm hätte, kannst auch einen BC556 oder BC557 nehmen.

Generell gilt: man braucht schon Erfahrung, um im KFZ eine Schaltung 
sicher funktionierend zu bekommen. Nicht böse sein, aber ich vermute, 
deine Erfahrung ist in Elektronik auch nicht soo groß - meine in der 
KFZ-Elektrik übrigens auch nicht. Zum Kern: rentiert es sich nicht, die 
Fernbedienung richtig reparienern zu lassen?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nachtrag:
was passiert eigentlich mit dem Signal der Funkzentralverriegelung, wenn 
du einen Pull-Up nach 12V an den Ausgang schaltest? Da kommt dann 
vielleicht wieder der volle Signalhub raus ...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.