www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik FT245R und MProg wollen nicht zusamen


Autor: Pö (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe den obigen USB- Seriell Chip am laufen und jetzt hab ich mir 
gedacht ich ändere mal die Bezeichnung dec Chips mit Mprog.

Also, D2xx Chip mit D2xx Treibern installiert, mprog aufgerufen, eigenes 
Template erzeugt und gespeichert. soweit so gut.
Dann: "Scan fo aviable devices"
Ergebnis:
number of blank devices=0
number of programmed devices=1
Stimmt soweit. Ist ja ein Chip angeschlossen und dessen EEprom ist ja 
von Werk programmiert.

Also:
"Programm all existing devices"

Fehlermeldung:

Error. "No device found"


Kapier ich nicht. Er zeigt doch an das er eins gefunden hat!!

Hat da mal jemand einen Tipp?

Danke Pö

Autor: Pö (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ups, hab mich verschrieben, es ist ein FT232R wofür das Mprog ja auch 
gedacht ist. Problem steht aber trotzdem .-)

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welche Version MProg hast du denn?
Welche Treiberversion?

Was macht MProg denn, wenn du nach dem Scan auf "Read & Parse" gehst?

Autor: Pö (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na das aktuelle gerade von der HP , 3.0 oder nicht?
Treiber auch die aktuellen, 2.04.06 oder so.

Hm. Probier ich morgen früh, habs gerade nicht vor mir.
read hab ich gemacht, da hat er ordnungsgemäß eingelesen, stand dann 
unten in dem Fenster.
read&parse hab ich nicht probiert.

Denke Problem liegt irgendwo anders... muß auch noch mal alle 
Devicebezeichnungen gegenprüfen.

In dem Programm gibt es rechts zwei Reiterkarten, einmal FT2232 und 
einmal FT 232R. In der Anleitng steht an der Stelle aber manchmal auch 
FT245R.. Erkennt das Programm denn automatisch den angeschlossene IC? 
Nicht das die Deviceerkennung falsch läuft...

Autor: Pö (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, Problem an sich gefunden. saß wieder vor dem Rechner...

man sollte, wenn man ein neues Template generiert, vorzugswise auch das 
richtige Device auswählen....


Ich habe trotzdem noch eine Frage:

Wenn ich jetzt das Geröt einstecke, dann erscheinen im Taskmanager 
hintereinander 3 Meldungen, die erste lautet auf "neue Hardware gefunden 
- "mein sensorname". Aber alle anderen lauten trotzdem wie bisher auf 
FTDI, usb-seriel converter. Ist das normal?, kann man da keinen Einfluß 
nehmen?

Und im Gerätemanager unter Eigenschaften Steht:

Gerätetyp: USB-Controller
Hersteller: FTDI
Ort: (Pfad0) MEINSENSORNAME


wenn das die Eintragungen sind ie ich unter "Product Description" 
gemacht habe, warum steht dann da noch FTDI.
Oder anders gefragt:
Wo erscheinen die Eintragungen die ich in "Product Description" gemacht 
habe überall?

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Also, D2xx Chip mit D2xx Treibern installiert ...

Nur als Hinweis: In diesem Treiber steckt sowohl der D2xxx- als auch der 
VCP-Treiber.

Das ist alles imoh alles korrekt so, die Discription und so kannst du 
z.B. mit deinem eigenen Programm auslesen, wenn du den D2xx-Treiber 
ansprichst.
Du kannst die VID, PID, und vom Treiber die *.inf Datei ändern. Dann 
erscheint auch im Gerätemanager dein Wunschtext.

Autor: Sirko Pöhlmann (poehli)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Martin wrote:
>> Also, D2xx Chip mit D2xx Treibern installiert ...
>
> Nur als Hinweis: In diesem Treiber steckt sowohl der D2xxx- als auch der
> VCP-Treiber.

Das macht doch nix, oder?

> Das ist alles imoh alles korrekt so, die Discription und so kannst du
> z.B. mit deinem eigenen Programm auslesen, wenn du den D2xx-Treiber
> ansprichst.
> Du kannst die VID, PID, und vom Treiber die *.inf Datei ändern. Dann
> erscheint auch im Gerätemanager dein Wunschtext.

Danke für den Hinweis. Dachte ich hab da mal ein Appl. Note von FTDI 
dazu gesehen, konnt sie aber nicht finden.

Alles klar, hab ich gemacht mit den inf Dateien. Dumm nur das damit 
sofort die WHQL Zertifizierung flöten geht....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.