www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MSPGCC,ECLIPSE und LPT


Autor: Marco Dennstedt (marcod)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin bestimmt nicht der erste der ein solches Problem mit mspgcc und 
Eclipse hat, habe aber im Forum leider nix passendes gefunden.

Ich habe nach Anleitung die Einrichtung von mspgcc und eclipse 
vorgenommen bekomme aber keinen Kontakt zum MSP über den GCC Proxy.
Das FET hängt an der LPT1 aber der MSP wird nicht erkannt.
Kann mir da jemand helfen?

Vielen Dank im Voraus!

mfg
Marco

Autor: MartinH (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welcher  MSP430 ?
Welche GCC Version ?

Gruß

Autor: Marco Dennstedt (marcod)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

der MSP ist ein F4618 und die mspgcc Version ist mspgcc-20070216..

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Marco,

Du willst also debuggen und bekommst keine Verbindung?
Klappt denn die Übertragung deines Programms auf den MSP?
Gibts irgendwelche Fehlermeldungen? Beschreib mal mehr und genauer!

Autor: Marco Dennstedt (marcod)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

die folgende Zeile gebe ich in der Konsole im Ordner mspgcc ein:
msp430-gdbproxy --port=3333 msp430
Als Antwort bekomme ich das er das Target nicht findet.
Als Targetboard ist das Experimentierboard von TI mit MSP430 FG4619 und 
20xx angeschlossen.
Der FG 4619 soll angesprochen werden.

Hat jemand ne Idee was da falsch laufen könnte?

Gruß
Marco

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wird denn der recht neue F4618 überhaupt schon unterstützt? Hast du mal 
mit der kostenlosen IAR Version probiert, ob du Zugriff hast? Welches 
Windows benutzt du? Ist der portio Treiber richtig installiert?

Autor: Johnny Maxwell (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Als Antwort bekomme ich das er das Target nicht findet.

Vielleicht hast du es noch nicht bemerkt, aber die indirekte Rede ist 
bei Fehlermeldungen nicht wirklich hilfreich.

Autor: Marco Dennstedt (marcod)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Johnny Maxwell:
Ja ich weiss das das nicht besonders hilfreich ist, sorry...

Das mit dem recht neuen F4619 kann ich bestätigen, habe es mit einem 
F449 probiert da kriege ich sofort Kontakt und der Prozessor wird sofort 
erkannt.

Vielen Dank an alle Beteiligten für ihre Tips!

Gruß
Marco

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja ein Blick in die Liste der aktuell unterstütztden µC des MSPGCC 
hätte auch geholfen. aber gut. Schade dass die neuen immer noch nicht 
benutzt werden können.

Autor: Marco Dennstedt (marcod)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja ist echt schade....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.