www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ist mein nagelneuer AVRISP mkII schon kaputt?


Autor: Josef Kaeufl (josefk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich bin nun verzweifelter Besitzer eines AVRISP mkII. Leider geht damit 
garnichts.
Ich habe jetzt schon zwei Schaltungen mit dem AVRIPS und einem STK500 
Nachbauf programmiert. Immer das gleiche. Mit dem STK500 kompatiblen 
Programmer auf irgendeiner Com Schnittstelle klappt alles wunderbar. 
Sobald ich aber meinen AVRISP auswähle und an meine Platine anstecke 
blinkt das Kontrolllämpchen nur rot und AVRStudio bringt folgende 
Fehlermeldung:
"[...]The ISP connector appears to have been connected the wrong way, or 
the reset line may have an incorrect pull-up. See the Users Guide's 
Troubleshooting section.[...]"

Falsch rum ist er nicht angesteckt. Habs aber trotzdem mal andersrum 
probiert :) Kein Erfolg. Der Widerstand zwischen Reset-Pin am Stecker 
und µC ist 0,9 Ohm. Das sollte also auch passen.

Was kann das dann nur sein?

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit pull-up der reset-line ist imho nicht der Leiterwiederstand zwischen 
ISP-Stecker und Zielcontroller gemeint, sondern etwas anderes:

Am Reset-Pin des Zielcontrollers soll ein R (typ. ca. 10kOhm) gegen die 
Betriebsspannung Vcc geschaltet sein. Der ISP-Anschluss kommt dann quasi 
hinter den Widerstand (von der Spannungsquelle aus gesehen).

Schöne Grüße,
Alex

Autor: Josef Kaeufl (josefk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achso,

ist aber alles richtig mit der Hardware. Der 10k PullUp ist bei Reset 
drauf.

Mir scheint, dass ich entweder zu blöd bin irgendwelchen Einstellungen 
für den AVRISP vorzunehmen, oder dieser einfach kaputt ist.

PS: Treiber habe ich nicht explizit installiert. Windows hat da selber 
was dazu gefunden. Sollte ja auch einfach nur ein FTDI Chip (oder 
Ähnliches) dahinter stecken, der mit Standarttreibern versorgt wird.

Autor: Thomas W. (thomasw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du evtl mal einen Schaltplan posten?

Autor: Gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
checke mal die Seriennummer deines AVRISP MKII
Manche haben einen Fehler in der Firmware.
(Seriennummer 20071012 bis 20080130)
Von Atmel gibt es einen Bugfix:
http://www.atmel.fi/dyn/resources/prod_documents/a...

Autor: Josef Kaeufl (josefk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lol. Hab echt einen Programmer aus der Reihe. Glück muss man haben.

Autor: Alex Bürgel (Firma: Ucore Fotografie www.ucore.de) (alex22) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, Glück jemanden zu finden, der von diesem Fehler wusste :-)

Autor: FBI (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie schon anderswo geschrieben, immer wieder einen Blick wert:
http://www.atmel.no/beta_ware/

Autor: Christian U. (z0m3ie)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Selbst im Beta des AVR Studios ist dieser Bug in der Firmware noch nicht 
behoben. Also nicht auf das aktuelle Release auch wenns die Beta ist 
verlassen. Das Update von der Website nehmen und gut is.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.