www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik und wider einmal cypress cy7c68013a


Autor: Marco Hartung (hilfesuchender)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und guten Morgen

Ich habe ein Problem mit dem Cy7c68013:

ganz kurz -- Schaltung aufgebaut , angeschloßen , cyusb.inf wie 
beschrieben angepasst und treiber installiert.  Lief super - und auch in 
der CyConsole  wurde er erkannt.

Jetzt mein Problem: nach diesem Erfolgserlebnis hab ich den computer 
runtergefahren. Als ich am nächsten tag weitermachen wollte, wurde nix 
mehr erkannt.
Meldung:  "gerät konnte nicht gestartet werden"  (bei doppelklick auf 
Gerät - Eigenschaft im Gerätemanager)
Auch mehrere neuinstallationen des Treibers halfen nicht
Da die Schaltung ja schon einmal erkannt wurde, gehe ich davon aus das 
sie in Ordnung ist ?? - wenn dem nicht so sein sollte, wie kann 
überprüfen ob der chip Ok ist? Hab alles da (zum messen), nur keine 
Erfahrung mit diesem chip

Danke im Voraus

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie hast du denn den Reset-Pin des 68013 angeschlossen? Hast du die 
Firmware im EEPROm oder ganz ohne Firmware oder wird die über USB 
geladen? Abziehen und neu Anstecken bringt nix? Was sagt denn USBView?

Autor: Marco Hartung (hilfesuchender)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Reset-Pin hab ich über ´nen RC Glied (27k und 1µF) - für die 
Zeitverzögerung angeschloßen.
Habe keinen EEprom, die Firmware soll über usb geladen werden.
Nein abziehen und neu anstecken bringt nix - Nur das übliche - Usb 
device (mit gelben ausrufezeichen) verschwindet beim abziehen aus´n 
geräte manager und beim anstecken erscheint das  Usb - Device mit 
gleiche gelben zeichen wieder (gelbe zeichen : Gerät konnte nicht 
gestartet werden)
Werde USBDevice gleich Montag testen.

Autor: Christian R. (supachris)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marco Hartung wrote:
> Den Reset-Pin hab ich über ´nen RC Glied (27k und 1µF) - für die
> Zeitverzögerung angeschloßen.

Du hast also das Dokument "Power and Reset-Considerations" nicht 
gelesen. Mit so einer langen Verzögerung klappt das nichtmal bei 
self-powered ordentlich. Bei Bus-powered schon gar nicht.
Lies das Dokument von Cypress.

Autor: Marco Hartung (hilfesuchender)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wo liegt das Dokument bei cypress? hab alles durchsucht

die werte für das RC_Glied hab ich dem 
"ez_usb_r___technical_reference_manual__trm__14.pdf"
kapitel 7 "Resets" entnommen

Autor: Marco Hartung (hilfesuchender)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab´s gerade gefunden - werde jetzt lesen

Autor: Marco Hartung (hilfesuchender)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

so, hatte mir die pdf mal durchgelesen und bin nach reichlich messen zu 
dem entschluß gekommen, dass es nicht am RESET und dem RC-Glied lag - 
eher daran das der chip kaputt war (vermutung: ladete mich ständig e. 
statisch  auf  und entlud mich überall - sicher auch mal an meiner 
Schaltung) hab also Chip getauscht und trage jetzt anti e. statisch 
labor schuhe - naja nur so nebenbei - aber bisher lauft die schaltung 
stabil, treiber erkannt, Firmware drauf

also Danke für deine hilfe supachris - werde bestimmt nochmal mit ein 
paar fragen auftauchen

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.