www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik jmp $0000 - Befehl ?


Autor: Uwe Seidel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
bin immernoch am bootloader-kämpfen.
dieser code ist jetzt mal nur zum testen der funktion.
folgendes:
ganz am anfang wird "Reset" an das uart gesendet. geht.
sende dann zur kontrolle ständig das über uart empfangene byte zurück.
sollte das byte 'r' sein soll nach $0000 gesprungen werden.
aber dann sollte ja alles von vorn beginnen oder etwa nicht.
hin wie her ... der sprung macht nicht das was er soll.
hab die datein mal angehangen. vielleicht kann mir mal einer
sagen , was da sache ist.
BTW in der simulation ist alles richtig.

Ciao Uwe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.