mikrocontroller.net

Forum: PC Hard- und Software Probleme mit PonyProg und LPT1


Autor: Tobias Müller (tobim)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tagchen,

hab mir vor kurzem eine PCI Erweiterungssteckkarte gekauft, damit mein 
neuer PC auch nen LPT Port besitzt.
Ich konnte die Karte korrekt installieren und ich sehe nun im 
Gerätemanager einen Eintrag im Knoten "Anschlüsse (COM und LPT)" der 
lautet "MosChip PCI Parallel Port (LPT1)".

Jetzt das Problem:
sobald ich in PonyProg (Version 2.07c Beta) in das Interface Setup gehe, 
um meinen Port, mit dem ich meine Microcontroller ansteuere, zu 
definieren, wird leider kein LPT Port angezeit bzw. die Ports LPT1 - 3 
sind deaktiviert (Optionbox Parallel ist markiert und die Combobox hat 
den Eintrag "AVR ISP I/O").

Wahrscheinlich erkennt mein PC diese PCI Schnittstelle nicht. Anders 
kann ich mir das nicht erklären. Hab aber auch keine Ahnung, wie ich das 
anstellen muss, damit es funktioniert. Hab auch schon im BIOS 
nachgeschaut...

Kann mir jemand hefen??? oder zumindest einen Tip gebeb?
oder hatte jemand so ein Problem???

Mfg
Tobi

Autor: Peter Bandhauer (basejump)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du die LPT IO Adresse (glaub 0x0378 bis 0x037F) von deinem PC 
freigeben und sie deiner Karte zuordnen?

Müsste unter Windows einstellbar sein.

Stell auch SPP ein (Standard Parallel Port)

Autor: Tobias Müller (tobim)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich kann im gerätemanager lediglich die bezeichnung, also lpt1 - lpt3 
auswählen. wo kann ich denn unter win die io adresse eingeben?

Autor: Peter Bandhauer (basejump)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geh mal in die Systemsteuerung und da dann auf den Gerätemanager.
Da suchst du deinen LPT Port aus, lass dur seien Eigenschaften anzeigen 
und wähle Ressourcen aus.

Deaktiviere da einfach mal das "Automatisch konfigurieren" und stell 
einen anderen E/A-Bereich ein. (Dasiskonfiguration ...)

Hast du zur Karte irgend ein Treiber/Software dazu bekommen?

noch was:
Beitrag "LPT-Karte die x.te."

Autor: Tobias Müller (tobim)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
diese checkbox ist leider deaktiviert....
wie kann ich sie aktivieren?

Autor: Hans-der-kanns (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tobias Müller schrieb:
> diese checkbox ist leider deaktiviert....
> wie kann ich sie aktivieren?

Für den Fall, dass immer noch jemand eine Lösung suchen sollte oder 
aktuell, so wie ich, auf dieses Problem stoßen sollte:

Lösung:
1. PONYPROG2000.INI im Programmordner öffnen
2. folgenden Eintrag von "YES" auf "NO" abändern >>> AutoDetectPorts=NO
3. folgenden Eintrag mit den Infos aus Gerätemanager/LPT/Ressourcen 
ergänzen: z.B. E/A-Bereich E400 - E407 >>> LPTPorts=E400
4. speichern - FERTIG!

------------------------------------------------------------------------

Anlass war bei mir ebenfalls der sagenumwobene MosChip MCS9805, der als 
separate PCI-Steckkarte auf dem Mainboard sitzt.
Nachdem ich die INI-Datei abgeändert hatte, lief mit PonyProg 2.07a beta 
alles einwandfrei!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.