mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Abschaltverhalten von Mosfets und IGBTs messen


Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
In etlichen Application Notes zu IGBTs findet man Bilder der Strom und 
Spannungsverläufe beim Abschalten von IGBTs und daraus errechnet die 
Verlustleistung. Hier finden sich z.B. solche Kurven in Figure 7-9 auf 
Seite 4: http://www.irf.com/technical-info/whitepaper/apec0...
Ich wollte das ganze mal nachmessen, allerdings sehen meine Kurven 
leicht anders aus als die aus den AppNotes.

Der prinzipielle Aufbau:
Der IGBT/Mosfet wird über einen kräftigen Mosfet Treiber über 10 Ohm am 
Gate mit etwa +13V / -2V versorgt. Emitter/Source ist mein 
Massepotential vom Oszilloskop und der restlichen Schaltung um eine 
Beeinflussung der Strommessung durch den Gatestrom zu vermeiden. Die 
Strommessung geschieht über einen 33mOhm Shunt im TO-247 Gehäuse. Dieser 
liegt zwischen dem negativen Pol einer potentialfreien Spannungsquelle, 
die durch mehrere 68µF Elkos und einen 1µF Folienkondensator gepuffert 
wird und Masse.
Zwischen Drain und positiver Betriebsspannung liegt eine Spule (kleiner 
Ringkern mit etwa 100µH), und parallel dazu eine schnelle Diode 
(HFA25PB60) die die Energie der Spule nach dem Abschalten verheizen 
darf.
Nun wird der IGBT/Mosfet eingeschaltet und der Strom gemessen. Sobald 
dieser über einen bestimmten Wert geht, wird abgeschaltet.

Dabei wird die Drain/Collector - Source/Emitter Spannung und der 
Source/Emitterstrom gemessen.

Im ganzen sieht der Strom/Spannungsverlauf so aus wie im Anhang (rot: 
Kanal 1: Spannung, grün: Kanal 2: Strom).
Dunkelgrün bzw. Dunkelrot gestrichelt sind jeweils die Nulllinien 
eingezeichnet.
Der Ringkern beginnt etwas in die Sättigung zu gehen, aber das dürfte 
keinen Einfluss haben, da die Spule nur als zeitabhängige Stromquelle 
missbraucht wird.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wenn man den Abschaltzeitpunkt allerdings vergrößert betrachtet und mit 
dem im Datenblatt vergleicht, dann sieht die Kurve doch ziemlich 
unterschiedlich aus.
Der Verlauf der Spannung ist vergleichbar mit der Kurve aus dem 
Datenblatt, auch wenn die Spitze bei mir sehr viel größer ist.
Was mich allerdings stört, ist die negative Spitze beim Strom:
Bei rund 18mV/A -> 5,5A/div komme ich auf einen Strom von fast -30A.

Jetzt rätsel ich schon die ganze Zeit, wieso der Strom negativ wird, und 
vor allem, wie ich die Spitze weg bekomme.

Meine Vermutung: Durch die Spannungsspitze wird Energie in den 
parasitären Kapazitäten in der Diode oder im IGBT/Mosfet gespeichert. 
Diese wandert anschließend zurück in die Spule bzw. andere parasitäre 
Induktivitäten, wodurch der negative Strom zustande kommt. Der 
Strom/Spannungsverlauf erinnert nämlich stark an den Verlauf bei einer 
Horizontalendstufe in einem TV.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich hätte ich erwartet, dass der IGBT einen flacheren Verlauf der 
Strom/Spannungskurve zeigt, da dieser langsamer schaltet als ein Mosfet.
Aber irgendwie ist es genau umgekehrt.
Dies bestätigt aber meine Theorie, dass es sich um parasitäre 
Kapazitäten handelt.

Jetzt allerdings die Frage: Wieso haben die Kurven in obigem Datenblatt 
dieses Problem nicht?

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
frage 1: wieso ist Strom beim Einschalten nicht linear?
Frage 2: Tastkopf ch2 an neg. Versorgung? dann sollte doch I negativ 
sein bei on, oder invertiert dargestellt?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
faraday wrote:
> frage 1: wieso ist Strom beim Einschalten nicht linear?

Weil die Spule etwas in die Sättigung kommt.

> Frage 2: Tastkopf ch2 an neg. Versorgung? dann sollte doch I negativ
> sein bei on, oder invertiert dargestellt?

Ja, ist invertiert.

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sicher, daß neg. Spitze nicht vom Masseclip (kurz) kommt?
Schließ mal Tastkopf 2 kurz und miß nochmal.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich denke das kann ich ausschließen:
Das Signal vom Shunt geht direkt über einen 47 Ohm Widerstand (zur 
Impedanzanpassung an das RG58 Kabel) an die BNC Buchse.
Direkt am Oszi hängt auch nochmal ein 50 Ohm Abschlusswiderstand.
Nur die bis zu 600V der Spannungsmessung möchte ich ungern direkt ins 
Oszi schießen, daher da über einen 10:1 Tastkopf. Momentan sind das aber 
nur etwa 20V + Überschwinger beim Abschalten.

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
dann schließ mal den Shunt kurz

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Direkt kurzschließen kann ich leider nicht, da der Shunt für die Messung 
des Stromes zum Abschalten benötigt wird.
Ich habe aber mal die Leitung vom 47 Ohm Widerstand auf den anderen 
Anschluss des Shunts geklemmt, also quasi den Messausgang 
kurzgeschlossen.
Ein paar Störungen sind immer noch da, aber das sind nur noch etwa +/-1A 
statt den -30A, also vernachlässigbar.

Autor: G_dal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was du beim IGBT misst ist der sogen. Tail(zu dt. Schwanz)-Strom.
Beim IGBT völlig normal, ist nur verschieden groß je nachdem ob du einen 
PT, NPT oder Trench IGBT hast. Google das mal.

Autor: G_dal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da kannst du übrigends nichts dagegen machen, außer nen anderen IGBT 
nehemn.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diesen Tailcurrent erwarte ich ja auch, aber laut den Beschreibungen 
nach müsste dieser positiv sein.
Nur ist mein Strom leider negativ...

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Application Note steht, dass der Gate-Treiber Widerstand zum 
Abschalten so optimiert wurde, dass lediglich 10% Spannungsüberschwinger 
am Drain/Collector aufgetreten sind. Von daher ist Dein Aufbau damit 
wohl nicht vergleichbar, da Deine Überschwinger bei >100% liegen.
Du hast sicherlich recht mit Deiner Vermutung, es wird sich um die 
Entladung von Sperrschicht/Diffusionskapazitäten handeln.

Autor: G_dal (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
war wohl etwas zu voreilig, tail-Strom ist das nicht

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Spike bei der Spannung scheint durch die parasitären Induktivitäten 
zu entstehen. Je nachdem wo ich messe, kann ich die Amplitude auf etwa 
die Hälfte reduzieren. Selbst an den Elkos ist ein kleiner Hügel 
sichtbar.

Das Platinenlayout ist nicht perfekt, das ist mir klar, aber dass es so 
extrem ist, hätte ich nicht erwartet. In der Praxis ist das Layout mit 
Sicherheit auch nicht sehr viel besser...

Ich habe mal etwas am Gatewiderstand gespielt: Ich muss auf >100 Ohm 
gehen um den den Spannungspeak einigermaßen wegzubekommen.
Damit der Strom nicht negativ wird, sind es schon 1kOhm Gatewiderstand.
Wie die Kurvenform dann aussieht, kann man sich leicht vorstellen...
Desweiteren frage ich mich, wie realistisch die Ergebnisse sind, wenn 
man den Gatewiderstand anpasst, dass die Kurve gut aussieht.

Was muss ich machen, um den Tailcurrent zu sehen?
Ich habe die Spule auch mal durch einen 1 Ohm Widerstand ersetzt, das 
ändert an der Kurvenform vom Strom beim Abschalten nahezu nichts.
Ich war auch schon bei 200V 20A, aber auch das ändert an der Kurvenform 
nahezu nichts.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der Spike bei der Spannung scheint durch die parasitären Induktivitäten
> zu entstehen.

Wenn wir den Messergebnissen mal glauben, liegt die 
Flankengeschwindigkeit des Stromes bei 17A/10ns. Bei den üblichen 
10nH/cm ergibt das, mit V=L*di/dt, gute 17V pro cm Leitungslänge. Das 
ist gerade mal die Länge der Diode! Auch über der Shuntlänge wird es 
eine entsprechende Überhöhung geben, weil der Shunt bei Deinem Aufbau ja 
keine gegenkoppelnde Wirkung hat.

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich habe die Spule auch mal durch einen 1 Ohm Widerstand ersetzt, das
>ändert an der Kurvenform vom Strom beim Abschalten nahezu nichts.

Irgendwas ist hier faul.
Ich denke, daß Dein Tailstrom durch den neg. Stromspike überdeckt wird.
Ich glaube auch, daß die angegebenen Kurven stimmen.
Auch am Layout wird's nicht liegen. Irgeneine "Kleinigkeit" wurde 
übersehen.
Was Du machen könntest:
- Schaltplan aufzeichnen + posten
- größere Spule nehmen
- anderen IGBT nehmen

Warum Du den Shunt nicht kurzschließen kannst, habe ich nicht 
verstanden.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es lang wirklich am Shunt, da wäre ich nie drauf gekommen! Danke!
Ich hatte extra diesen Shunt verwendet, da dieser intern quasi auch SMD 
ist, und daher eine niedrige Induktivität hat, aber die war wohl immer 
noch zu groß.

Ich habe mal einen neuen Shunt gebastelt, jetzt sieht der Strom am IGBT 
sehr viel besser aus. Man kann sogar den Tailcurrent etwas erkennen.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So sieht der neue Shunt aus:
20x 1 Ohm 0603 parallel. Kurzzeitig wird er die 20A schon aushalten...

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
faraday wrote:
> Warum Du den Shunt nicht kurzschließen kannst, habe ich nicht
> verstanden.

Da ich das Abschalten bei einem bestimmten Strom untersuchen möchte, 
geht das Signal vom Shunt zu einem Komparator (LM311), wo es mit einer 
Referenzspannung verglichen wird.
Überschreitet der Strom einen bestimmten Wert, wird ein RS-Flipflop 
zurückgesetzt und beendet den Einschaltzyklus. Somit ist das ganze 
kurzschlussfest, ich kann anstelle der Spule auch nur ein Stück draht 
verwenden.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Layout rund um den Drain, die Gateanbindung usw. etwas 
optimiert (da jetzt der Platz des früheren Shunts frei wurde), jetzt 
sieht man den Tailcurrent relativ gut: Es sind immerhin rund 1A (2A/div) 
über >200ns.

Nochmals danke an alle! Da wäre ich nie drauf gekommen.

Gut, dass ich eine 10000er Rolle 1 Ohm Widerstände habe, jetzt weiß ich 
für was ich die gebrauchen kann...

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Es lang wirklich am Shunt, da wäre ich nie drauf gekommen!

und wie bist Du nun auf den Shunt gekommen?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also wegen des Verhaltens bei  "ohmscher"  Belastung

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein: Der Shunt war zu groß (von den Abmessungen her). Daher hat er, 
alleine durch deine Länge einen induktiven Anteil. Und der hat dann 
diesen Spike produziert.
Der alte Shunt hatte etwa 25mm Weglänge die der Strom durchlaufen 
musste, beim neuen (0603) sind es gerade mal etwa 2mm.

Autor: flätz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke mal, dass eine gute Stromzange hier gute Dienste leistet. Wenn 
ich das richtig sehe, tritt die Überhöhung haupsächlich über der 
primären Streuinduktivität des Stromwandlers auf, und gelangt dadurch 
nicht an den Messeingang. Zumindest wird es hier so gemacht:


http://www.st.com/stonline/products/literature/anp/8415.pdf

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe gerade den ganzen Thread durchgelesen, und wollte mich für die 
guten Bilder bedanken, anhand derer man das ganze gut nachvollziehen 
konnte. (Auch wenn ich nicht alle 20 Rs gefunden habe.)
Und natürlich auch bei Flätz für des Rätsels Lösung.
Das 3cm schon zuviel sind hätte ich auch nicht gedacht, aber mit der 
Rechnung von flätz gibt das schon Sinn. 3cm * 10nH/cm * 17A/10ns =51V

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexander Schmidt wrote:
> (Auch wenn ich nicht alle 20 Rs gefunden habe.)

Die sind auf 3 Ebenen übereinander, 20x 0603 ist doch schon eine Menge 
Zeug, vor allem wenn es kompakt sein muss.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.