mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Netzteil mit OP 084-Verständnisproblem


Autor: Uwe Spalteholz (winterschlaefer)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe irgendwie einen Aussetzer beim Lesen des beiliegenden 
Schaltplans.
Es ist ein Netzteil aus einer älteren Funkamateurausgabe, welche 
angeblich
sehr genaue Spannungskonstanz hat.
Nun wollte ich diese Schaltung in mein Freewareeagle eingeben und
scheitere jedoch an den 3 Massepunkten.
Könnte es sein, das die mit 0 Ausgang verbunden werden müssen oder 
bleiben die potentialfrei und nur miteinander verbunden.
Die Versorgungsspannung für den OPV greife ich direkt nach den Ladeelko
ab,Richtig?
Bitte um Hilfe

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese "Massen" müssen mit dem 0V-Ausgang verbunden werden. Am besten an 
der Stelle an dem auch der Rükckopplungswiderstand für die 
Spannungsregelung mit 0V verbunden ist. Alles möglichst nahe am Ausgang, 
damit die Spannungsabfälle auf den Leitungen, verursacht durch den 
Laststrom, ausgeregelt werden.
Da muss ein Single-Supply Opamp rein, z. B. LM324. Dann muss man 
allerdings die Rückführwiderstände kleiner machen; 10k, 15k. Ein TL084 
wäre völlig falsch, es sei denn man hat eine zusäzliche Versorgung mit 
-3V oder negativer für die Opamps.

Autor: Peter R. (pnu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Massepunkte sind die gegen Massestrom empfindlichen Punkte, sie 
sollten am 0V-Punkt zusammengeführt werden, möglichst sternförmig.

Auch für die restliche Schaltung gilt es, dass der 0V-Anschluss der 
Bezugspunkt ist.

Der Stromkreis zwischen Brücke und Ladeelko ist unkritisch, er sollte 
aber mit 0V über eine niederohmige Leitung verbunden sein, die "hinter" 
dem Ladeelko beginnt, also keine Anteile des zwischen Brücke und 
Ladeelko fließenden Stroms führt.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tipp fürs Layout.

Mach gleich mal einen Platzhalter für einen kleinen Kondensator rein und 
zwar jeweils zwischen dem -Eingang und dem Ausgang von Opamp A2 und A3.
Es könnte nämlich gut sein, dass die Schaltung schwingt, wenn am Ausgang 
des Netzteils ein Kondensator angeschlossen wird. Ein C mit ca. 100pF 
könnte das dann richten.

Autor: Dr.PillePalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
moin

wenn der Ausgang des LM324 auf ca. 0,6V hängenbleibt wars nix mit 0Volt 
am Ausgang,dagen kann aber eine 2,7V Zenerdiode in der Basisltg. helfen.
Ansonsten ist das die klassische ELO / Elrad Schaltung  halt 1984 als 
der 324 auf den Markt kam.

mfg

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wenn der Ausgang des LM324 auf ca. 0,6V hängenbleibt

Du hast du die 2*Ube vergessen.
Mit dem LM324 kommt sehr wohl auf 0V am Ausgang heran.
Einzig allein die Strombegrenzung geht nicht ganz bis 0A bei 0,0xV.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Schaltung kannst Du genau so nachbauen, wie sie angegeben ist.
Ich habe sie vor Jahrzehnten mit dem B084 vom Halbleiterwerk Frankfurt
/Oder aufgebaut und sie hat mich nicht im Stich gelassen.

Wichtig ist, was Helmut S. um 11.19 Uhr in seinem ersten Absatz schrieb.

MfG Paul

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
>> wenn der Ausgang des LM324 auf ca. 0,6V hängenbleibt
>
> Du hast du die 2*Ube vergessen.
> Mit dem LM324 kommt sehr wohl auf 0V am Ausgang heran.
> Einzig allein die Strombegrenzung geht nicht ganz bis 0A bei 0,0xV.

Auch die Strombegrenzung sollte praktisch bis 0A herunterreichen, wenn
man für VD6 statt einer SY320 eine Schottkydiode mit geringerem
Spannungsabfall nimmt.

Ich verstehe in diesem Zusammenhang nur nicht ganz, welchen Zweck das
5k-Trimmpoti rechts oben haben soll. Eine Strombegrenzung von (nahezu)
0A ist nur möglich, wenn das Trimmpoti auf 0Ω eingestellt ist. Warum
lässt man es dann nicht gleich weg? Sollte es zur Einstellung des
Maximalwerts der Strombegrenzung dienen, müsste es mit dem 10k-Poti
vertauscht werden. Oder habe ich gerade ein Brett vor dem Kopf?

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Sollte es zur Einstellung des Maximalwerts der Strombegrenzung
> dienen, müsste es mit dem 10k-Poti vertauscht werden.

Da liegst du richtig. Poti und Trimmpoti müssen vertauscht werden.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poti und Trimmpoti sind in der Schaltung richtig. Damit wird die 
minimale Strombegrenzung eingestellt (0mA macht ja keinen Sinn). Der 
Maximalstrom ist durch VD7 und den 0,5 Ohm Shunt vorgegeben und braucht 
nicht eingestellt werden.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> 0mA macht ja keinen Sinn

Soso, und warum haben praktisch alle besseren Labornetzgeräte eine 
Strombegrenzung von 0 bis xA?

Es macht sehr wohl Sinn, dass man die Strombegrenzung bis (fast) auf 0A 
einstellen kann.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Krümelkacker  :)

Helmut S. schrieb:
> dass man die Strombegrenzung bis (fast) auf 0A
> einstellen kann

Deine Antwort dazu.

Und daß man den Trimmer für den Minimalstrom auch auf fast 0 stellen 
kann ist meine Antwort dazu.

Fazit ist trotzdem, daß die Anordnung stimmt.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Manche Leute lassen sich halt nicht helfen. Da kann man nichts machen.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schrieb:
> Manche Leute lassen sich halt nicht helfen. Da kann man nichts machen.

Bist Du jetzt übellaunig?

Wenn der Spannungsabfall am Shunt die Flussspannung von VD7 übersteigt, 
hast Du den Maximalstrom - da muss nichts eingestellt werden.

Mit dem Einstellregler wird der Minimalstrom eingestellt. Wenn man auf 
eine Einstellung des Maximalstromes Wert legt, kann man natürlich mit 
einem 2. Einstellregler den Regelbereich des Potis zur anderen Seite 
ebenfalls einschränken.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es geht doch darum, das die Strombegrenzung ab 0A eingesetllt werden 
soll. Das lässt sich ohne Mehrkosten machen, wenn man Poti und Trimmpoti 
vertauscht.
Vermutlich wurde die Schaltung einmal falsch abgedruckt und da die 
Nachbauer halt meistens Anfänger waren, haben sie denn Sinn des
Trimm-potis auch nie verstanden. Das sollte rihtig eingebaut dazu 
dienen, den max. einstellbaren Strom abzugleichen.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Schaltung wurde nicht falsch abgedruckt. Eine Strombegrenzung auf 0 
zu setzen, ergibt für mich keinen Sinn. Denn das bedeutet, daß kein 
Strom entnommen werden kann. Ob nun 5 mA oder 50 mA, daß kann man seinen 
Bedürfnissen nach mit dem Trimmer einstellen.

Du darfst auch in dem Zusammenhang den 4,7 kOhm Widerstanf parallel zum 
Ausgang nicht vergessen. Der Stromfluss durch ihn ist von der 
Ausgangsspannung abhängig. Schon deshalb ist eine Regelung ab 0 sinnlos. 
Das Ganze ist keine präzise, aber eine ausreichende regelbare 
Strombegrenzung.

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal Figure 17 an wo das Poti liegt. Das ist von Leuten 
geschrieben die mehr Netzteile entwickelt haben als wir alle hier 
zusammen.
http://www.slack.com/pdf/HP-AN90B.pdf

Es ist ja erstmal normal, dass du versuchst deine Schaltung mit allen 
Mitteln zu verteidigen um den Design-Review zu überstehen, aber man muss 
halt auch mal zugeben können, dass (d)eine Idee nicht so der Bringer 
war.
Der Fragesteller macht gerade ein Layout, da kann er die Schaltung 
gleich richtig machen. Damit hat er dann die bessere Strombegrenzung.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist nicht "meine" Schaltung.

Der Maximalstrom ergibt sich aus dem "Trick" mit der Diode. Es spielt in 
meinen Augen keine Rolle, ob der nun 1,1A oder 1,3A beträgt - denn er 
ist mit dem Poti einstellbar.

Die Lage von Poti und Trimmer ist allerdings notwendig (und ergibt sich 
aus diesem Design), da bei 20V und keiner Last am Ausgang schon 4,25 mA 
fließen.

Die anderen Schaltungsvarianten sind mir auch bekannt.

Es gibt nichts, was ich hier zugeben müsste (wobei ich keine Probleme 
damit hätte, Fehler einzugestehen). Ich versuche lediglich, die 
Anordnung von Poti und Trimmer verständlich zu machen.

Es steht ja frei, auch die Stromobergrenze einstellbar zu machen. Das 
ist in der Schaltung eben nur nicht vorgesehen worden.

Ob er die Schaltung nun so macht wie aus seinem Post, oder so wie in 
Deiner PDF, hängt einfach mal von seinen Genauigkeitsforderungen ab. Da 
gibt es kein richtig oder falsch.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Huch, da hat man irgendwas geschrieben, geht man mal kurz weg, und schon
kriegen die Leute sich in die Haare ;-) Naja, so schlimm ist es ja noch
nicht.

Irgendwie will es mir aber nicht einleuchten, warum man das Minimum der
Strombegrenzung abgleichen können wollte. 0A als festes Minimum ist doch
in Ordnung. Auch das Maximum muss nicht unbedingt abgleichbar sein. Hat
man allerdings zwei dieser Netzgeräte, ist es schön, wenn beide bei voll
aufgedrehtem Poti den gleichen Strom liefern. Und bei Serienprodukten
macht es einen guten Eindruck, das sich alle verkauften Exemplare gleich
verhalten.

Bei der Spannungseinstellung sitzt der Trimmer ja auch am "richtigen"
Ende, d.h. man kann mit dem 10k-Poti die Ausgangsspannung bis 0V ein-
stellen und zusätzlich mit dem Trimmer die Maximalspannung abgleichen.
Warum sollte dies beim Strom anders sein?

mhh schrieb:
> Die Lage von Poti und Trimmer ist allerdings notwendig (und ergibt sich
> aus diesem Design), da bei 20V und keiner Last am Ausgang schon 4,25 mA
> fließen.

Das ist ein kleiner Schönheitsfehler, da wegen des 4k7-Widerstands am
Ausgang der Ausgangsstrom bei aktivierter Strombegrenzung eine leichte
Abhängigheit von der Ausgangsspannung aufweist. Allerdings ist der
Fehler von maximal 4,25mA so gering, dass ich mich nicht daran stören
würde. Der Widerstand ist wohl dazu da, bei eingestellten 0V und
unbelastetem Ausgang den Einfluss des Reststroms durch den Transistor zu
beseitigen.

Wieso aber der 4k7-Widerstand bzw. die 4,25mA der Grund für die Lage der
Potis sein soll, kann ich nicht erkennen.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Interessanterweise findet sich in der ELRAD 3/78 eine fast identische 
Schaltung, allerdings sind der 5k-Trimmer und das 10k-Poti gerade 
vertauscht! Mit dem 5k-Trimmer findet also ein Abgleich des 
Maximalstroms statt.

Das geht so: Da an der Diode 0,6V abfallen, 1A an 0R5 aber nur 0,5V 
verusachen, muß der 5k-Trimmer bei voll aufgedrehtem 10k-Poti auf einen 
Widerstand von 2k eingestellt werden. Das teilt dann die 0,6V auf 0,5V 
herunter.

Den Trimmer braucht es, weil der Widerstand des Potis um bis zu +/-20% 
schwanken kann.

Kai Klaas

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ELRAD 3/78 eine fast identische Schaltung ...

Hallo Kai,

könntest du mir einen Scan von dem Schaltplan schicken oder hier 
anhängen?

Gruß
Helmut

Autor: Christian K. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Helmut S. schreibt:
>> ELRAD 3/78 eine fast identische Schaltung ...
>
> könntest du mir einen Scan von dem Schaltplan schicken oder hier
> anhängen?

Siehe Anhang.

Christian.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poti und Trimmer haben doch die gleiche Anordnung.
Wir sind also wieder beim Minimalstrom.  :)

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Poti und Trimmer haben doch die gleiche Anordnung.

Ja, genau! Aber nur im Schaltplan!! Auf der Platine sind sie gerade 
vertauscht!!!

Kai Klaas

Autor: Helmut S. (helmuts)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
>>Poti und Trimmer haben doch die gleiche Anordnung.
>
> Ja, genau! Aber nur im Schaltplan!! Auf der Platine sind sie gerade
> vertauscht!!!
>
> Kai Klaas

Na dann hat sich ja mein Anfangsverdacht erhärtet.
Die "Nachentwickler" haben abgezeichnet anstatt abzukupfern. :-)

Autor: Dr.PillePalle (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
mhh

um das jetzt mal zu beenden hab ich ne ollle Platine rausgesucht
Bj. 2000 und genau da hab ich denselben Fehler gemacht und nachher die 
Leiterbahnen umgefrickelt :-)

mhh hat recht ,Poti und Trimmer sind falsch eingezeichnet ,um den 
Max.Strom einzustellen muss das Poti an + und der Trimmer an die Diode

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schon lustig.  :)

Funktionell spielt es eigentlich keine Rolle.

Den einen stört eben das Aufleuchten der LED zur Anzeige des 
Stromregeleinsatzes beim Hochleiern des Spannung (die dann nicht weiter 
hochgeht) ohne Last am Netzteil, der andere möchte eben den Maximalstrom 
justieren. Kosmetik halt.

Autor: Dr.PillePalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was auch noch ganz lustig ist ist das es keine ZTK Zenerdioden mehr im 
Handel gibt und das Ding mit ner Normalen eine total abartige 
Temperaturdrift hat (It's not a bug ,it'S a feature ) ich weiss jetzt 
nur nicht mehr ob die Spannung rauf oder runter geht :-)) , wenn sie 
runter geht
wäre es ja ein Temperatur foldback ....
Es gibt aber noch Temperaturstabile Referenzdioden bei Reichelt ich 
glaub 1n27 oder so und die R's 1,2,3 sollten Metallfilm 1% sein

Autor: Dr.PillePalle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das waren die Dioden 1N821 - 1N829 , die hat Reichelt aber auch nicht 
mehr im Programm (im KAtalog 4/2009 sind sie noch drinn)

mfg

Autor: Kai Klaas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die entsprechenden Bildchen mal eingescannt.

Auch im Text ist von Abgleich des Maximalstroms die Rede.

Im Schaltplan ist übrigens noch ein Fehler: Der Ausgang sitzt natürlich 
an der falschen Stelle!

Kai Klaas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.